HardwareHeaven.com

HardwareHeaven.com

Looking for the skin chooser?
 
 
  • Home

  • Hardware reviews

  • Articles

  • News

  • Tools

  • Gaming at HardwareHeaven

  • Forums

 

Go Back   HardwareHeaven.com > Forums > Graphics Cards > AMD Graphics Cards


AMD Graphics Cards Discuss everything that is Radeon!

Reply
 
Thread Tools
Old Jul 31, 2009, 04:20 PM   #1
DriverHeaven Newbie
 
Join Date: Jul 2009
Posts: 1
Rep Power: 0
jahende is on a distinguished road

exclamation ATI Radeon Mobility x600 & Windows 7

Hello Everyone,

I have just discovered DriverHeaven and I'm loving it. The reason I went out searching in the first place is because of an issue I'm having. First off, my specs.

HP ZD8000 CTO Notebook
P4 3Ghz
ATI Radeon Mobility x600 (256Mb)

Everything worked great on XP, I upgraded to Windows 7... Worked good (Aero and all) for a couple of days then after reboot got "black screen". I figured my video driver needed updating. Went to HP website, no support in a nutshell. Only have the XP driver (that "black screens").

So, Last night I downloaded the latest Win7 32bit Catalyst 9.7 from ATI. Then downloaded the modder tool and followed the instructions specifically. Everything seemed to go well, then after reboot, I get a message stating that my drivers are not properly installed. I look in device manager and see that I have a ! next to Radeon x600.

Any suggestions? I'm at my wits end. Should I have downloaded a different Catalyst? Modified a file? Anything?

I appreciate your help in advance.
jahende is offline   Reply With Quote


Old Aug 16, 2009, 04:16 PM   #2
HardwareHeaven Junior Member
 
Join Date: Mar 2009
Location: Poland
Posts: 22
Rep Power: 0
PenrynHD is on a distinguished road

Re: ATI Radeon Mobility x600 & Windows 7

Remove drivers, clean Driver Sweeper and Install again.
__________________
[SIGPIC][/SIGPIC]
PenrynHD is offline   Reply With Quote
Old Sep 4, 2009, 01:18 PM   #3
DriverHeaven Newbie
 
Join Date: Sep 2009
Location: Australia
Posts: 1
Rep Power: 0
somemadcaaant is on a distinguished road

Re: ATI Radeon Mobility x600 & Windows 7

Did you end up getting this to work? I've tried on latest drivers 9.8 with out success. I have same card and laptop.
somemadcaaant is offline   Reply With Quote
Old Sep 4, 2009, 03:08 PM   #4
HH Assassin Guild Member
 
IvanV's Avatar
 
Join Date: Dec 2004
Posts: 7,747
Rep Power: 759
IvanV is godlike in his statusIvanV is godlike in his statusIvanV is godlike in his statusIvanV is godlike in his statusIvanV is godlike in his statusIvanV is godlike in his statusIvanV is godlike in his statusIvanV is godlike in his statusIvanV is godlike in his statusIvanV is godlike in his statusIvanV is godlike in his status
System Specs

Re: ATI Radeon Mobility x600 & Windows 7

Hello somemadcaant and welcome to DH.

I believe that the problem is that the Windows 7 drivers, as well as the latest Catalyst drivers in general, do not support the architecture on which your card was built. I think that your best chance is to download the Catalyst 9.3 for Windows Vista and try with those.
IvanV is online now   Reply With Quote
Old Sep 6, 2009, 10:48 AM   #5
DriverHeaven Newbie
 
Join Date: Sep 2009
Posts: 3
Rep Power: 0
garacs1 is on a distinguished road

Re: ATI Radeon Mobility x600 & Windows 7

Quote:
Originally Posted by IvanV View Post
Hello somemadcaant and welcome to DH.

I believe that the problem is that the Windows 7 drivers, as well as the latest Catalyst drivers in general, do not support the architecture on which your card was built. I think that your best chance is to download the Catalyst 9.3 for Windows Vista and try with those.
Hi guys, first post so don't shoot...

I basically have the same problem as the original poster, upgraded to W7 from WinXP PRO with x700 mobility graphic card on a L715 MSI laptop, and while under XP the drivers worked perfectly with the modding tool, I am having trouble with W7.

I am now installing the vista drivers instead of the W7 dedicated drivers, and will report if successfull.

Have any further suggestions?

Garacs1
garacs1 is offline   Reply With Quote
Old Sep 6, 2009, 11:40 AM   #6
DriverHeaven Newbie
 
Join Date: Sep 2009
Posts: 3
Rep Power: 0
garacs1 is on a distinguished road

Re: ATI Radeon Mobility x600 & Windows 7

Here I am again, finally with the correct video card drivers loaded.

I had to use the Vista drivers instead of the W7 ones, but finally device manager recognizes the video card and the laptop turns on without any issues (up to now...)

I downloaded the drivers for vista, ran mobilitymodder following the instructions precisely and installed the drivers, ince modified.

At the next reboot, I ran to device manager and the video ard was there!


Only problem, it appears that aero interface is not able to run...

have any suggestions?

Garacs1
garacs1 is offline   Reply With Quote
Old Sep 6, 2009, 12:17 PM   #7
DriverHeaven Newbie
 
Join Date: Sep 2009
Posts: 3
Rep Power: 0
garacs1 is on a distinguished road

Re: ATI Radeon Mobility x600 & Windows 7

ok last update for today: I used this guide:

Overclocking your laptop, Mobility Radeon

in order to make the modified drivers "signed", and restarting the laptop finally gave me a fully working vga driver, capable of running aero no problems!

Actually, running the "evaluate your pc" or something like that application (my OS is in german... can't remember the correct name sorry) at the moment it appears that the bottleneck is the cpu, a turion...

Well, at least the vga is working properly, now.

Thanks for the help (I did some simple search on the forum, and found the soltions myself, but thanks nevertheless).

Garacs1
garacs1 is offline   Reply With Quote
Reply

Thread Tools