3549 released - x86 and x64 - BETA

Discussion in 'General Discussion' started by Eugene Gavrilov, Aug 18, 2009.

  1. Eugene Gavrilov

    Eugene Gavrilov kX Project Lead Programmer and Coordinator

    hi guys! :)

    a new version is out, build 3549

    changes:

    * (an attempt) to fix problem with more than 2Gb of RAM
    * (an attempt) to fix 'beeping' problem with a2zsnb and similar
    (to enable 'beeping' fix: in kxctrl set 'extended options' hw param 15 bit 0x4000 (KX_HW_ALT_CHN_ALLOCATION))
    kxctrl -shw 15 0x4000
    --

    please test and report here: let me know if the issues are fixed

    no more changes in this release

    x86 version (Windows XP, Windows Vista, Windows 7): kxdrv3549-x86-full.exe
    x64 version (Windows XP, Windows Vista, Windows 7): kxdrv3549-x64-full-b.exe

    UPD: re-uploaded x64 driver

    E.
    Last edited: Sep 18, 2009
  2. sebaelcastor

    sebaelcastor New Member

    You're the man!! I've been waiting for this fix so much time, but the x64 installer has a broken file kxfxlib.kxl has 0 bytes, and the driver is not working.
  3. LordShade

    LordShade New Member

    kxdrv3549-x64-full-b.exe, windows 7 x64, 4GB RAM: Problem still exists :(
    kxdrv3549-x86-full.exe, windows 7 x86, 4GB RAM: Problem also still exists...
    But, kxdrv3549-x64-full-b.exe, windows vista rtm x64, 4GB RAM: works fine!
    Last edited: Aug 19, 2009
  4. konfuzion

    konfuzion New Member

    Signed-up today to thank Eugene! Thanks Thanks! :)

    Tested with Vista Ultimate SP2 x64 - 4GB - SB Live! Value CT4832 ;)

    So far, no problems encountered
  5. RPGWiZaRD

    RPGWiZaRD New Member

    I think I'll have to give it a try with 4x1GB in Win 7 x64 and XP 32bit just to see if it made any difference.

    EDIT: Nope, not working in Windows 7 x64, just no sound, tried playing around with buffer sizes as well.

    EDIT2: x86 version works fine in Win XP 32bit.

    So now it seems XP, Vista works fine, but not Windows 7. :(
    Last edited: Aug 19, 2009
  6. loosedway

    loosedway New Member

    Îòâåò: 3549 released - x86 and x64 - BETA

    Win7 64bit RAM 4GB, problem still exists...
    Live 5.1 PCI\VEN_1102&DEV_0002&REV_07
    Last edited: Aug 20, 2009
  7. Temragon

    Temragon New Member

    Indeed, it appears to continue to work in vista, but not 7. (Of course, it was working fine for me in xp and vista before, anyways)
  8. Eugene Gavrilov

    Eugene Gavrilov kX Project Lead Programmer and Coordinator

    Îòâåò: 3549 released - x86 and x64 - BETA

    get the debug log (here) and send me the physical addresses allocated by the driver whenever you start audio playback

    check if 'Master Mixer' and the other (Wave 2/3...) devices produce the same result

    E.
  9. liyang_ws

    liyang_ws New Member

    need for manual registration "kxfxlib",Otherwise "kx mixer" is impossible to run.
    After the driver installation,Or silent,Or noise!
    problem still exists
    windows 7 x64 4G ram
    sb live 4760 soundcard
    Last edited: Aug 20, 2009
  10. danube533

    danube533 New Member

    problem still exists...
    a2zsnb.....
  11. Daioh

    Daioh New Member

    I get a delay in front and rear speaker sounds when using the surrounder. (a quarter of a second or so) Strangely enough, it now plays double on the front speakers (so both normal and the quarter-second delay one) and there is no sound from the rear speakers. It is really annoying. Already tried changing the playback device to every other available Kx device to no avail. Strangely enough I was unable to make the sound play on my front speakers without changing 'swap front and rear speakers'. If I am not mistaken that should be possible when using one of the Wave Out outputs.

    <edit> it also started popping and cracking just now. </edit>

    <edit2> rebooting it three times apparently fixed the problem somehow... I hope the crackling doesn't show up again o_O </edit2>

    Using Vista x64 Business 2GB RAM with an Audigy2 ZS
    Last edited: Aug 20, 2009
  12. LordShade

    LordShade New Member

    WinXP 4GB, All works fine:
    Code:
    00000000	0.00000000	kx_wdm: waveout open[8988c008;88b16000]: open(freq=48000; n_channels=2[2]; bps=16; type:  Normal)	
    00000001	0.00061578	kx_wdm: waveout open[8988c008;88b0a000]: open(freq=44100; n_channels=2[2]; bps=16; type:  Normal)	
    00000002	0.11292567	kx_wdm: waveout open[8988c008;88b30000]: open(freq=44100; n_channels=2[2]; bps=16; type:  Normal)	
    00000003	0.11342566	kx_wdm: waveout open[8988c008;88b2a000]: open(freq=44100; n_channels=2[2]; bps=16; type:  Normal)	
    00000004	0.11966674	kx_wdm: waveout open[8988c008;88b93000]: open(freq=48000; n_channels=2[2]; bps=16; type:  Normal)	
    00000005	0.12021475	kx_wdm: waveout open[8988c008;88b87000]: open(freq=44100; n_channels=2[2]; bps=16; type:  Normal)	
    00000006	0.13158131	kx_wdm: waveout open[8988c008;88b87000]: open(freq=44100; n_channels=2[2]; bps=16; type:  Normal)	
    00000007	0.13216200	kx_wdm: waveout open[8988c008;88b81000]: open(freq=44100; n_channels=2[2]; bps=16; type:  Normal)	
    00000008	0.13268222	kx_wdm: waveout open[8988c008;88b7b000]: open(freq=44100; n_channels=2[2]; bps=16; type:  Normal)	
    Vista x64, All works fine:
    Code:
    00000000	0.00000000	kx_wdm: [CMiniportWaveOutStream::Init]: allocated buffer @FFFFF980120DC000, phys: 0:691000	
    00000001	0.00000761	kx_wdm: waveout open[5618490;36d4000]: open(freq=48000; n_channels=8[8]; bps=16; type:  Buffered)	
    00000002	0.00005636	kx_wdm: [CMiniportWaveOutStream::Open]: allocated buffer @FFFFFA80036DA000, phys: 0:5cda000	
    00000003	0.00023208	kx_wdm: [CMiniportWaveOutStream::Open]: allocated buffer @FFFFF98012136000, phys: 0:11f000	
    00000004	0.00039300	kx_wdm: [CMiniportWaveOutStream::Open]: allocated buffer @FFFFF98012139000, phys: 0:15f000	
    00000005	0.00055105	kx_wdm: [CMiniportWaveOutStream::Open]: allocated buffer @FFFFF9801213C000, phys: 0:162000	
    00000006	0.00071119	kx_wdm: [CMiniportWaveOutStream::Open]: allocated buffer @FFFFF9801214B000, phys: 0:165000	
    00000007	0.00087029	kx_wdm: [CMiniportWaveOutStream::Open]: allocated buffer @FFFFF9801213F000, phys: 0:168000	
    00000008	0.00103149	kx_wdm: [CMiniportWaveOutStream::Open]: allocated buffer @FFFFF9800FCA3000, phys: 0:16b000	
    00000009	0.00119289	kx_wdm: [CMiniportWaveOutStream::Open]: allocated buffer @FFFFF98012148000, phys: 0:16e000	
    00000010	12.31103039	kx_wdm: [CMiniportWaveOutStream::Init]: allocated buffer @FFFFF9801202A000, phys: 0:691000	
    
    Win7 x86, not work, tryed masermixer and waveoutputs:
    Code:
    00000000	0.00000000	kx_wdm: 	
    00000001	0.00000404	waveout open[869ef488;877c8000]: open(freq=48000; n_channels=8[8]; bps=16; type:  Buffered)	
    00000002	3.86638570	kx_wdm: 	
    00000003	3.86639023	waveout open[869f1838;877c8000]: open(freq=48000; n_channels=2[2]; bps=16; type:  Normal)	
    00000004	8.26627254	kx_wdm: 	
    00000005	8.26627731	waveout open[869f14b0;877c8000]: open(freq=48000; n_channels=2[2]; bps=16; type:  Normal)	
    00000006	11.72673321	kx_wdm: 	
    00000007	11.72673702	waveout open[869f2c80;877c8000]: open(freq=48000; n_channels=2[2]; bps=16; type:  Normal)	
    
    Win7 x64, not work, also mastermixer and waves:
    Code:
    00000000	0.00000000	kx_wdm: 	
    00000001	0.00000472	[CMiniportWaveOutStream::Init]: allocated buffer @FFFFF88009ECD000, phys: 0:df5d4000	
    00000002	0.00000943	kx_wdm: 	
    00000003	0.00001179	waveout open[5b25450;4375000]: open(freq=48000; n_channels=8[8]; bps=16; type:  Buffered)	
    00000004	0.00026374	kx_wdm: 	
    00000005	0.00026644	[CMiniportWaveOutStream::Open]: allocated buffer @FFFFF88009F27000, phys: 0:df692000	
    00000006	0.00026812	kx_wdm: 	
    00000007	0.00027014	!! [CMiniportWaveOutStream::Open]: physical address out of limits (0.df692000)	
    00000008	0.00057902	kx_wdm: 	
    00000009	0.00058138	[CMiniportWaveOutStream::Open]: allocated buffer @FFFFF88009F2A000, phys: 0:df68b000	
    00000010	0.00058340	kx_wdm: 	
    00000011	0.00058542	!! [CMiniportWaveOutStream::Open]: physical address out of limits (0.df68b000)	
    00000012	0.00089127	kx_wdm: 	
    00000013	0.00089362	[CMiniportWaveOutStream::Open]: allocated buffer @FFFFF88009F35000, phys: 0:df67f000	
    00000014	0.00089565	kx_wdm: 	
    00000015	0.00089733	!! [CMiniportWaveOutStream::Open]: physical address out of limits (0.df67f000)	
    00000016	0.00121362	kx_wdm: 	
    00000017	0.00121598	[CMiniportWaveOutStream::Open]: allocated buffer @FFFFF88009F38000, phys: 0:df67b000	
    00000018	0.00121800	kx_wdm: 	
    00000019	0.00122002	!! [CMiniportWaveOutStream::Open]: physical address out of limits (0.df67b000)	
    00000020	0.00156359	kx_wdm: 	
    00000021	0.00156629	[CMiniportWaveOutStream::Open]: allocated buffer @FFFFF88009F4A000, phys: 0:df674000	
    00000022	0.00156831	kx_wdm: 	
    00000023	0.00157033	!! [CMiniportWaveOutStream::Open]: physical address out of limits (0.df674000)	
    00000024	0.00187819	kx_wdm: 	
    00000025	0.00188055	[CMiniportWaveOutStream::Open]: allocated buffer @FFFFF88009F4D000, phys: 0:df66b000	
    00000026	0.00188257	kx_wdm: 	
    00000027	0.00188459	!! [CMiniportWaveOutStream::Open]: physical address out of limits (0.df66b000)	
    00000028	0.00219617	kx_wdm: 	
    00000029	0.00219853	[CMiniportWaveOutStream::Open]: allocated buffer @FFFFF88009F50000, phys: 0:df664000	
    00000030	0.00220055	kx_wdm: 	
    00000031	0.00220257	!! [CMiniportWaveOutStream::Open]: physical address out of limits (0.df664000)	
    00000032	0.00251481	kx_wdm: 	
    00000033	0.00251717	[CMiniportWaveOutStream::Open]: allocated buffer @FFFFF88009F53000, phys: 0:df65d000	
    00000034	0.00251919	kx_wdm: 	
    00000035	0.00252121	!! [CMiniportWaveOutStream::Open]: physical address out of limits (0.df65d000)	
    00000036	12.50758648	kx_wdm: 	
    00000037	12.50759220	[CMiniportWaveOutStream::Init]: allocated buffer @FFFFF88009ECD000, phys: 0:df5d4000	
    00000038	12.50759792	kx_wdm: 	
    00000039	12.50760078	waveout open[5b27ad0;3879000]: open(freq=48000; n_channels=2[2]; bps=16; type:  Normal)	
    00000040	12.50760174	kx_wdm: 	
    00000041	12.50760269	!! [CMiniportWaveOutStream::Open]: physical address out of limits (0.df5d4000)	
    00000042	18.09586143	kx_wdm: 	
    00000043	18.09586525	[CMiniportWaveOutStream::Init]: allocated buffer @FFFFF88009ECD000, phys: 0:df5d4000	
    00000044	18.09587097	kx_wdm: 	
    00000045	18.09587479	waveout open[5b27590;42c4000]: open(freq=48000; n_channels=2[2]; bps=16; type:  Normal)	
    00000046	18.09587479	kx_wdm: 	
    00000047	18.09587669	!! [CMiniportWaveOutStream::Open]: physical address out of limits (0.df5d4000)	
    00000048	22.12374306	kx_wdm: 	
    00000049	22.12374878	[CMiniportWaveOutStream::Init]: allocated buffer @FFFFF88009ECD000, phys: 0:df599000	
    00000050	22.12375259	kx_wdm: 	
    00000051	22.12375259	waveout open[5b273e0;42cf000]: open(freq=48000; n_channels=2[2]; bps=16; type:  Normal)	
    00000052	22.12375641	kx_wdm: 	
    00000053	22.12375832	!! [CMiniportWaveOutStream::Open]: physical address out of limits (0.df599000)	
    
    And strange, Left Channel of phones is playing, right - silent, also win7 x64:
    Code:
    00000000	0.00000000	kx_wdm: 	
    00000001	0.00000472	[CMiniportWaveOutStream::Init]: allocated buffer @FFFFF88009ECD000, phys: 0:df548000	
    00000002	0.00000909	kx_wdm: 	
    00000003	0.00001145	waveout open[5b25450;3959000]: open(freq=48000; n_channels=8[8]; bps=16; type:  Buffered)	
    00000004	0.00023949	kx_wdm: 	
    00000005	0.00024185	[CMiniportWaveOutStream::Open]: allocated buffer @FFFFFA800375B000, phys: 0:755b000	
    00000006	0.00056487	kx_wdm: 	
    00000007	0.00056723	[CMiniportWaveOutStream::Open]: allocated buffer @FFFFF88009F2D000, phys: 0:df60f000	
    00000008	0.00056925	kx_wdm: 	
    00000009	0.00057094	!! [CMiniportWaveOutStream::Open]: physical address out of limits (0.df60f000)	
    00000010	0.00091215	kx_wdm: 	
    00000011	0.00091451	[CMiniportWaveOutStream::Open]: allocated buffer @FFFFF88009F30000, phys: 0:df607000	
    00000012	0.00091653	kx_wdm: 	
    00000013	0.00091855	!! [CMiniportWaveOutStream::Open]: physical address out of limits (0.df607000)	
    00000014	0.00123349	kx_wdm: 	
    00000015	0.00123585	[CMiniportWaveOutStream::Open]: allocated buffer @FFFFF88009FBC000, phys: 0:df600000	
    00000016	0.00123787	kx_wdm: 	
    00000017	0.00123989	!! [CMiniportWaveOutStream::Open]: physical address out of limits (0.df600000)	
    00000018	0.00156090	kx_wdm: 	
    00000019	0.00156325	[CMiniportWaveOutStream::Open]: allocated buffer @FFFFF8800A057000, phys: 0:df5c6000	
    00000020	0.00156527	kx_wdm: 	
    00000021	0.00156730	!! [CMiniportWaveOutStream::Open]: physical address out of limits (0.df5c6000)	
    00000022	0.00192704	kx_wdm: 	
    00000023	0.00192939	[CMiniportWaveOutStream::Open]: allocated buffer @FFFFF8800A05A000, phys: 0:df5c3000	
    00000024	0.00193141	kx_wdm: 	
    00000025	0.00193344	!! [CMiniportWaveOutStream::Open]: physical address out of limits (0.df5c3000)	
    00000026	0.00227667	kx_wdm: 	
    00000027	0.00227903	[CMiniportWaveOutStream::Open]: allocated buffer @FFFFF8800A06C000, phys: 0:df5bc000	
    00000028	0.00228105	kx_wdm: 	
    00000029	0.00228307	!! [CMiniportWaveOutStream::Open]: physical address out of limits (0.df5bc000)	
    00000030	0.00261081	kx_wdm: 	
    00000031	0.00261317	[CMiniportWaveOutStream::Open]: allocated buffer @FFFFF8800A06F000, phys: 0:df5b5000	
    00000032	0.00261519	kx_wdm: 	
    00000033	0.00261721	!! [CMiniportWaveOutStream::Open]: physical address out of limits (0.df5b5000)	
    
  13. Temragon

    Temragon New Member

    7, x64, 8GB (No sound)
    First, trying to play with WMP, 2/3 set as default with src -> k1lt
    Code:
    kx_wdm: [CMiniportWaveOutStream::Init]: allocated buffer @FFFFF880080D0000, phys: 0:cfbe5000
    kx_wdm: waveout open[8723200;6a69000]: open(freq=48000; n_channels=2[2]; bps=16; type:  Normal)
    kx_wdm: !! [CMiniportWaveOutStream::Open]: physical address out of limits (0.cfbe5000)
    kx_wdm: [CMiniportWaveOutStream::Init]: allocated buffer @FFFFF880080D0000, phys: 0:cfbe5000
    kx_wdm: waveout open[8723200;6a69000]: open(freq=48000; n_channels=2[2]; bps=16; type:  Normal)
    kx_wdm: !! [CMiniportWaveOutStream::Open]: physical address out of limits (0.cfbe5000)
    
    Second, Opening playback control and setting to master mixer, this was spat out
    Code:
    kx_wdm: [CMiniportWaveOutStream::Init]: allocated buffer @FFFFF880080AF000, phys: 0:cfb79000
    kx_wdm: waveout open[8723200;75a5000]: open(freq=48000; n_channels=2[2]; bps=16; type:  Normal)
    kx_wdm: !! [CMiniportWaveOutStream::Open]: physical address out of limits (0.cfb79000)
    kx_wdm: !!! No minorTarget in wave::vol!
    kx_wdm: !!! No minorTarget in wave::vol!
    kx_wdm: !!! No minorTarget in wave::vol!
    kx_wdm: !!! No minorTarget in wave::vol!
    kx_wdm: !!! No minorTarget in wave::vol!
    kx_wdm: !!! No minorTarget in wave::vol!
    kx_wdm: !!! Get WaveOutVolume to 0 channel=0
    kx_wdm: Get WaveOut MUTE to 0 channel=0
    kx_wdm: !!! No minorTarget in wave::vol!
    kx_wdm: !!! No minorTarget in wave::vol!
    Third, trying to playback again, with master mixer set
    Code:
    kx_wdm: [CMiniportWaveOutStream::Init]: allocated buffer @FFFFF880080AF000, phys: 0:cfb79000
    kx_wdm: waveout open[7c8a290;75b9000]: open(freq=48000; n_channels=8[8]; bps=16; type:  Buffered)
    kx_wdm: [CMiniportWaveOutStream::Open]: allocated buffer @FFFFF88008186000, phys: 0:cfeb0000
    kx_wdm: !! [CMiniportWaveOutStream::Open]: physical address out of limits (0.cfeb0000)
    kx_wdm: [CMiniportWaveOutStream::Open]: allocated buffer @FFFFF8800818A000, phys: 0:cfea7000
    kx_wdm: !! [CMiniportWaveOutStream::Open]: physical address out of limits (0.cfea7000)
    kx_wdm: [CMiniportWaveOutStream::Open]: allocated buffer @FFFFF8800818E000, phys: 0:cfe8a000
    kx_wdm: !! [CMiniportWaveOutStream::Open]: physical address out of limits (0.cfe8a000)
    kx_wdm: [CMiniportWaveOutStream::Open]: allocated buffer @FFFFF880081A5000, phys: 0:cfe7d000
    kx_wdm: !! [CMiniportWaveOutStream::Open]: physical address out of limits (0.cfe7d000)
    kx_wdm: [CMiniportWaveOutStream::Open]: allocated buffer @FFFFF880081A9000, phys: 0:cfe72000
    kx_wdm: !! [CMiniportWaveOutStream::Open]: physical address out of limits (0.cfe72000)
    kx_wdm: [CMiniportWaveOutStream::Open]: allocated buffer @FFFFF880081AD000, phys: 0:cfe6a000
    kx_wdm: !! [CMiniportWaveOutStream::Open]: physical address out of limits (0.cfe6a000)
    kx_wdm: [CMiniportWaveOutStream::Open]: allocated buffer @FFFFF8800261D000, phys: 0:cfe5d000
    kx_wdm: !! [CMiniportWaveOutStream::Open]: physical address out of limits (0.cfe5d000)
    kx_wdm: [CMiniportWaveOutStream::Open]: allocated buffer @FFFFF88002621000, phys: 0:cfe53000
    kx_wdm: !! [CMiniportWaveOutStream::Open]: physical address out of limits (0.cfe53000)
    
    Vista x64, 8gb, master mixer (Works fine)
    Code:
    kx_wdm: waveout open[90917a0;71fe000]: open(freq=48000; n_channels=8[8]; bps=16; type:  Buffered)
    
    Last edited: Aug 21, 2009
  14. Trax

    Trax New Member

    Still doesn't work on Windows 7 rc1 x86 with 4gb of ram on SB 0228.
  15. thinhint

    thinhint New Member

    don't work with SB Audigy 2 0350 , Windows 7 X64 4GB RAM!!!!!
  16. krylko

    krylko New Member

    Re: Îòâåò: 3549 released - x86 and x64 - BETA

    First of all, thanks for your hard work, Eugene!

    SB0243 on Win 7 x64 RC1 4GB RAM here.

    <=3549 doesn't work. Clicking noise on Wave 2/3, no sound on Master Mixer and others... I won't whine, I know this one is not as easy to pin down. I'll try my best to help in fixing.

    Here's the output from DebugView:

    Code:
    HQ Intersection: client: 2ch/96000Hz/32Bps vs my: 2ch/96000Hz/32Bps
    kx_wdm: 
    [CMiniportWaveOutStream::Init]: allocated buffer @FFFFF8800A000000, phys: 0:cfd1b000
    kx_wdm: 
    waveout open[5b7c840;53b4000]: open(freq=48000; n_channels=2[2]; bps=16; type:  Normal)
    kx_wdm: 
    !! [CMiniportWaveOutStream::Open]: physical address out of limits (0.cfd1b000)
    KTM:  TmCommitTransaction for tx 5b57060
    KTM:  Notifying RM of 1 for tx 5b57060
    KTM:  TmPrepareTransaction for en 67e6490
    KTM:  Notifying RM of 16 for tx 73819a0
    KTM:  Notifying RM of 1 for tx 5b57060
    KTM:  TmPrepareTransaction for en 6cf1060
    KTM:  Notifying RM of 1 for tx 63e5740
    KTM:  Notifying RM of 16 for tx 63e5740
    KTM:  Notifying RM of 2 for tx 5b57060
    KTM:  TmPrepareTransaction for en 67e6490
    KTM:  Notifying RM of 2 for tx 73819a0
    KTM:  Notifying RM of 32 for tx 73819a0
    KTM:  Notifying RM of 2 for tx 5b57060
    KTM:  TmPrepareTransaction for en 6cf1060
    KTM:  Notifying RM of 2 for tx 63e5740
    KTM:  Notifying RM of 32 for tx 63e5740
    KTM:  Notifying RM of 2 for tx 5b57060
    KTM:  Notifying RM of 4 for tx 5b57060
    KTM:  TmCommitTransaction for tx 73819a0
    KTM:  Notifying RM of 4 for tx 73819a0
    KTM:  Notifying RM of 64 for tx 73819a0
    KTM:  TmRollbackEnlistment for tx 73819a0
    KTM:  TmRollbackEnlistment for tx 5b57060
    KTM:  TmRollbackTransaction for tx 73819a0
    KTM:  TmRollbackEnlistment for tx 73819a0
    KTM:  Notifying RM of 4 for tx 5b57060
    KTM:  TmCommitTransaction for tx 63e5740
    KTM:  Notifying RM of 4 for tx 63e5740
    KTM:  Notifying RM of 64 for tx 63e5740
    KTM:  TmRollbackEnlistment for tx 63e5740
    KTM:  TmRollbackEnlistment for tx 5b57060
    KTM:  TmRollbackTransaction for tx 63e5740
    KTM:  Notifying RM of 4 for tx 5b57060
    KTM:  TmRollbackEnlistment for tx 5b57060
    KTM:  TmRollbackEnlistment for tx 63e5740
    KTM:  TmRollbackTransaction for tx 5b57060
    KTM:  TmCommitTransaction for tx 73819a0
    KTM:  Notifying RM of 1 for tx 73819a0
    KTM:  TmPrepareTransaction for en 67e6490
    KTM:  Notifying RM of 16 for tx 4004950
    KTM:  Notifying RM of 1 for tx 73819a0
    KTM:  TmPrepareTransaction for en 57df060
    KTM:  Notifying RM of 1 for tx 63e5740
    KTM:  Notifying RM of 16 for tx 63e5740
    KTM:  Notifying RM of 2 for tx 73819a0
    KTM:  TmPrepareTransaction for en 67e6490
    KTM:  Notifying RM of 2 for tx 4004950
    KTM:  Notifying RM of 32 for tx 4004950
    KTM:  Notifying RM of 2 for tx 73819a0
    KTM:  TmPrepareTransaction for en 57df060
    KTM:  Notifying RM of 2 for tx 63e5740
    KTM:  Notifying RM of 32 for tx 63e5740
    KTM:  Notifying RM of 2 for tx 73819a0
    KTM:  Notifying RM of 4 for tx 73819a0
    KTM:  TmCommitTransaction for tx 4004950
    KTM:  Notifying RM of 4 for tx 4004950
    KTM:  Notifying RM of 64 for tx 4004950
    KTM:  TmRollbackEnlistment for tx 4004950
    KTM:  TmRollbackEnlistment for tx 73819a0
    KTM:  TmRollbackTransaction for tx 4004950
    KTM:  TmRollbackEnlistment for tx 4004950
    KTM:  Notifying RM of 4 for tx 73819a0
    KTM:  TmCommitTransaction for tx 63e5740
    KTM:  Notifying RM of 4 for tx 63e5740
    KTM:  Notifying RM of 64 for tx 63e5740
    KTM:  TmRollbackEnlistment for tx 63e5740
    KTM:  TmRollbackEnlistment for tx 73819a0
    KTM:  TmRollbackTransaction for tx 63e5740
    KTM:  Notifying RM of 4 for tx 73819a0
    KTM:  TmRollbackEnlistment for tx 73819a0
    KTM:  TmRollbackEnlistment for tx 63e5740
    KTM:  TmRollbackTransaction for tx 73819a0
    
    I hope this helps. If there's anything else I can do, please let me know. I'd like to see KX working on my machine so that I can finally turn off my on-board sound. Using Creative drivers is not an option :)
    Last edited: Aug 23, 2009
  17. mckil

    mckil New Member

    Thank you for update mr.E.
    It is work with sb0102 10k1[b800] on win7 x86.
    but i can hear tick sound often on play ac3 movie or mp3.
    It happens when SET mastermixer for output 5.1ch.
    other wave out sets are fine.(couldn't make sound 5.1ch)
    why it does? i hope you know why.
    anyway have nice day~

    (I couldn't write ENGLISH well. I'm sorry If I was rude.^^)
    Last edited: Aug 24, 2009
  18. coursing

    coursing New Member

    Rise your buffer size to 10ms
  19. akirabbq

    akirabbq New Member

    Win7 x64, 3GB RAM, nforce570 ultra + A64X2 5000 and CT4670, not working.
  20. wmjordan

    wmjordan kX Driver @ China

    Oh well.
    It is time to try an update.
    BTW, has this build fixed the 'increasing temporary files' problem?

Share This Page