3550 x64 probs with win7

Discussion in 'General Discussion' started by lustpain, Oct 22, 2009.

  1. lustpain

    lustpain New Member

    hi, someone maybe tell me
    i was x86 XP (4GB ram) with audigy 2zs and 3550 .. with working ASIO and everything
    i switch on the same machine to x64 win7 (6GB ram) and install 3550 for x64 .. but

    1, FL or other apps doesn't see KX ASIO (possible problem - my VSTplugins dir is in x86 program files but i install x64 kx drivers (but i locate vstplugins dir) ??) .. i can't open KX asio panel. (I see other have this problem too.)

    edit:
    Only way to see KX in FL is use Asio4All and witch it to KX in Asio4All panel

    2, kx manager look like this .. blank places? what the hell?
    [​IMG]

    and i use genius kl0210 multimedia keyboard and when i use volume up down i see only this .. no green and no movement .. and volume doesn't work for me
    [​IMG]

    can someone help me?

    i reinstall and install several times .. and i try x86 version of 3550


    thanks for any answer
    Last edited: Nov 20, 2009
  2. =MO=MaTriX

    =MO=MaTriX New Member

    same problem here!
    my kx manager looks the same and my spdif out is not really working, because i cant configure passthru.

    ive got an audigy 1 player, win 7 german version 64bit, 8gb ram
  3. Russ

    Russ New Member

    64 bit ASIO will not work with 32 bit applications.

    Other people have also mentioned this... it may be a bug, or maybe those things are not currently supported (by kX) with your OS (I do not know). Read the following bug report: http://www.driverheaven.net/bug-reports/190334-3550-vista-x64-kx-mixer-options-empty-bug.html
  4. RPGWiZaRD

    RPGWiZaRD New Member

    Yea I also have a blank list for ASIO in Win 7 64bit but I don't use ASIO anyways.
  5. Eugene Gavrilov

    Eugene Gavrilov kX Project Lead Programmer and Coordinator

    Îòâåò: 3550 x64 probs with win7

    ASIO: try to register it manually by opening command prompt with administrative privileges, then CD to your kX folder and type regsvr32 kxasio.dll
    Note that kX does only support 64-bit hosts in 64-bit mode, at least, now...

    SPDIF control empty: discussion in the thread mentioned above

    E.
  6. lustpain

    lustpain New Member

    will that "probs/bugs" solve by next release?
  7. lustpain

    lustpain New Member

    when i try to install x86 version .. its ERROR SELECTING DEVICE .. damn .. i'am so love in KX and i can't use it :)
  8. scarbies

    scarbies New Member

    I had the same issue. Had to setup my DSP like in attached pic. Still no volume sliders or anything though :(

    Main win7 volume works!

    Running O.L.D. soundblaster live value so wasnt expecting much

    Attached Files:

    • DSP.jpg
      DSP.jpg
      File size:
      70.9 KB
      Views:
      452
  9. weenerdog

    weenerdog New Member

    hey gang. i also have the problem of no asio control panel opening. win7-64/4G ram/SB0350 audigy2zs.

    things i have tried so far -
    1. manually registering kxasio.dll. regsvr32 reports success.
    2. adding a reg key to register the dll (right before kxmixer is loaded)
    3. deleting the reg key hkey_current_user\software\kx\ASIO per the discussion of (i think) 3538.

    maybe we can put our heads together and figure this out :)

    peace&love,
    weenerdog
    kx junkie, bluegrass musician, coffee-hound
  10. Russ

    Russ New Member

    You guys are trying to open the ASIO Control Panel from the kX menu (with any host applications closed), right?
  11. weenerdog

    weenerdog New Member

    wow thanks for the quick response. yes, no apps open. just trying to open the asio panel from the kx settings menu

    weenerdog
  12. Russ

    Russ New Member

    OK, just checking (so we can be sure that it is not a 64 bit kxasio/32 bit host issue (which was the issue with at least one person))...

    Did you register the DLL at an elevated privilege level (i.e. as admin)?

    I do not think it should make a difference here, but did you trying adding the kX 3550 folder to your system path?
  13. weenerdog

    weenerdog New Member

    i copied the kx .dlls to the \windows\system32 directory (didn't want to waste time piddling around trying to figure out adding a path with spaces in it to the PATH variable.
  14. weenerdog

    weenerdog New Member

    russ:

    i'll figure that out now and do it, just to eliminate a possibility
  15. Russ

    Russ New Member

    I doubt that is it.... In any case, spaces are not an issue if you do it from within the System Properties pages (i.e. here).

    Just append it (the full path, spaces and all (i.e. C:\Program Files\kX Audio Driver\3550)) to the end (preceded by a semi-colon) of the Path System variable.

    Aside from the above, I do not know why it would work for some people but not everyone, unless it is an issue with user rights (i.e. related to UAC or something similar), etc.
    Last edited: Oct 26, 2009
  16. weenerdog

    weenerdog New Member

    ok i gave all users full control of the \program files\kX Audio Driver\ directory, subdirectories, and files. no change.
  17. Russ

    Russ New Member

    There is a program here that shows all dll's that are registered with Windows. Maybe give it a try and see if it lists kxasio.dll, etc?

    I gave it a try and here is what it shows for me on Windows XP.

    I realize that you registered kxasio.dll and that it stated that it was successful, but maybe it is not taking for some reason (e.g. see kikkoman's post in the 3550 Released thread)? BTW: The above program can also register dll's, etc (though I do not know if it would give you any different results).
    Last edited: Oct 26, 2009
  18. weenerdog

    weenerdog New Member

    handy program. thanks. after a clean reboot, kxasio.dll appears to be registered & looks just like yours, as far as i can tell. at least we know its getting that far.

    i'll keep hammering on it. the fun is in the figgering out.
    if you have any insights, please share :)
    thanks again for all your help, man, and thanks to you all for kx
  19. weenerdog

    weenerdog New Member

    UPDATE - SUCCESS
    tried a couple more things with no success. so just for the fun of it, i installed reaper x64 and the asio control panel works like a charm from within reaper's audio settings dialog. so the problem wasn't so much broken ASIO after all. still cant reach it from the kx settings menu, but its kind of moot.

    thanks Russ!
  20. Russ

    Russ New Member

    Interesting... Well I am glad it is working for you :)
    I wonder why it is not working from the kX menu...

    In any case:
    @everyone else (who is using the 64 bit version of kX)
    Make sure you are using a 64 bit (x64) ASIO host. :lol:

Share This Page