ATI AGP Video Card Problems?

Discussion in 'AMD Graphics Cards' started by Dyre Straits, Nov 17, 2007.

  1. Dyre Straits

    Dyre Straits 9 Grandkids! #10 in the Oven!

    ***PLEASE! ONLY AGP USERS RESPOND!***

    As many of our members know, there's been a host of problems among users of AGP cards since around the release of Catalyst 7.7 and 7.8. Although this problem doesn't afflict all AGP users across the board, it's still a big problem and everyone concerned would like to get it fixed.

    If you're among the ones who have been hit with this trouble, please do the following:

    Post the Hardware ID of your particular graphics card. To get that information easily, just go to Device Manager and expand the Display Adapters section.

    Once done, double click on the Primary adapter.

    On the next screen, select the Details tab.

    In the Dropdown Menu beneath Property, select Hardware Ids. The next few lines are what we need you to initially post here.

    Once you've posted that information, also provide the Manufacturer of the video card, it's 'street name' (e.g. Radeon X1950 Pro), the amount and type of VRAM installed on it.

    Please ALSO state which version/s of Catalyst Drivers you've used and whether any of them have helped or not. We also need to know the OS you're using.

    ***PLEASE! ONLY AGP USERS RESPOND!***

    Thank you for your cooperation.

    If you have any further information you feel is needed, please be very brief or start a new thread with that information if you feel it isn't specific to our goal in this thread.
     
  2. Stop It

    Stop It HHs' Resident Kitty Lover

    Heya Dyre, I'll gladly contribute :)

    PCI\VEN_1002&DEV_7244&SUBSYS_317218BC&REV_00
    PCI\VEN_1002&DEV_7244&SUBSYS_317218BC
    PCI\VEN_1002&DEV_7244&CC_030000
    PCI\VEN_1002&DEV_7244&CC_0300

    Is my Hardware IDs, the card is a Gecube X1950XT AGP, the rest of my system is as per my specs on the left, I never tried the 7.8 Cats as I only bought my card a month ago, but I have not had a problem with the 7.9s, 7.10s or the current Crysis "Hotfix" driver (8.43).

    Hope that helps :)
     
  3. jhardy89

    jhardy89 New Member

    PCI\VEN_1002&DEV_9587&SUBSYS_00281002&REV_00
    PCI\VEN_1002&DEV_9587&SUBSYS_00281002
    PCI\VEN_1002&DEV_9587&CC_030000
    PCI\VEN_1002&DEV_9587&CC_0300

    Sapphire HD2600PRO 512MBDDR2 MEMORY AGP.

    At the moment, I'm running the default drivers which came with the installation CD (but only because no other drivers seem to work).

    If someone can tell me how to check which version they are, please tell me, and I'll be glad to do so.
     
  4. Dark Lord

    Dark Lord Well-Known Member

    PCI\VEN_1002&DEV_7244&SUBSYS_317218BC&REV_00
    PCI\VEN_1002&DEV_7244&SUBSYS_317218BC
    PCI\VEN_1002&DEV_7244&CC_030000
    PCI\VEN_1002&DEV_7244&CC_0300

    Gecube X1950xt 256meg

    [​IMG]

    windows XP SP2. useing 7.10s. last ones that worked for me were the 7.7s.
     
  5. Dyre Straits

    Dyre Straits 9 Grandkids! #10 in the Oven!

    @ jhardy89: Do your drivers come with CCC or not?
     
  6. RealityRipple

    RealityRipple Embrace Entropy

    Hardware ID:
    PCI\VEN\1002&DEV_9587&SUBSYS_00281545&REV_00
    PCI\VEN\1002&DEV_9587&SUBSYS_00281545
    PCI\VEN\1002&DEV_9587&&CC_030000
    PCI\VEN\1002&DEV_9587&&CC_0300

    Manufacturer: VisionTek
    Name: VisionTek Radeon HD 2600 PRO AGP

    Attempted drivers:
    Omega 3.8.360 through 3.8.421 - Direct3D works, but is terribly glitchy.
    ATI Catalyst 7.7 through 7.10 - Direct3D fails to initialize.
    VisionTek Supplied drivers (Catalyst with some mods) 7.9 and 7.10 - Direct3D fails to initialize.
     
    Last edited: Nov 19, 2007
  7. jhardy89

    jhardy89 New Member

    Yeah, they did.

    However, I've already managed to figure out which version of CCC I'm running (7.8).

    Any idea whether any previous Omega drivers or newer CCC's (excluding 7.10) will work for me?

    cheers.
     
  8. Dyre Straits

    Dyre Straits 9 Grandkids! #10 in the Oven!

    Many people are vouching for the CAT 6.12s. Or, if that one doesn't work well, the CAT 6.11s. (I wish Omegadriver hadn't changed his desigation numbers so we could more easily see which of his versions correspond witih the same CAT version. :( )
     
  9. Bart1987

    Bart1987 New Member

    PCI\VEN_1002&DEV_7280&SUBSYS_E190174B&REV_9A
    PCI\VEN_1002&DEV_7280&SUBSYS_E190174B
    PCI\VEN_1002&DEV_7280&CC_030000
    PCI\VEN_1002&DEV_7280&CC_0300

    Manufacturer: Sapphire Technologies
    Name: Sapphire Radeon X1950 Pro 512MB AGP
    Catalyst 7.10 (omega and normal) both worked a while but started getting errors with steam: "Internal driver error in IDirect3DDevice9::present()" after that dxdiag wouldn't complete anymore, switching to 7.7 and 7.6 didn't help after that, they just wouldn't work anymore. Had to reïnstall my windows and now I'm running with catalyst 7.10 and it's working fine. Used all drivers with CCC, cept for the omega
     
  10. DeKay

    DeKay New Member

    PCI\VEN_1002&DEV_9587&SUBSYS_00281462&REV_00
    PCI\VEN_1002&DEV_9587&SUBSYS_00281462
    PCI\VEN_1002&DEV_9587&CC_030000
    PCI\VEN_1002&DEV_9587&CC_0300

    The card is a MSI Radeon 2600PRO AGP with 256mb of ram, i've tried pretty much every catalyst driver i could use .... that meant adding the AGP version of the card to the .inf files (why did ATI remove the agp support for these cards in the latest catalysts??). If i get lucky and the games don't show any artifacts, the pc locks up after about 2 mins of 3d... i'm fed up with this, i had to replace an aging 9600XT which died 2 weeks ago, and i thought i'd give the new 2600pro a try, guess i was wrong...
    ati please prove me wrong and that i did a good choice with this card, give us some good drivers please :x

    --- edit : i'm using windows xp sp2 (i previously had Vista installed and it didn't work well so i thought Vista was the reason for it not working so i reverted to XP... waste of time though :/)
     
  11. Fr4nk3nst41n

    Fr4nk3nst41n New Member

    PCI\VEN_1002&DEV_94C4&SUBSYS_002818BC&REV_00
    PCI\VEN_1002&DEV_94C4&SUBSYS_002818BC
    PCI\VEN_1002&DEV_94C4&CC_030000
    PCI\VEN_1002&DEV_94C4&CC_0300

    Gecube HD 2400 PRO 256MB

    currently using Gecube´s 7.10 version (regular catalyst wont install)
    windows xp

    original cd drivers drivers has caused my computer to crash on startup

    current omega drivers solved the startup crash issue but the sistem was unstable.
     
    Last edited: Nov 23, 2007
  12. dreadnum

    dreadnum New Member

    PCI\VEN_1002&DEV_9586&SUBSYS_0028174B&REV_00
    PCI\VEN_1002&DEV_9586&SUBSYS_0028174B
    PCI\VEN_1002&DEV_9586&CC_030000
    PCI\VEN_1002&DEV_9586&CC_0300


    Manufacturer : Sapphire Technologies

    Name : HD 2600 XT AGP, 256MB of VRAM

    I use Omega drivers based on 7.10 on XP, but no drivers available on VIsta

    Thanks
     
  13. PCI\VEN_1002&DEV_9587&SUBSYS_00281002&REV_00
    PCI\VEN_1002&DEV_9587&SUBSYS_00281002
    PCI\VEN_1002&DEV_9587&CC_030000
    PCI\VEN_1002&DEV_9587&CC_0300

    Sapphire
    HD 2600 PRO (AGP)
    512 mb ram (DDR2)
    Windows XP (SP2)

    I have tried different Catalyst versions without any luck (I am not sure how to check the current version I am running sorry). Annoying thing though: At one time, some week ago I could run Medal of honor airborne and Crysis without problems. But I updated drivers, windows, Catalyst etc... and now... PROBLEMS.
    I can't for the life of me remember which drivers I had installed when it all worked fine.
    I also updated my directx to latest version (dx 9.0c). It didn't do me any good at all.

    On a sidenote: Crysis support said that the problem was known to them and that I should await a patch for the game in early december. I just ask myself why? Crysis DID run properly some week ago?

    Any thoughts on this appreciated.
    Thanks
     
    Last edited: Dec 3, 2007
  14. DeKay

    DeKay New Member

    any news regarding these issues? :(
     
  15. Solution (maybe)

    Ok I got Crysis running again (for my spec. see above post) What I did was:

    ¤ Updated BIOS to the latest possible.
    ¤ Checked windows update and installed/updated all NET framework things (which wouldn't install before).

    I then started Crysis without Catalyst installed at all, and it worked. Of course the graphics wasn't great but I was no longer in a grey fog anymore so something was going right.

    Next on my agenda is to find a Catalyst version that will let it self be installed on my system (CCC-Crysis hotfix would not). I expect/hope (pray) that this will improve graphics. I will post on development.

    I really, Really urge you all to check the two items above and continue from there. If you do this and find better ways to get things working, let us all know.

    /Håkan
     
    Last edited: Dec 20, 2007
  16. Tried Catalyst that came with the card (CCC 7.8) without sucess. Earlier I tried 7.11 and Crysisfix versions of Catalyst, neither worked. Anyone who got ANY Catalyst to work with Crysis at all?
     
  17. schrafsch

    schrafsch New Member

    PCI\VEN_1002&DEV_9587&SUBSYS_00281787&REV_00
    PCI\VEN_1002&DEV_9587&SUBSYS_00281787
    PCI\VEN_1002&DEV_9587&CC_030000
    PCI\VEN_1002&DEV_9587&CC_0300

    Powercolor HD 2600 Pro, AGP, 512MB
     
    Last edited: Dec 23, 2007
  18. narcussist

    narcussist New Member

    PCI\VEN_1002&DEV_9587&SUBSYS_00281002&REV_00
    PCI\VEN_1002&DEV_9587&SUBSYS_00281002
    PCI\VEN_1002&DEV_9587&CC_030000
    PCI\VEN_1002&DEV_9587&CC_0300



    Motherboard: Matsonic MS8147C
    CPU:AMD Athlon XP 2600
    RAM (tell us the number of sticks and if you´re using different brands): Generic 1GB 3 sticks same brand
    Video Card: Sapphire ATI Radeon HD 2600PRO -AGP : 8x 128MB Apeture (never said I was good at spelling)
    0
    PSU (Yes, in fourth place.) Detailed specs of the three main rails are a MUST! (...or at least the Brand & Model):Cheifmax 550w 12v-30A
    Monitor (connection used):Cornerstone Color 21/75 fp
    Hard drives: Maxtor 250GB : Seagate 200GB
    Optical Drives:none
    Additional PCI cards: Cmedia Sound Card 5.1
    Number of fans present: 6 total

    Video Card Drivers in Use (Control Panel or Catalyst Control Center?):
    ATI RADEON™ HD 2400Pro/2600Pro/2600XT(AGP Only!) Windows XP(32/64-bit)(multilanguage)
    XP_8.42-070914a-053413E-ATI

    Operating System: Windows XP home SP2 updated completely.

    These are the only Drivers I can get to work on my card. Direct3D test always fails for me. No games will load. I just installed this card 12-14-07, and went threw a ton of tries at trying different drivers, from 7.7 to 7.11 and no luck. Drivers from CD only crashed my system, other divers would only say.


    Here we go: (for what all I have done so far)

    I just got this card, before I bought I was reading and did see that the drivers that came with the disk did not work so I went and pre-downloaded the drivers. The driver I mentioned above is the only one I can get to work, so I am hoping that is all the drivers in one. After I installed that I tried to update the drivers on the drivers page with the ones that were newer than the
    ATI RADEON™ HD 2400Pro/2600Pro/2600XT(AGP Only!) Windows XP(32/64-bit)(multilanguage)
    XP_8.42-070914a-053413E-ATI
    but I had no luck as I always got the
    Notify >> (something )!=3 or something like that >> Failed to install (0xton of numbers and letters)

    So ok, I figured it was ok, and thats where my driver situation is stuck.

    Now I try to play the games that made me buy this card, COD4, NFS-PS. No Luck.

    COD4 will flick the start screen for about 1/2 a second then nothing. NFS-PS will start to load then flicker the screen a ton of times, like it is trying to refresh, then crash back out to desktop.

    I figured I would try to play some of my old games that I know work. NFS-C, NFS-MW, Tony Hawk Pro-Skater2 (old game I know), these wont even load either.

    The card I just got done replacing was a Nvidia GeForce 5500FX 256MB. everything worked fine before the swap. The last ATI card I used was the Radeon 3200 32mb back in like 2002, and I had nothing but a head ache then. So coming back to an ATI card was kind of worrying me, and now I know why.

    Another problem I am having is when in the analog connector, I do not get the bios screen, if I want to see the bios screen I have to hook up my tv to the card or use the HDMI - Analog adaptor and run from the HDMI slot. Which I might just have to go back to doing, but I do not like to use adaptors, because of the signal loss.


    After every try at the drivers I have used the "Driver Cleaner Pro" from guru, just to make sure I had no traces or the driver left behind.

    if anyone has any luck please inform us so we know how to be able to use this card.
     
  19. Blad31k

    Blad31k New Member

    PCI\VEN_1002&DEV_7244&SUBSYS_317218BC&REV_00
    PCI\VEN_1002&DEV_7244&SUBSYS_317218BC
    PCI\VEN_1002&DEV_7244&CC_030000
    PCI\VEN_1002&DEV_7244&CC_0300



    Hi, Ive got a

    ATI Radeon X1950XT AGP 256MB (GeCube's X Series some get this confused with the XTX) but its just they way Gecube and branded the name.


    System:

    CPU: intel P4 HT 2.8ghz OC at 3.3ghz but now de-clocked until these issue's are resolved.

    RAM: DDR 400 XMS CORSAIR 2GByte TwinX for Dual Channel

    MB: P4C800-E Deluxe
    OS: Windows XP Pro with Service Pack 2 (SP2)
    PSU: 700W EZcool Super Silent

    Im currently running the 8.43 basically Catalyst 7.11 fixed version for Crysis and im getting all these Blue/Yellow Artifacts and also all these lines on my screen. At first i thought this was just with Crysis as i know there are all sorts of bugs that need weeding out. So i installed Need For Speed Most Wanted and i as getting the exact same Problem. When I play Guildwars it seems fine as this game is not quite as graphically demanding as the others.

    Ive Tried the 7.9, 7.10, 7.11 ATI's, 7.10 omega, DNA 5.0.01 ATI, Gecubes Drivers. Ive done the procedure of un-installing the driver restarting in safe mode running driver cleaner pro and then re-booting and installing the new driver for each driver ive tried and still no improvements. This was such a frustrating process and with no better results i just don't know what to do. I spend all this cash and yet the main purpose of me buying this card was to be able to run these games but can't due to ATI not creating a decent driver. I think i know what my colour's are going to be next time.

    It would be interesting to buy a top Nvidia AGP card and see what the result of that would be.

    I just hope i can fix this problem is it something im doing wrong, ive even tried re-applying the Direct X 9.0c. :sigh:
     
    Last edited: Dec 16, 2007
  20. narcussist

    narcussist New Member

    [SOLVED] ATI AGP Problems

    1. Click on Start, then Control Panel, then go to Add/Remove Programs.
    2. At the top of the list you should see several ATI entries. Select the entry entitled ATI Software Uninstall Utility, and click Change/Remove.
    3. You will be prompted to restart your system once the uninstall is complete.
    4. Once restarted, check the Add/Remove Programs list again for any remaining ATI software or other drivers that you have tried.
    5. If any ATI software is still listed, click Change/Remove on those entries to uninstall each one individually.
    6. Next, please scroll through the list until you find an entry called DAO
    7. Select DAO, then Click Change/Remove to uninstall this program.

    1.Go to link below - Double-click on the downloaded driver file. Click Run
    Use the default directory for extracting the files and press the Install button.

    XP Catalyst 7.7
    http://ati.amd.com/support/drivers/x...-cat77-xp.html

    2. Click Next on the first install screen.
    3. Click Yes to the License agreement.
    4. Click the Custom button.
    5. Select the driver, catalyst control center and uncheck the box for steam
    # The installer will start to load the display driver first.
    Next you will see the WDM Capture drivers load (for VIVO or All-In-Wonder).
    The Catalyst Control Center setup will start shortly after.
    A dialog box will indicate the install progress.

    6.Click Finish to restart your computer.

    If it still doesn't work continue below
    7.Device manager=> have disk
    8.Select the Driver location which should be C:\ATI\Driver Folder\Driver
     

Share This Page