ATI mobility FireGL 9000 - opengl?

Discussion in 'AMD Graphics Cards' started by Agger, Apr 11, 2005.

  1. Agger

    Agger New Member

    Help: Mobility FireGL 9000 - OpenGL problems++

    I uninstalled all ati drivers. restarted, then installed omega drivers succesfully, then restarted.

    Everything seemed to work, but no opengl support..

    Tried to launch the game Riddick (who have big problems with IBM ati drivers), the game said that it needs openg gl 1,3 to run. (a 5 year old GF2TI runs it better)

    I launched OpenGL extension viewer, and I saw that its used GDI Generic.

    With the IBM drivers, it has 100% support from 1,0 to 1,3. and 98% of 1.4, and 2/3 of 1.5.

    When using IBM ati drivers, the renderer/vendor is set to ATI.

    with omegas, or modded catalyst drivers. is says:

    Vendor: Microsoft
    Renderer: GDI Generic
    Version: 1.1.0

    When I look at the ICD driver it says:

    ATI Technologies Inc.
    ATI OpenGL driver
    6.14.10.4898
    C:\WINDOWS\system32\atioglxx.dll

    When I had IBM's ati drivers, it was two lines with some dll, cant remember what that was tho.

    Would be great to use omegas or modded catalyst drivers.

    My system:

    IBM T40p - 2373-g5g
    1,6ghz centrino
    gfx: ati mobility FIREGL 9000 - 64MB
    1GB ddr memory
    win-xp-pro sp2


    is it any hope? :confused:

    What should I do?
    Last edited: Apr 12, 2005
  2. Agger

    Agger New Member

    Monitor resolution

    My default resolution is 1400x1050 (max)
    Something weird happend.. after installing/uninstalling drivers.

    When I try to change the resolution, or when games is trying to set lower resolution for the game, it rezise the whole screen, so that the visual screen is getting smaller, with black egdes arround.

    It doesn't resize itself to the egdes of the screen.. weird..
    This image illustrate it's look when 1024x768 res.

    [​IMG]

    When setting back to 1400x1050 the screen goes to all egdes.

    Tried both the IBM and omegas drivers.

    Will be thankfull for help :)
  3. Agger

    Agger New Member

    Along the way

    The resolution problem was a BIOS setting.
    It stood to THINKPAD LCD. (who should be ok?)
    I changed it to default VGA. and resolutions lower than 1400x1050 was possible wihtout making them small.

    The other problem with OPENGL.
    When installing IBM's ATI drivers, it adds a second opengl dll. named atioglgl.dll who is: ATI FGL OpenGL driver (version 6.14.10.4901)

    and it also add's the standard: ATI OpenGL driver (6.14.10.4901)

    What omega and catalyst dont do is adding the atioglgl.dll..

    Shouldn't OPENGL work wihtout, only using the standard opengl driver?.. weird or logical?

    Anyone who can think of something.. ?

    If I could force it to use the standard opengl driver. or maby add use of the ATI FGL OpenGL driver.. is that possible?

    would be great to get better performance using modded catalyst or omegas drivers.
    Last edited: Apr 12, 2005
  4. patje

    patje Former Mobility Modman

    Hi Agger,

    This is a know issue to me, and i'm still looking into a way to make it work (if possible)
    It must have something to do with the second openGl file.

    when i'm back at the office next week i'll try to have another look at it
  5. Korben

    Korben New Member

    Fragment Shader on ATI FIREGL 9000 (IBM T40p)

    I'have exactly the same problem. I also have an IBM T40p and have to use fragment shader. It doesn't work with the officiel IBM drivers. I uninstalled them and install the last omegadrivers but it doesn't work. I have the same probleme of resolution and, most important, I still can use Fragment shader (GL_ARB_FRAGMENT_PROGRAMM) and Vertex Shader. What should I do?
    Thanks
  6. burnheart

    burnheart New Member

    I had exacly the same problem with my AmiloPRO7010 and IGP Radeon9000 and Catalyst 5.4 drivers. After install in Viewer I used to get :

    Vendor: Microsoft
    Renderer: GDI Generic
    Version: 1.1.0

    so the OpenGL was not installed at all (strange...).

    I managed to solve it :))).

    The thing is you CANNOT use patje's mode tool. It causes the problem and you don't need it honestly (sorry patje).

    All you have to do is force windows to install the original catalyst drivers (without 'no inf file' error message).

    Here's what you do:
    Unistall all the old drivers with driverCleaner. Then choose your graphics card and 'update driver option' then choose your own .inf file location (not the directory, point to the FILE itself).
    Windows will then warn you that the driver may not work with the system at all (that's why XP won't accept it in automatic search).

    Pay no attention to this and force XP to install the driver 0 choose your device form the list. It DOES install without any error messages.

    Then you're done. OpenGL works great and smoother than ever before.

    AT LEAST THIS WORKED IN MY CASE but I believe it will work in yours as well.

    Good LucK!
    Burnheart
  7. patje

    patje Former Mobility Modman

    Hi Burnheart! and welcome to DH
    First post and already a contribution, impressive!

    Well the suggested way will indeed work, but not on all cards. The 9000/9100 IGP series are supported by the standard catalyst suite. at least the desktop variant is. So yes you can force the installation this way. The modtool will just doesn't provide the correct info. That is something I need to find out, and this will help. Thanks for that!

Share This Page