Desktop Icon positions will not "save" on re-boot

Discussion in 'AMD Graphics Cards' started by jimshu1, May 14, 2007.

  1. jimshu1

    jimshu1 New Member

    I have been installing new verions of OMEGA drivers on top of older versions for some time for my ATI RADEON 9800 PRO AGP 8X 256MB DDR 256 BIT video card.

    This morning, I decided to do a clean uninstall of the drivers using the built in uninstall and running DH Video Driver Cleaner Pro. I uninstalled all ATI drivers.

    I then installed the Radeon Omega Driver v3.8.291 (6.9), which I've used for some time. Everything went well and the driver works great. When I re-booted my system, I found all of my desktop icons clustered to one side. I re-positioned them and later re-booted to find them clustered again.

    I checked some Registry setting, such as:


    Still can't get them to save their positions on re-boot. Any suggestions.

    Thanks for any replies!
  2. Dyre Straits

    Dyre Straits 9 Grandkids! #10 in the Oven!

    When you right click on the Desktop, you get a Popup Menu with an option to "Arrange Icons By....."

    What settings are you using for that?
  3. ChaosMinionX

    ChaosMinionX USB 3 dot oh

    You wouldnt happen to be using any shutdown/startup tweaks for faster shutdown/startup sometimes they disable the computer from saving new settings to shutdown faster....Long shot, but could be.
  4. jimshu1

    jimshu1 New Member

    Dyre Straits, I do not have "Auto Arrange" checked. I have checked "Align to Grid" and "Show Desktop Icons". Nothing has changed here.

    ChaosMinionX, No new tweaks, and I have never used any except for changing from 5000 to 6000 the following timeout because ZoneAlarm needed a little more time. I've run with this one for 6 months, so I don't think it is it.

    [HKEY_CURRENT_USER\Control Panel\Desktop]

    Thanks for the suggestions/questions!
  5. jimshu1

    jimshu1 New Member

    I've even tried a Kelly's Korner tweak on saving user setting on WinXP shutdown. No joy.

    Windows Registry Editor Version 5.00




    "BagMRU Size"=dword:00001f40

    "BagMRU Size"=dword:00001f40
  6. jimshu1

    jimshu1 New Member

    OK, I've taken this on as a "Quest"

    For you Registry experts:

    I'm looking at Registry key:


    "ItemPos1280x800(1)" (or whatever resolution) shows no values on the problem system. It contains lots of hex values on a healthy one.

    Something is wrong with savings on exit.

    "ColInfo" is the same.

    Any suggestions on where to post for this problem? I'm sure this isn't the right forum, but I am going to try unstalling and re-installing the driver.

    After searching the Internet for a few days, this isn't a unique problem!

    Thanks again for all of the relies!
  7. jimshu1

    jimshu1 New Member

    OK, I got it fixed. I did two things:

    1) I ran sfc /purgecache, sfc /cachesize=100, and sfc /scanonce, after pointing it to where it looks for Windows files on my optical drive containing WinXP Pro SP2 (I normally delete files in my dllcache folder to save disk space).

    2) I imported the "ItemPos1280x1024(1)"=hex:00,00,00,00,00,00,00,00,........... string value from a working User account into HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell\Bags\1\Desktop of the problem User account and then hit F5 and the icons stayed in position!!!! I had previously tried manually creating "ItemPos1280x1024(1)" string value, but it just disappeared on re-boot. This time I just ran an exported .reg file from a working User account for the Desktop key. I compared all values before and after and there are no other changes except for "ItemPos1280x1024(1)". The other difference was I presed F5 before re-booting. I became hopeful when the icons stayed in position after F5, and I believe it updated the "ItemPos1280x1024(1)" hex values to my current User layout.

    I'm not sure which did the trick, but I'm leaning towards the sfc /scanonce.

    Anyway, I think my week long "quest" has ended. Thanks for the replies!
  8. Dyre Straits

    Dyre Straits 9 Grandkids! #10 in the Oven!

    Good to know and thanks for posting what cured the problem.

  9. jimshu1

    jimshu1 New Member

    Just updated my Omega drivers and ran into this same problem again. I always do a very thorough uninstall, so maybe that is causing my problem.

    Anyway, I solved my problem quickly, and in a different fashion than what I had posted above. Just updating my original post in case someone else runs into this problem and does a search.


    Allow the desktop icons to group anyway they want. Right click on desktop and choose “Arrange Icons By > Auto Arrange”. Re-boot system. Try to move a desktop icon, it should pop back due to the auto arrange option being “on”. Now turn the Auto Arrange option off (uncheck). Move a desktop icon (it will now stay) and then hit F5. This will save the icon position to the Registry at:

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell\Bags\1\Desktop] in a binary value named "ItemPos1680x1050(1)".

    Arrange the deskop icons in your preferred layout and hit F5 again. This should modify the above value. Re-boot and your desktop icon layout should be restored.
  10. Dyre Straits

    Dyre Straits 9 Grandkids! #10 in the Oven!

    Thanks again for the update and the fix for this problem.

    As you stated, this could be a result of doing a full uninstall of previous drivers. Omegadriver states in his 'readme' that it's not necessary to uninstall previous drivers. Simply run the installer and answer, "YES" to any prompt to overwrite existing files.

    Even personnel from ATI/AMD have stated that the installer for the official drivers is designed to do a full update of drivers without having to uninstall anything. This is how I've done it for years and I've rarely ever come across problems of this extent. It does seem that I run into more problems when I have done a complete uninstall.
  11. eyesonly

    eyesonly New Member

    sfc /purgecache to restore icon position saving

    Just wanted to let others that may find this thread know that I also had no saving of the icon positions on reboot. I did "sfc /purgecache" and rebooted and then they stayed in the correct position. So of the things you tried I would have to say sfc /purgecache is the one that works.

Share This Page