Echo or Reverb for Microphone Input?

Discussion in 'General Discussion' started by civic5zigen, Dec 15, 2002.

  1. civic5zigen

    civic5zigen New Member

    Hi, how do I make the input from Mirophone to be echo and reverb so it'll mix well with the audio? And only apply the reverb or echo effects to Min in and not the audios. I need to do this becuase I am trying to build an Karaoke machine, and currently the sound from Mirophone have no echo or reverb effects and sound very bad.

    I try looking into the DSP graph but I have no idea what to do, can someone help?
    Or is there an easiler to way to apply fx to min in only?

    Also, I need to hook two mic into my computer, so can I convert the Line-in to be same as Mic-In, and have the same echo fx and the boost? How do it do it?

    Thanks so much
  2. Max M.

    Max M. h/h member-shmember

    The simplest way is to connect prolog pin 0/1 (this is where mic-in comes from) to "xsumm_r" inputs 0/1 (inl/inr).
    Then you can adjust mic reverb send by "Reverb" fader at mixer's "FX" page... yep... something like that.
  3. civic5zigen

    civic5zigen New Member

    THanks Max M. I tried what u suggest but the sound from my mic still the same when I tune up all the setting in the FX window of the Mixer. Here what I did, am I doing something wrong?

    This is my default setting.
    [​IMG]

    I simply connect the "Line2/Mic2 Left In8" and "Line2/Mic2 Right In9" to the Inl and inr of the xsumm_r(enabled). Is this how I shoud do it cuz it didn't work??? Also when I do this the original connection from FXBus will now be disconnect from xsumm_r, is this normal?

    [​IMG]

    Also, I want to echo the microphone input only, cuz if I echo the whole thing the music will sound funny. Thanks again for the help
  4. Max M.

    Max M. h/h member-shmember

    >http://12.230.111.103:8080/jacktou/web_temp/kxdsp_2.gif

    Yep that's correct (btw. you did not mention mic2 before ;)

    Should work... So:

    1. Did you hear the mic itself (without "echo")?.... e.g. did you unmuted and adjusted it at mixer's "ins'n'outs" page?

    2. Did you adjusted "Wave Send" at mixer "fx" page
    (this is amount of reverb added to mic (for that ñfg))

    >Also, I want to echo the microphone input only,

    Yes, the effect is applied only to mic and midi synth in such configuration (e.g. inputs connected to xsumm_r), waves/mp3s are not affected at all...
  5. civic5zigen

    civic5zigen New Member

    1. yea, I guess it says Line2/Mic2 on the DSP graph, what's the different? I didnt see any Mic1.

    2. I didn't see any "Wave send" under FX, here's my FX page...

    [​IMG]

    3. No sound when Mic2 is enabled (unmute) under "Ins 'n' Outs".
    However, there's sound from microphone when enabling the Mic & mic Boost under AC97

    [​IMG]


    4. When disconnect the "Line2/Mic2" both LEFT and Right to the routing in DSP graph, I can still hear shound, infact, when I disconnect all the connection from prolong to routing, I can still hear music and also sound from mic. So for some strange reason, the Prolong's Line2/Mic2 doesn't effect anything.

    HELP.....
  6. Eugene Gavrilov

    Eugene Gavrilov kX Project Lead Programmer and Coordinator

    you should NOT enable mic on the 'ac97' page
    it should be enabled only in Digital Only Mode
    otherwise, you should only select 'mic' as your 'ac97 source' and keep the ac97 mic slider muted
    [the 'boost' button will still work]

    /Eugene
  7. civic5zigen

    civic5zigen New Member

    Thanks Eugene, but the only way for me to get any sounds at all from the Mirophone is to enable (unmute) the Mic in "AC97". If I check "Boost", select "Mic" as AC97 source, and then enable (unmute) Mic2 in "Ins 'n' Outs" I'll still get no sound from Mirophone at all.

    Addiontially, if I disconnect all connection between prolong and routing I can still hear music and sound from the mic as if prolong have noting to do with the mic at all.

    I double check the connection at the back of the card and Front speaker are plug into "Out2" and Rear are plug into "Out1" since I have KX swap front and rear channel. Then Mic is connect to Micrpohone.

    I reset the setting couple of times and start from all over but same result. Can someone give me an clue what am I doing wrong?

    THanks
  8. Dr_bologna

    Dr_bologna bolog

  9. civic5zigen

    civic5zigen New Member

    O men, that's overkill for me, I ain't that professional. I simply want to have reverb or echo effects on the microphone channel so it'll mix well together with the back ground music for Karaokes. I know it can be done with the driver, but I just can't get it to work anyhow.
  10. Dr_bologna

    Dr_bologna bolog

    I run my Guitar through my muti effex rack then into my sound card Via line in jack..
    I always have monitoring comming back through speakers with line in enabled and level turned up of course..
    But if i'm running " lets say" WaveLab 4.0 I will not get any action through it untill I go into the cards setup and turn on line in on the Recording section of the Soundcard mixer..
    Your Mic or line in is enabled in the recording section as well right ?
  11. Max M.

    Max M. h/h member-shmember

    civic5zigen

    Btw, man, you lost in microphones...

    Let's start from the beginning...

    "Mic" and "Mic2" are differrent things... the first is the input
    on the back of the card and the second is the input on LiveDrive ("platinum" model)...

    Look at my first reply - it said "prolog pin 0/1 (this is where mic-in comes from)" not "prolog Line2/Mic2 Left In8/9"... After that i've started to think that you want to record livedrive's microphone...

    Ok, so, now...

    1. replug you main speakers into black output ("rear") of the card - this is the main ("front") output in kX by default (see help and site for the reason). This is "must be done first" after kx is installed...

    2. Never unmute "mic" fader at "ac97" mixer page...
    Yes, this will "monitor" mic through green output but this does not send mic signal into dsp (and then mic cannot be recorded or processsed)

    To let mic1's sound to come from prolog 0/1 (again: 0/1) you should do only two things:

    a. Set "mic" as the source at "ac97" mixer page (in pulldown list with "?" above it)

    b. Unmute and adjust "Ac97" at "Ins'n'Outs" page.
    ---

    3. After all that just do all i sayd before...
    (e.g. "The simplest way is to connect prolog pin 0/1 (this is where mic-in comes from) to "xsumm_r" inputs 0/1 (inl/inr).
    Then you can adjust mic reverb send by "Reverb" fader at mixer's "FX" page... yep... something like that.")

    And... read, please, kxhelp "ac97" section...
    Last edited: Dec 17, 2002
  12. Max M.

    Max M. h/h member-shmember

    and more:

    >2. I didn't see any "Wave send" under FX, here's my FX page...

    The first fader is reverb "wave send"... See my first reply
    (i said "reverb")

    >So for some strange reason, the Prolong's Line2/Mic2 doesn't effect anything.

    Why do you think it should affect anything at all?
    It affects nothing but Mic2/Line2 input of LiveDrive..
    What the thing made you to bother with that Mic2 at all?

    And again reread my and Eugene replies carefully... do exactly like they said.
    Last edited: Dec 17, 2002
  13. s3n71nel

    s3n71nel New Member

    I have a few additional tips for u civic5zigen.
    I was doing a similar thing, except I was plugging my guitar into my live drive mic2 input.
    1)if u have a live drive don't use your headphones because the reverb doesnt go to the headphones, only the speakers.
    2)in kxDsp right click the 'reverb lite' hit tweak and turn up the ER/LR up full to give you a more noticeable reverb that u can dial in at the mixer fx screen.
    It should work for u if u follow all the directions on this page. :)


    I have a question:
    Can anyone tell me why the chorus effect goes to the headphones but the reverb doesn't? :hmm:
    Im using kx version 3528 with SB Live 5.1 platinum.

    cya ;)

    s3n71nel

    (edit:actually my second tip would give way too much reverb with the above suggested setup so forget about turning ER/LR up full but tweak it how u like.)
    Last edited: Dec 17, 2002
  14. civic5zigen

    civic5zigen New Member

    Thank guys, I couldn't have done this without the great support. Especially big thanks for Max. You are the man. I think my problem is forgot to umute and tune up "AC97" under "Ins 'n' outs". That's why I couldn't hear anything even when I've unmute mic under "ins 'n' outs" and also select mic as "AC97?" sources.

    Many thanks again for Max.

Share This Page