1. The Dark Forum Skin... It's ALIVE!!!!!

Gameport driver or a way to get rid of the gameport device?

Discussion in 'General Discussion' started by Shaamaan, Nov 8, 2012.

  1. Shaamaan

    Shaamaan New Member

    I'm a perfectionist, so the gameport device in the device manager is driving me crazy. I don't need it, I have no controllers which would use it, but it sticks out as the only device without a functioning driver. Also, Devices and Printers throws off warnings because of this.

    I'm using the latest kX drivers for my Audigy 2 card (SB0240) on Windows 7 x64. I found and old post on this forum related to the gameport but it's OOOOLD, and probably related to Windows XP where the gameport was still supported. Anyway, on my system the kX drivers couldn't handle that gameport device.

    So... is there anything that can be done? I'm basically looking for some way to get that device to behave and fall in line - it doesn't really have to WORK work (I don't have any controllers which could actually use it).

    PS. Just disabling the device still makes it stick out and still throws off warnings in the Devices and Printers panel... >_<
    Last edited: Nov 8, 2012
  2. Russ

    Russ New Member

    Try the Gameport support pack for Vista 32-bit. Someone in the Creative forum said that they were able to install it on Windows 7 x64.

    i.e. (from here)
    I do not know if it will actually work, but if the above is accurate it should do what you want.

    I think the links in the CL forum no longer work, but this site appears to have the files currently in their downloads section.
  3. mkk

    mkk Well-Known Member

    Or take it from someone who for many years also used to be a perfectionist, leave it be. It does not matter to the system in any way and it's not worth spending time on. Put it to disabled so that the system doesn't look for drivers for the thing that it will never find.

    I know it's not easy, but it's for the best in the long run. Save the time for things that really matter. :)
  4. Shaamaan

    Shaamaan New Member

    I'll check out what Russ suggested, and if that doesn't work I'll be forced to live with it, as you said mkk.
  5. Toff

    Toff New Member

    No need to try an x86 driver when there's an x64 one. I got it from some Creative web driver update a long time ago, no idea which one. I packed the folder with all the drivers (since I'm lazy to figure out which of those files belong to gameport specifically), you can get it here:

    dl.dropbox.com/u/80396093/Gameport.rar

    Just unpack it and let Windows search for drivers for your gameport driver in that folder automatically, there's no need to do it manually even. Your system will install the driver for you. The driver is dated as 2003 but it's digitally signed by Creative. No idea if it really works, but at least the system reports it is, and no more unknown devices. Works fine even on Win8 x64. :)
    Last edited: Nov 16, 2012
  6. imperia

    imperia Active Member

    Using windows 7 x64:
  7. Toff

    Toff New Member

    Was that with the drivers I posted? You're not trying to install it through Setup.exe, are you? Because you must not. I updated the archive now, removed Setup.exe and other files that might confuse people. Once again, installation must be performed through Device Manager only.
    Last edited: Nov 16, 2012
  8. imperia

    imperia Active Member

    I was trying with Device Manager only. But later I used ctzap to remove the driver, which removed kxdriver. Doh!
  9. Toff

    Toff New Member

    Are you sure you've been telling Windows to auto-search in the driver folder instead of manually selecting the .inf? And that you have Audigy 2 (SB0240)?
    Because it installs perfectly fine for me.
  10. imperia

    imperia Active Member

    I think I can't select .inf file - only folder. I've got Audigy 2 ZS Platinum. Gameport should be the same. Is your windows x64?
  11. Toff

    Toff New Member

    Sure, I'm using x64.

    Actually, the SUBSYS of that Gameport device might be different for the ZS. Open your Device Manager, go to that Gameport unknown device and check its Hardware ID string:

    ft.trillian.im/7a848a916f0e80902ef357449c3eae2131f067e7/6cfoSL83Ltg2pDcGdWeNUztCMZyfv.jpg

    It must look exactly as in the picture, that is:

    PCI\VEN_1102&DEV_7003&SUBSYS_00601102

    This is the only string that's present in the driver I posted. The driver will not install if this Device ID is any different. If yours is not the same I'd say it's worth a try downloading Creative's latest driver web update from their website, unpack it and let Windows search those files.
  12. imperia

    imperia Active Member

    The SUBSYS is 00401102. I will try to find that creative driver pack.
  13. Toff

    Toff New Member

    Ah, so there's the problem. You can also try to manually change Device ID string in the driver to the one you have by editing ctgame2k.inf, but this might make the driver lose its digital signature. Worth a try nevertheless if you can't find the proper driver for your device.
  14. imperia

    imperia Active Member

    Ok. Thanks. I will try to modify the .inf file.
  15. flood404

    flood404 New Member

    I have the driver for the gameport.

    Since Im a new member I can't post a link. But I can e-mail it instead.



    All you need to do is download this zip from your e-mail and unzip it to the desktop.

    Then go to device manager and click on your game port. Which was listed as PCI input device on my pc. Go to the driver tab. Click on update driver.

    Then click on Browse my computer for driver software.

    Then click on
    Let me pick from a list of device drivers on my computer.

    Click on have disk.

    Then click on browse and locate the file named on your desktop.
    ctgame2k.inf then click on Open. Then click OK.

    Then click on the Creative Game Port then click next.

    The driver is not signed but it works just fine. If you get an driver is not signed warning just click on allow unsigned driver for this device.

    You should have a successfully installed a Creative game port driver. Then close and you should have no more unknown game port or pci input device.


    This driver covers Windows XP 32bit 64bit, Vista 32bit and 64bit and windows 7 32bit and 64bit and windows 8 64bit. But windows 8 32bit should work too.


    There isn't a way to disable this device on the sound card itself unless you bought an SB350 card which does not have a game port. It also does not support the LIVE DRIVE device too. Its a slimmed down version.

    Report back if you have issues.
  16. Space Cowboy

    Space Cowboy New Member

    Would you please email me the driver? I have my account set so you should be just email it to me from here.

    Thank you


  17. Reelbox

    Reelbox New Member

    Helo,
    I would appreciate to receive this driver also. Problem is win7 and old creative SB card, so I am missing the gameport for my Forcefeedback Wheel and Joystick.
    (Gameport_Vista)
    Email: rkanhaeusser@t-online.de
    Thanks a lot.
    Regards Reelbox
  18. flood404

    flood404 New Member

    To whoever Gergely is your e-mail is not valid I keep getting mailer daemon failures. I can't mail you through Hardwareheaven either since you do not have that option enabled.

    I tried sending the link and instructions to you.
  19. flyer0738

    flyer0738 New Member

    Hi.

    Could you, please, send me the driver to my email?

    flyer0738@gmail.com

    I have the same problem as most of you: A gameport suporting a Joke not supported on Windows 7.

    Thanks and regards.
  20. Carbonic

    Carbonic New Member

    Glad I found this. I'm yet another person with an old Audigy card and a missing game port driver in Win7 x64. Same SUBSYS as imperia. I'd love it if you could e-mail me that file flood 404! I've set up my profile here so that you should be able to e-mail me that way. Thank you!

Share This Page