1. The Dark Forum Skin... It's ALIVE!!!!!

mic detection problem - rosetta stone

Discussion in 'General Discussion' started by ldy, Aug 5, 2008.

  1. ldy

    ldy New Member

    First off, thanks so much for kx :) I use it for asio recording with my old audigy 2 zs card, and it works like a charm.

    Now for the problem: I recently installed Rosetta Stone, and it won't recognize my microphone. Mind you, the mic itself works just fine, it's only that Rosetta doesn't recognize it. I've tried changing the settings every which way but loose (and yes, I've tried this: kX Project: Knowledgebase: kX Getting Started Guide - Microphone Setup), but nothing helps.

    Anyone have any words of wisdom? Thanks in advance for the help :)
  2. Doug W

    Doug W New Member

    Assuming that you are not using a USB type mic and you are using a dynamic mic or at least one that plugs into your MIC input on your Audigy 2 ZS - is that right?

    Do you use any custom DSPs or just the default kX mixer setup?

  3. ldy

    ldy New Member

    That is correct-- I am using a dynamic mic that plugs into my front mic/line-in input. And I'm just using the default dsp setup.

    For further elucidation, I'm using an SB0350 and driver ver 5.10.0.3537 (I haven't bothered updating the driver since 37 worked very well for me-- though I'll be feeling pretty sheepish if this is something that was addressed in a recent upgrade or the newest beta).
  4. Doug W

    Doug W New Member

    I don't think that an SB0350 with 3537 should be a problem. When I used 3534f with my Audigy 2 ZS it recognized it as a generic Audigy and worked properly.

    I would suggest making a custom DSP. I don't use the standard kX mixer anymore-too many sliders for me to keep track of.

    Download ProFX for 3537 from here:
    ProFx Version 3.x

    Read up on it here:
    Quick kX DSP Guide (by Lex Nahumury)

    Here is another example of a custom DSP you could create:
    http://webpages.charter.net/drw46/examples/kx-rec-profx.jpg
  5. dj_stick

    dj_stick Apple Fanboy? Staff Member

    i have no idea what "Rosetta Stone" is, but if it requires wndows mixer functionality, it probably won't work, as kX does not really use the windows mixer
  6. Russ

    Russ New Member

    Can you explain the above?

    i.e.
    When you say the MIC works, what do you mean?
    Have you tried recording from the MIC use MME (as opposed to ASIO)?
    i.e.
    Using Sound Recorder?

    If the above works then most programs that want to use the MIC should work. As far as the Windows Mixer goes, the main issue there is that if the program wants to control the volume of the MIC using Windows Mixer, it will not be able to, but it should still work anyway.

    If you cannot record the MIC use MME, then kX is probably not configured correctly, or the wrong device is set as the default for recording in the Windows Control Panel.

    As for Rosetta Stone not recognizing the MIC, what do you mean?
    Do you just mean that it does not work? Generally programs are not looking specifically for a MIC, but rather which driver to use to get input from the MIC, so when you say it does not recognize the MIC, I am not quite sure what you mean.

    In any case, make sure that you have kX configured correctly to record from the MIC using MME, and that Rosetta Stone and/or the Windows Control panel has kX Wave 0/1 set as the default for Recording (and probably Voice Recording as well). Since you are using the MIC jack at the front, then you would need to follow a different procedure to record then what is in the Getting Started Guide (the setup in the guide is for the MIC input on the rear of the card).

    To record from the MIC on the front, I think you only need to unmute the Line2/Mic2 slider on the Recording page of kxmixer, and set the volume to 0 dB. Also make sure that the Master Recording level is set to 100.
  7. ldy

    ldy New Member

    Yuppers. Works just fine.

    I mean that the program gives me a big ugly screen that says "microphone not detected." Apparently, this one does specifically look for a mic. Who knew?

    I have kx wave 0/1 set as default, the program just won't acknowledge it exists.

    Thanks for the reply, though :)


    I'm going to give Doug W's DSP settings a try in a little while. I'll let you all know how it turns out.

    Thanks for the advice, folks-- I really do appreciate it!
  8. Maddogg6

    Maddogg6 Tail Razer

    I would assume rosetta stone would use a mic for voice recognition, much like Skype may be configured to use mic sliders to auto adjust mic record volume - but can't determine what windows mixer slider to 'auto adjust' - MSN messenger has a similar problem if I recall correctly (grayed out mic volume slider in its audio setup).

    Not that I have any idea how to fix it, but maybe these ideas would give others something to consider.. ??
  9. Russ

    Russ New Member

    If you want try Doug W"s DSP config, and your MIC is connected to the drive bay, then you will probably need to replace ADC with a SRC plugin set to Line2/Mic2 In.

    In any case, I do not see how that config would help the program detect a MIC (not that it is a bad config, it is just not going to anything different then the other configs, as far as your software goes).

    What OS are you using?

    @Maddogg6, I do not have MSN Messenger, but Windows Messenger works with the MIC for me (I would think that they both use same stuff for MIC setup).
  10. Maddogg6

    Maddogg6 Tail Razer

    Run the Audio setup wizzard - when it gets to testing the mic - theres a grayed slider, no? there is for me - and I dont have MSN anymore either, but recall a echo cancellation option that would be grayed out as well some where, either when running a wizard, or in an options screen. (*looking*) maybe its now an option in step 1 of the audio setup wizard in Windows Live Messenger: "Click here if you are using headphones. Note: If you are hearing echo, uncheck this box" And while I can un-check it - I still hear my speakers echoing into my mic. But I swear I seen a version that called it echo cancellation, and was a grayed box with kX, but not with CL/or MS drivers.

    I have a feeling the OP's issue is related to this need to adjust mic recording levels by the host software... but I *have* been wrong before. Just trying to be helpful, sorry if I am not :D
  11. ldy

    ldy New Member

    Haha, took me a few minutes to figure that out, but I finally came to the same conclusion!

    I also had to move the WinMM recording out on k2lt from 8 to 7, for reasons I cannot fathom. I chalked it up to dsp gremlins of some sort and moved on.

    Apparently, you are correct. I did manage to get profx working with sound recorder, but no luck with rosetta stone.

    Here's the actual error message, just for shiggles:
    Microphone Setup

    There has been an error.

    No microphones have been found on your computer. Please attach one and try again, or disable speech to move on.
    WinXP pro.
  12. Russ

    Russ New Member

    @Maddogg6,
    Windows Messenger has the same type of setup. The slider it is not grayed out for me, it just cannot adjust the volume level (which is OK, because it can still be done in kxmixer, it just cannot be done automatically).

    @Idy
    I do not know, I have not seen such a thing myself as of yet. I wonder what the MIC detection thing is really looking for... There are no advanced setup screens or anything, where you can skip the detection stuff?
  13. ldy

    ldy New Member

    I have managed to bypass it by turning speech recognition off, then turning it on again.

    However, this small victory was short-lived-- there is no sound coming from the app whatsoever, and I'm guessing it's not recording sound, either. :(
  14. ldy

    ldy New Member

    OK, upon testing, the app works fine with a usb headset. As much as I'd like to MAKE it work with kx, I think the easiest fix is to just buy a usb headset.

    If anyone thinks of a nice fix, I'd love to hear it... in the meantime, I'm going to suck it up and go hit amazon now :)

    Thanks so much for the help, guys-- I've always been impressed with both the level of technical expertise and the generosity of this forum's posters, and today I'm even moreso. Good travels to you all.
  15. peate

    peate Active Member

    Just out of curiosity, have you tried the rear mic input? Maybe Rosetta Stone is looking for an AC97 mic, like it would for built-in sound. That's what worked for me with Messenger anyways.
  16. miro85

    miro85 New Member

    Problem SOLVED

    I have finally found a solution! I found it by chance on the rosetta stone troubleshooting page. I have nod 3 antivirus + firewall and in the firewall settings the rosetta stone application was blocked (it was denied internet access). I just deleted it from the list and the next time rosetta stone asked for internet access I clicked yes. Now rosetta stone detects both my dynamic microphone and my usb headset and it works fine. Hope this works for everybody.
    Russ likes this.
  17. reggepole

    reggepole New Member

    I am very glad to be a part of this forums. And I am even gladder that I can thank miro85 who solved not only his/her problem but my one too.
  18. Shaamaan

    Shaamaan New Member

    Re: Problem SOLVED

    Doesn't work in my case; I've allowed Rosetta access from the very start, yet it still does not detect any microphones.

    EDIT: I've also tried renaming (as suggested in another thread) the recording device so that it contains the word "microphone" in it; it still doesn't work. :(
    Last edited: Sep 28, 2009
  19. amatisea

    amatisea New Member

    Another solution ^_^

    I've been having the same problems with Rosetta Stone - It was fine with my previous microphone but that was accidently broken so I bought a new microphone (Logitech usb one). And it would not detect it. I've found a slightly annoying solution where if I plug my old microphone into the pink slot and have my main speakers as default it would show both microphones in the list.

    Hope this helps other people who come across this problem ^_^.
  20. ADX1

    ADX1 New Member

    I found that it took so many tries to get Rosetta Stone to recognize my microphone successfully. I thought it was a hardware failure so did google search trying to find the problem. In the end, it was that I was not speaking loud enough into the microphone. Once I did this, the microphone is recognized on every try.

Share This Page