1. The Dark Forum Skin... It's ALIVE!!!!!

Mic won't stop playing through speakers

Discussion in 'General Discussion' started by ShadowDrake, Apr 26, 2009.

  1. ShadowDrake

    ShadowDrake New Member

    Hey, I've got a Live 5.1 and I'm on Windows 7, build 7100 (RC1!)

    I installed the latest version of the kx driver, which is uhhh... 3545b.

    Sound plays great, and following the primary mic guide, I was able to get my mic working. The only thing I ever use it for is Ventrilo.

    Well, the sound that plays through the mic also continually plays through my speakers - I can't get it to stop. Resetting the AC'97 settings has it stop, but as soon as I choose Mic from the dropdown, it plays through the speakers again... even if the mic is muted.

    So:

    In's and Outs:
    All sliders along the bottom muted

    Recording:
    AC97 set to 0, unmuted
    All others at -inf + muted

    AC97:
    Mic chosen from dropdown, mic gain set to 0, mic boost checked.
    All others at defaults, inf + muted, gain is at 0, not muted.

    Again, once I select Mic from the dropdown in AC97, any sound the mic picks up comes through the speakers and won't stop till I reset the AC97 settings.

    What am I missing? I've checked a few threads for reference but nothing has worked...

    http://www.driverheaven.net/general-discussion/102348-i-can-hear-myself-through-mic.html
    http://www.driverheaven.net/general-discussion/82651-help-muting-myself-poor-quality-ts.html

    etc...
  2. Russ

    Russ New Member

    What do you mean by "mic gain"? If you mean the "Mic In" slider on the AC97 page of kxmixer, it should be muted.
  3. ShadowDrake

    ShadowDrake New Member

    Ah, yeah, sorry. That's what I meant.

    I can have it muted, and I will still hear the mic through the speakers. It starts playing through the speakers as soon as I choose Mic from the dropdown... even if everything else is set to default.
  4. Russ

    Russ New Member

    Well there is only 2 things in kX that would cause the MIC to play in the speakers (assuming default DSP config):
    1) The above slider.
    2) The AC97 slider on the Ins and Outs page.

    Make sure both are muted.
    If that does not work, try Resetting AC97 (button on AC97 page) and redo the config.

    Beyond that, double-check settings in Ventrillo (make sure that monitoring is not enabled).

    Windows 7 is not really supported... Although I do not think that is related to your issue, it is a possibility.
  5. ShadowDrake

    ShadowDrake New Member

    Well based on that, I narrowed it down a little bit. If either the AC97 slider on Ins and Outs is not muted, or the mic isn't muted on the AC97 page, it will play through the speakers.

    Sounds like it's just an issue with Win7 for now, alrighty, thanks! I really appreciate the work you guys do :D
  6. Russ

    Russ New Member

    Right, both sliders should be muted (unless you want to hear it in your speakers). This is normal.
  7. ShadowDrake

    ShadowDrake New Member

    Well if that's the case, can I get it to play through ventrilo without it playing back through the speakers?
  8. Russ

    Russ New Member

    Neither of those sliders are needed for WinMM recording, so...
  9. Kilau

    Kilau New Member

    In Windows 7 I also had the same problem. The mic was always open and playing back through the speakers. In Windows XP the solution was easy you simply opened the playback sliders and muted the microphone.

    In Windows 7 it took me a while to find the settings to fix this. At first I thought the sliders were completely gone but I did finally find them.

    Here is how to stop your mic from playing back though the speakers in Windows 7.

    Control Panel
    Hardware and Sound
    Sound (the heading)
    Click on "Speakers" (or whatever your playback device is called)
    Click the "Properties" button near the bottom
    Select the "Levels" (the sliders for playback will appear)
    Scroll down to the "Microphone" slider
    Click the "Mute" button so the litttle "NO" sign appears (red circle with a line though it)

    That should solve your problem.

    Good Luck
    ~Kilau

Share This Page