Mobility Radeon X700 Drivers - Vista

Discussion in 'Mobility Modder Discussion' started by hackwoodg, May 13, 2007.

  1. hackwoodg

    hackwoodg New Member

    I have just installed Vista Ultimate 32bit on my laptop which has the ATi Mobility Radeon X700 in it.

    I can't get the drivers anywhere and when I use the workaround on this site I get the following error message:

    'Failed to find any installable components!'

    Please, any idea's??
  2. Spike

    Spike Driver Cleaner Maker Staff Member

    Have you followed the steps on the site where you download it exactly?

    did oyu also try updating the driver through the device manager and pointing it to the modified driver?
  3. hackwoodg

    hackwoodg New Member

    Hi

    I followed the site definitely.

    Did not try pointing device manager though, will try that now.
  4. hackwoodg

    hackwoodg New Member

    No didn't work.

    Got the message that Windows feels the current driver is up to date!!!

    This is so frustrating.
  5. kipusoep

    kipusoep New Member

    Got the same problem, although the modtool works and the ati install manager installs the drivers, but when the screen goes flickering it stays black and then I get a hard reboot... :(
  6. Spike

    Spike Driver Cleaner Maker Staff Member

    It is still strange that by most people it works and by some not and they have the same mobility chipset. I am thinking it has to do with the motherboard chipset if that has real vista drivers or not. Have you tried installing the latest vista drivers for your motherboard chipset?
  7. kipusoep

    kipusoep New Member

    Nope, where could I find those?
  8. Snurk

    Snurk New Member

    Same problem here.. :(
    Got a ASUS A6Va with the ATI Radeon Mobility x700 (vista 32bit)

    (BIOS is updated to: A6VAAS.212)
  9. peXounet

    peXounet New Member

    I also have an A6VA from Asus, and a X700, and a black screen after flickering. At reboot, I have strange white lines on the black screen. I have a similar problem when installing fglrx on Linux ... (if it helps ...)

    EDIT : Of course I have followed the steps and the ModTools have worked (it install the driver)
  10. Oberyn

    Oberyn New Member

    So i'm not the only one having problems...
    I've got an a Asus W2Vb with X700 mobility installed. Using Modded Drivers makes NT Kernel / System use 100% CPU time when running the 3D Renderer (games & co.).
    That makes the CPU overheat in a random time...At the beginning I thought it was a DX problem, then an ATI issue more afterwards a Blizzard (i play wow) code mistake.
    Reading here I realized it could be a problem with the newer ModTool.

    The OLD modder with ATI Catalyst 7.2 (the last it supported) didn't give problems, not even under Vista.

    EDIT: Nvm i'm still testing. I've just seen I didn't have Intel inf update utility for Vista installed
    EDIT2: Ok, tested with no success. I fear it's the modder...Is it possible to have the old one for a test?
    Last edited: Aug 10, 2007
  11. Spike

    Spike Driver Cleaner Maker Staff Member

    The old modtool does not support vista. Overheating and such can't be caused by the new mod tool.

    Are you running xp or vista. Make sure that all drivers are updated to the newest you can get.
  12. gwen5484

    gwen5484 New Member

    I have the same problem (Acer Aspire 5024 Wlmi) ... did you find a solution ?
  13. bushwhacker

    bushwhacker New Member

    MSI M635 (1029) w ATI X700 graphics

    Installed Vista 32 bit Business without incident. Works fine w. the MS driver for the X700 provided during the install.
    Modded the 7-12_vista32_dd_ccc_wdm_enu_55816.exe with DH Mobility Modder.net tool successfully and installed driver ONLY.

    When booting with both A/C and battery:
    Runs fine until the A/C is removed (battery in & charged) - display freezes on current screen, mouse moves and seems functional, keyboard seems functional ( ie. keystrokes can be used to shutdown properly) - the display shows no functionality.

    When booting with just battery:
    Black display w. cursor visible when GUI starts. Can see cursor change when Welcome screen login box is found on the black display. Boots into Vista w. black display only. Keystrokes work to shutdown.

    Rolling back to MS driver restores functionality and Device Manager is indicating the following for the X700:

    Driver Provider: ATI Technologies Inc.
    Driver Date: 8/21/2006
    Driver Version: 7.14.10.830
    Driver Signer: microsoft windows

    other Laptop Details:
    BIOS v2.5
    2GB DDR400
    AMD Turion 64 MT37 (2.0 GHz)
    Seagate Momentus 7200.1 80GB
    Last edited: Jan 2, 2008
  14. Anoyz

    Anoyz New Member

    got same problem!
    Acer aspire 5510, with vista business.
    The laptop just shuts down instantly... I had to uninstall the drivers, and I'm working like that for months... :S can't find solution.

Share This Page