PAX Drivers for Soundblaster X-FI Surround 5.1 Pro USB (SBX1095)

Discussion in 'PAX Download - USB Series' started by opcode_x64, Jul 21, 2015.

  1. opcode_x64

    opcode_x64 New Member

    Joined:
    Jul 21, 2015
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Hello everybody,

    I am using Windows 7 64 Bit Version on MacBook Pro with 16 GB RAM, i7 CPU and 256 GB SSD. The Windows 7 installation is a native one via BootCamp, so no Virtual Box or something like that.

    My Problem:
    I just installed the Creative Original Drivers wich works fine but sometimes the sound is lagging while I am playing (Americas Army 2.5 (Unreal 2 Engine)). This was annoying me a lot but today I got my first blue screen while I was playing and the blue screen came directly after the sound has began to lag. So I decided to install the PAX Drivers for my SoundBlaster X FI Surround 5.1 Pro (USB). But wich drivers I have to install ? I always get the error message, that no supported devices are found when I try to uninstall the PAX Drivers. I have already disabled the Driver Sign Enforcement via admin command line in Windows 7.

    What could be the reasons for the sound lag and why I cant install the PAX drivers ?

    Please help me out guys.

    Thank you !

    opcode_x64
     
  2. Robert McClelland

    Robert McClelland I'm An Uncle for 2nd time Staff Member

    Joined:
    Jun 25, 2002
    Messages:
    15,266
    Likes Received:
    247
    Trophy Points:
    88
    I get work on them this week sometime ;) I was getting my new cpu ready :).
     

Share This Page