PAX_XFTI_PCDRV_L11_2_40_0015_2017v1.00 Titanium Driver

Discussion in 'PAX Download - PCIe X-Fi Series' started by Robert McClelland, Jun 3, 2017.

  1. Suku

    Suku New Member

    Joined:
    Aug 3, 2016
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    1
    Dont worked here, i removed all my drivers with Drive Sweeper 2.0 and istalled XFTI_PCDRV_L11_2_40_0015 And then the pax over, When I click on creative audio control panel it appears that the audio supported by the application was not found
     
  2. Dragondale13

    Dragondale13 New Member

    Joined:
    Jan 16, 2013
    Messages:
    23
    Likes Received:
    2
    Trophy Points:
    3
    @ Suku - Did you disable driver signature enforcement, before installing the PAX set?
     
  3. Suku

    Suku New Member

    Joined:
    Aug 3, 2016
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    1
    yes, Only with the creative website drive does not work either, I do not know why.. but with Daniels drive work o_O and he use (Creative SB X-Fi Titanium series driver 2.40.0015)
     
  4. Dragondale13

    Dragondale13 New Member

    Joined:
    Jan 16, 2013
    Messages:
    23
    Likes Received:
    2
    Trophy Points:
    3
    Alright.Do you first let windows, install any default driver from windows update?
     
  5. Suku

    Suku New Member

    Joined:
    Aug 3, 2016
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    1
    No, i removed with Drive Sweeper and installed in sequence, I did the same thing after removing it with the daniel drive and ran normal
     
  6. Dragondale13

    Dragondale13 New Member

    Joined:
    Jan 16, 2013
    Messages:
    23
    Likes Received:
    2
    Trophy Points:
    3
    Hm..well use whatever works I guess.:)
    I'll do a re-install of these, without the windows update driver installing beforehand and report back.
     
  7. Suku

    Suku New Member

    Joined:
    Aug 3, 2016
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    1
    how do i see the version of drive installed on Windows? if really is the 2.40.0015
     
  8. Dragondale13

    Dragondale13 New Member

    Joined:
    Jan 16, 2013
    Messages:
    23
    Likes Received:
    2
    Trophy Points:
    3
    Right click my computer, properties, device manager, scroll down to sound devices, right click on SB X-Fi, properties and under driver tab, you'll see the version number.

    Re-installed this driver and everything works, can access Audio Control panel on the official set and on PAX set installed on top.
     
  9. Suku

    Suku New Member

    Joined:
    Aug 3, 2016
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    1
    i tried but it shows other version, u can post screenshot of ur version
     
  10. Dragondale13

    Dragondale13 New Member

    Joined:
    Jan 16, 2013
    Messages:
    23
    Likes Received:
    2
    Trophy Points:
    3
    Sure, here you go.

    Creative Driver Screen.png
     
    Last edited: Aug 30, 2017
    Suku likes this.
  11. demonixient

    demonixient Member

    Joined:
    Apr 17, 2014
    Messages:
    100
    Likes Received:
    8
    Trophy Points:
    18
    Is there a way to reset all settings back to normal? Ie: removing HKEY_LOCAL_MACHINE\SOFTWARE\Creative Tech from registry and Creative folders from the system?

    I wish Console Launcher could work. I am finding some of my settings are being interfered with by Windows.

    Would a small contribution encourage you to get Console Launcher working for this?
     
  12. Dragondale13

    Dragondale13 New Member

    Joined:
    Jan 16, 2013
    Messages:
    23
    Likes Received:
    2
    Trophy Points:
    3
    Hey guys and gals! Update on the issues I was having.

    Turns out I had to have HPET enabled in the bios as well as Windows.Since my W7 x64 install I've had it at default, enabled in bios, disabled in Windows.

    With W10, it recognizes that it's on in bios, installs the system driver for it, but doesn't use it, unless explicitly set.
    Voila! All instability is gone.Using latest drivers for eveything with no issues.I unplugged LAN, uninstalled gpu and spu drivers, thorough cleaning in safe mode, turned HPET on in bios during reboot, enabled in Windows, rebooted and installed latest drivers.For me I saw the real improvement from full shutdown.

    Not sure if it'll stabilize every config.Some people prefer to have it off both ways, as that gives a performance boost, so testing for yourself is recommended.

    So my X-Fi isn't obsolete after all, feeling is priceless :).
     
  13. Dragondale13

    Dragondale13 New Member

    Joined:
    Jan 16, 2013
    Messages:
    23
    Likes Received:
    2
    Trophy Points:
    3
    Hey Rob! Re-installed this set earlier today and no issues at all.
    CMSS-3D, AlchemyX enabled, card is performing/sounding tiptop again and no interference with cpu performance.
    Still went through "system32" folder and deleted the cloned ".ini" files.
    Also still have two copies of "instwdm.ini" and "ctzapxx.ini" in there.
    Neither one of them will delete, but thankfully it doesn't seem to be causing any problems.
    Thanks again for the driver and your time, you da man!! :)
     
  14. Robert McClelland

    Robert McClelland I'm An Uncle for 2nd time Staff Member

    Joined:
    Jun 25, 2002
    Messages:
    15,302
    Likes Received:
    248
    Trophy Points:
    88
    sorry if haven't been around been busy getting settle in new home in mich in middle no where have used cell tower internet :p lol don't worry its unlimited data :p ten megs and 7 megs upload best I can get from being 4 miles away lol
     
  15. maurixmystic

    maurixmystic New Member

    Joined:
    May 26, 2015
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    What improvements does this new driver bring?

    use the latest construction of daniel k (I have a x fi titanium fatality) On Windows 10 x64 creators fall update
     
  16. demonixient

    demonixient Member

    Joined:
    Apr 17, 2014
    Messages:
    100
    Likes Received:
    8
    Trophy Points:
    18
    I went to the dark side and tried Daniel_K's driver - mostly to see if it fixed some issues I am having with a game, but also to see if Console Launcher worked.

    Console Launcher does work. But the drivers didn't fix my game sound issues for me. Also Daniel_K's drivers do not sound as good PAX drivers.
     
    Robert McClelland likes this.
  17. Robert McClelland

    Robert McClelland I'm An Uncle for 2nd time Staff Member

    Joined:
    Jun 25, 2002
    Messages:
    15,302
    Likes Received:
    248
    Trophy Points:
    88
    Some day ill take look too see if there new driver's to work on :) I'm just having to much fun with Destiny 2 lol
     
  18. demonixient

    demonixient Member

    Joined:
    Apr 17, 2014
    Messages:
    100
    Likes Received:
    8
    Trophy Points:
    18
    My previous offer was genuine by the way.
     
  19. kevinracer

    kevinracer New Member

    Joined:
    Nov 10, 2017
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Can you build this driver for XFi Titanium Fatal1Ty Pro with -20db Boost Microphone? Properties of Recored not have tab Custom, Mic very noise, it's not happen with my Audigy 2. When i using onboard audio and tick +20 microphone boost, look it same problem of Xfi titanium. Please mod custom tab -20db for Xfi titanium.
     
  20. demonixient

    demonixient Member

    Joined:
    Apr 17, 2014
    Messages:
    100
    Likes Received:
    8
    Trophy Points:
    18
    Where is the subwoofer gain option in Creative Control Panel? It used to be under Speakers in Creative Console Launcher. :(
     

Share This Page

visited