1. The Dark Forum Skin... It's ALIVE!!!!!

Realtek/Soundmax Modds + SB X-fi MB 1.2

Discussion in 'PAX Drivers' started by -Alexa-, Apr 9, 2011.

  1. -Alexa-

    -Alexa- New Member

    Realtek/Soundmax modded drivers for SB X-fi MB 1.2

    For Realtek and Soundmax users:

    Soundmax is updated for all codecs.(Soundmax users please test it)


    1.Uninstall previous realtek/Soundmax drivers and restart
    2.Install modded driver and restart
    3.Install creative software and restart
    4.Activate it.

    Realtek HD Audio drivers is based on 2.60
    Soundmax HD Audio driver based on 6.10.1.6585
    Creative Software 1.2
    -Console Launcher
    -Audio Control Panel
    -Volume Panel
    -Alchemy
    -Sound Blaster Plugin for Media Center
    -Software Update/Bonus Software
    Bonus Software
    -Creative Media player
    -Karaoke Player
    -Wave Studio

    Fixes/Improvements
    -All creative effects(EQ,Cristalyzer,CMSS3D...)
    -Console launcher Delay on Winodws 7 Sp1
    -CMSS3D will turn off when playing 5.1/7.1 sources(Games,DVD movies)

    Realtek Audio driver

    MEGAUPLOAD - The leading online storage and file delivery service

    Soundmax Audio driver
    MEGAUPLOAD - The leading online storage and file delivery service

    Creative software
    MEGAUPLOAD - The leading online storage and file delivery service


    [​IMG]

    [​IMG]

    [​IMG]

    Enjoy:)
    Last edited: May 13, 2011
    Robert McClelland likes this.
  2. speedfirat

    speedfirat New Member

    thanks a lot
    but what is creative software's version for example i use x-fi 1.5(mb1.1-2 mix) consol launcher version 2.61.49 vs.. you can add your packages creative music server and sound blaster jukebox(from x-fi mb2 but i can use mix 1.5 version)
  3. VanhCloud

    VanhCloud New Member

    Greetings from Spain.
    I installed everything following the steps. But it doesn't work. I tested drivers: Alexa, Daniel_k, etc.
    Versions 2.16, 2.48, 2.49, 2.58 and 2.59.
    My sound card is Realtek HD ALC888/1200 and my motherboard is Asus P6T.
    When I run the X-Fi MB, tells me that the application doesn't support the current audio device and forces me to change it. If I agree, only I get SB X-Fi MB.
    Can you help?

    Thnks.
  4. -Alexa-

    -Alexa- New Member

    Did you activate x-fi software before run?Activation is in Realtek folder.
  5. VanhCloud

    VanhCloud New Member

    Yes, I booted into safe mode and I ran RUN.EXE but still doesn't work ...
  6. -Alexa-

    -Alexa- New Member

    Ok.Try this way again..Remove first x-fi software and then realtek driver and restart
    1.After windows start install realtek modded driver and restart
    2.wait to windows start all services and programs and then install x-fi mb software.
  7. VanhCloud

    VanhCloud New Member

    I just try... still not working...
    I don't understand...
  8. Robert McClelland

    Robert McClelland I'm An Uncle for 2nd time

    Hi Alexa you think you can do me favor you can copy my tweaks into the drivers of this set? I don't own the software card I don't know what be going on :p? This software not from Dan K is it I want make sure? :)
  9. -Alexa-

    -Alexa- New Member

    @ VanhCloud: Can you give me your HW ID?
  10. -Alexa-

    -Alexa- New Member

    @ Robert: This driver/software is not from Daniel K,i modded it.Thanks to him, i'm banned from Seven forums.I will add your tweaks if they will work with this drivers.
  11. VanhCloud

    VanhCloud New Member

    Code:
    HDAUDIO\FUNC_01&VEN_10EC&DEV_0888&SUBSYS_104383C0&REV_1001
    HDAUDIO\FUNC_01&VEN_10EC&DEV_0888&SUBSYS_104383C0
    I think these are my hardware ID.
    Thnks.
  12. -Alexa-

    -Alexa- New Member

    This device(alc888) is included in driver,probably x-fi software doesn't support mix of audio codecs.(alc888/1200,662/883)
  13. VanhCloud

    VanhCloud New Member

    So no solution? T_T
    I looked on the internet that there are people who work in 888/1200 drivers...
  14. RanCorX2

    RanCorX2 Active Member

    yea I couldn't get it to work on my new laptop that has the 888 codec, but also found on some forums that others with the same hd codec say it works, they are either lying or aren't sharing all the info....

    a quick search reveals this http://www.jayceooi.com/tag/creative-sound-blaster-x-fi-mb/ & http://www.bfbrasil.com/forum/archive/index.php/t-72814.html & http://www.overclock.net/sound-cards-computer-audio/454816-x-fi-software-integrated-sound-cards.html (download is dead though :( )

    just found this;

    http://www.giga-byte.co.uk/microsite/56/tech_090106_xfi.htm downloads work and ALC888 is listed!
    Last edited: Apr 14, 2011
  15. VanhCloud

    VanhCloud New Member

    But, the last link is for the Gigabyte motherboard, I have Asus don't think that works.
    But if the Gigabyte chip works... must be a way to work in the Asus.

    Thnks
  16. RanCorX2

    RanCorX2 Active Member

    i'm going to try it out.
  17. RanCorX2

    RanCorX2 Active Member

    nope, couldn't get it working, like you said, you obviously need a supported motherboard. damn oem's!!
  18. VanhCloud

    VanhCloud New Member

    So there is no hope for us? xD
    Because the problem is still not clear to me ... don't know why some are doing and not to others. It's the fault of the motherboard?
  19. -Alexa-

    -Alexa- New Member

    I test it on MSI K9N Neo V2 with realtek ALC888 and they work without any problem.
  20. VanhCloud

    VanhCloud New Member

    Have you tried using the SB X-Fi MB 1.1, 1.2 or II?

    Thnks.

Share This Page