Silent Hill 2 Problems

Discussion in 'Gaming Discussion' started by t_wiligh_t, Oct 20, 2006.

  1. t_wiligh_t

    t_wiligh_t New Member

    I know, it is an "old" game but I have always liked Silent Hill serries and I am intended to play all of them in my laptop.

    I am experiencing some problems:

    The videos appear purple with new drivers since the use of ATI Tray Tools. I dont know when they switched from Radlinker to ATT. I tried some older drivers and I had the problem fixed but I cant run newer games with no problems.

    The flashlight has its glow but it does light up the room.

    Does any1 have ideas?

    Thanks in advance.
     
  2. Rayder

    Rayder Mostly lurking lately....

    Do you have the patch installed?
    http://www.gamespot.com/pc/adventure/silenthill2/downloads.html?mode=patches

    You might have to turn off AA. It's been a very long time since I played that game. It seems there WAS a workaround.....

    I'll dig it up and see if I have the same problem with it...I'm running an X1600 on this PC (not the one in my sig)

    EDIT:
    OK, I installed it....yes, you have to turn off AA in order to have the advanced filters in the advanced options. That SHOULD make the flashlight work.

    For the videos, possibly you need the nVidia patch (even though you are using a Radeon).

    I have the original disks, added patch 1 (from the provided link) and installed a NoCD patch. I did not install the nVidia patch. Seems to be working fine. I'm using the 6.9 official drivers though.

    I haven't gotten as far as getting the flashlight, but I seem to remeber that AA was the culprit. I have to go somewhere and don't have time to play it that far...should have already left. :rolleyes:

    Hope that helps.
     
    Last edited: Oct 21, 2006
  3. t_wiligh_t

    t_wiligh_t New Member

    Thanks for your reply!

    I have Acer Ferrari 3000LMI (almost 3 years old:)) with Radeon 9200 mobility.

    I always use omega drivers because they support mobility cards (stupid ATI).

    As for Sillent Hill I have installed older driver (Catalyst 4.5 I think to make it show the videos properly)

    I always have AA off due to perforance.

    I do not have the original disk though:uhoh:
     
  4. >GSXR<mrbusa

    >GSXR<mrbusa MY BIKE vvv

    I have seen alot of older laptop users having problems with the latest catalyst drivers, official or modded. I think we are at a point that some of the older hardware is not supported very well anymore.
     
  5. Rayder

    Rayder Mostly lurking lately....

    ATI stopped supporting anything older than a 9550 with the 6.6 drivers. Try using the 6.5's or older.
     

Share This Page