1. The Dark Forum Skin... It's ALIVE!!!!!

SLOOOOOOOW VelociRaptor speed on SATA 1-4(1.8 MB/sec, even on burst)

Discussion in 'Hardware Discussion & Support' started by JB2007, May 25, 2009.

  1. JB2007

    JB2007 New Member

    Greetings:

    I have an ASUS MA3A79-T Deluxe w/ an HD 4670. I recently did a fresh install of Windows NT5, with this hardware, loaded the drivers from ATI's website and even downloaded the south bridge SB750 drivers (v 9.5), but still I am getting horrific transfer rates on SATA 1-4. A peculiar thing is that the transfer graph is constant (flatline) from start to end of disk (1.8 MB/sec-even on burst), whereas, w/ SATA 5-6 it's about 124 at start, and 90 at end w/ about 254 burst.
    NOTE: I need more than two SATA ports (non-RAID) or else I would use just 5 & 6.

    So I then looked in:
    Control Panel>System>Hardware>Device Manager>IDE ATA/ATAPI controllers

    and found these entries

    AMD PCI IDE Controller
    AMD SATA Controller(Native IDE Mode)
    Primary IDE Chanel (two)
    Secondary IDE Channel (two)

    The "Primary" and "Secondary" have atapi.sys & storprop.dll for drivers, while the "AMD" ones have amdide.sys. No matter what SATA port I put a hard drive in they all have disk.sys as a driver & all w/ write cache enabled. Question is I don't know if SATA 1-4 are tied to the Primary/Secondary channels, or even if this would be the problem. Has anyone experienced this, or know of a solution? If not, does anyone know of a forum/borad that would help? Thanks!
  2. Mousey

    Mousey HH's Official Rodent Staff Member

    Windows NT5/XP If i'm not mistaken?
    Have you not wondered it might be the operating system?
    I can't stress this enough, XP is going on 9 years old now so the majority of new hardware that appears now either performs poorly in XP if not at all now.

    Try installing Vista and see how it performs in that.
  3. JB2007

    JB2007 New Member

    I wish I could move to newer OS, but at this time I am bound, so please no "Just move to xxx OS." Therefore, can anyone please help me w/ my problem? And yes it is NT5/XP.
  4. Tipstaff

    Tipstaff Well-Known Member

    Did you meant to say that you have the ASUS M3A79-T Deluxe?

    First thing I would do is replace the SATA cable with a different one just to make sure that the cable is ok.

    Questions:
    - when running the benchmarks, are you disabling your anti-virus software (if you have any installed that is)?
    - how many drives do you have hooked up to those SATA ports, including optical drives?
    - what bios version are you running for the motherboard?
    - are you overclocking your system in any way?
    - does that board have a Marvell SATA controller too? Maybe listed under SCSI devices?
  5. JB2007

    JB2007 New Member

    Greetings all again!

    Tipstaff:

    "replace the SATA cable with a different one just to make sure that the cable is ok."
    Reply: will do but I doubt it as the cables are all identical.

    - when running the benchmarks, are you disabling your anti-virus software (if you have any installed that is)?
    Reply: Yes antivirus and all antmalware software is disabled.

    * how many drives do you have hooked up to those SATA ports, including optical drives?
    Reply: Doesn't matter if the VelociRator (or for that matter, any other hard drive) is by itself on any of SATA 1-4, still 1.8MB/sec. On SATA 5 or 6, it gives me regular speed whether another drive is on 5 or 6 or not. BTW, I have a Thermaltake 750W powersupply (FWIW).

    * what bios version are you running for the motherboard?
    Reply: I think it's either 0703 or 0602 (not at comp right now)

    * are you overclocking your system in any way?
    Reply: No.

    * does that board have a Marvell SATA controller too? Maybe listed under SCSI devices?
    Reply: Disabled in BIOS.
  6. Tipstaff

    Tipstaff Well-Known Member

    Nice and clear response on all that, JB. ;)

    The reason I mention this is that I've seen bad SATA cable totally mess things up. In fact, I had this experience a couple days ago with a system where the drive would respond either slowly, or would not be seen by the bios at all. Turned out to be a bad cable (brand spanking new cable too).

    If you do have the Asus M3A79-T Deluxe I would consider upgrading the bios to the latest version, being 902 (direct page HERE). Now, even though they don' mention anything about controller updates in the bios it's still worth seeing if this solves this issue.

    This is only used for the eSATA port anyways, right?

    On a related note, I need you to look into something for me on your machine. Are there any errors in Event Viewer related to the controller? You can get to this by going into Control Panel | Administrator Tools | Event Viewer. Look through all the listings, but pay particular attention to the "System" one.
  7. JB2007

    JB2007 New Member

    Tried:

    *New SATA II cables
    *Newest BIOS (0902)
    *eSATA has always been off.

    Still a no go. Haven't tried jumpering them to SATA I yet as I don't have the little jumpers yet. Just funny how only ports 5-6 work fine and at SATA II speed. If this doesn't resolve soon, I may just get a SATA II controller card, but the good 4 port, PCI-e ones cost about $145.
  8. Chaos

    Chaos Number Nine

    Not sure if this is relevent but are it running in IDE mode in the SATA options? have you tried AHCI detection for it
  9. Tipstaff

    Tipstaff Well-Known Member

    I thought about suggesting that too, but since it's XP, and the system isn't setup for AHCI or RAID, switching the controller over would mean re-installing XP. That's why I mentioned the Marvell controller, however I then realized it only powers an eSATA port, and no internal ports.

    One thing I might suggest is to see what mode the hard drives are running in. That being DMA or PIO. I wish I could help on this regard, but my experience with AMD controllers are very limited. All I can do is suggest looking in the sections you mentioned in Device Manager as they are the usual obvious locations (that being Primary and Secondary controllers, or under SCSI and Raid Controllers.. although this one usually shows up in relation to hard drives whenever the controller is set to AHCI or RAID).

    Getting back to your first post, while it won't say what is hooked up to it, if you check the properties of the Primary and Secondary listings, if there is something hooked up to them it will tell you what mode they were running in, and under what Device listing within the Advance Settings tab for that controller. With PATA/IDE this would indicate Master/Slave, but with SATA it indicates which port it is connected to. To find out exactly what is hooked up to that controller go to the Details tab, and change the drop down box to "Bus Relations". That will list exactly what device is hooked up.
  10. JB2007

    JB2007 New Member

    Small update:

    * BIOS set to IDE Mode (I don't have AHCI running, and can't since I didn't do F6 at OS install)
    *In Device Manager the info in the Primary/Secondary Channels is not consistent, with some drives showing "Current Transfer Mode: PIO Mode" and some say "Not Applicable." In any event, SATA 1-4 have same transfer speed regardless of what the tabs say, and some options are greyed out and can't be changed.

    *I even tried uninstalling everything under "IDE/ATAPI controllers" and reinstalling them, to no avail.

    *I even tried uninstalling a sound card that was on the only occupied regular PCI slot, still a no go.
  11. Tipstaff

    Tipstaff Well-Known Member

    The ones that are "Not Applicable" are ok. If a drive is not hooked up to that particular port, then it will show as "Not Applicable". The ones that interest me are the ones who's transfer speed is set to "PIO". This is an old compatibility mode that can greatly affect the speed of your drives.

    Questions:

    - Can you change any of the listings that say they are in PIO mode to DMA mode?
    - Of the ones that you say are greyed out, are there any hard drives showing in that listing, or are there any that say what mode they are currently running in?

    If it were controllers that an optical drive was attached to my thinking would be that Windows might have flagged that controller as having issues, and has set the controller to run in PIO mode, or has set the Upper and Lower filters on it. I've seen this before with optical drives (both IDE and SATA) where if the system encountered errors, repeatedly, from a drive connected to the controller, it would do input those filters. However I don't think I've encountered this with hard drives directly.
  12. SeraphicSorcerer

    SeraphicSorcerer New Member

    You definitely need to get those in DMA mode if possible there should also be a BIOS option to enable DMA, I don't know where it would be on your Board, on mine its under Advanced Bios Settings, anyhow. GL. You should notice huge gains once you get DMA enabled.
  13. Judas

    Judas Obvious Closet Brony Pony


    I have seen hardrive symptoms like this...

    One case being a Faulty Hardrive, the controller on the hardrive was flaky and would force a PIO mode tranfer and reguardless of what i did, it would not change, using the hardrives manufacturer Disk tool, i was able to find out relatively quickly, that the controller was malfuctioning. This was a Samsung drive that was just not working right (sata 1).

    Number 2 occured with a SIS SATA Chipset, not sure which version but reguardless of the drive i stuck in, i would either get BSODs or rediculiously low performance, i never ran any benchmarks mind you but i know it was slower then it should have been, and also producing a PIO MODE ONLY even after trying to force DMA.... reguardless in this case, whichever port i plugged into, didn't matter. The drive appeared to produce errors when using the manufacturers tool on that machine, but with the drive in another machine, the tool showed perfect health. I had to replace the motherboard to resolve the problem completely.
  14. JB2007

    JB2007 New Member

    *I'll see what the tabs say exactly when I get home. To be honest I've been building my own systems for about 15 years, and I have seen slow drive performance before, but nowhere this level. Usually, the standard MS driver was at issue, but still then it would still give you acceptable performace (only until updating the driver to the controller specific device would you see the full performance).

    *I only have HD's hooked up to the SATA ports. I did have an LG BD/HD DVD internal drive hooked up once, but that was only for OS install. I have since (in Device Manager) uninstalled everything under ATA/ATAPI and reinstalled and trying both the standard MS and then SB750 drivers from AMD/ATI.

    *Only other cards installed are an HT Omega 7.1 Striker (PCI) and and Intel Network Adapter 9300 (PCIe). Although problem did exist before the sound card install, doubt it could be the NIC, and everything that can be disabled in BIOS (serial, parrallel, sound, NIC, etc) has already been done so.

    *Out of all the things that strike me as odd, it's the 1.8MB/sec on BURST.

    *Out of curiosity, I googled PIO just to see what was the slowest version:

    Mode 0 (3.3 MB/sec Max)

    *I have heard of the above mentioned bumping down of speed if MS encounters problems with a device, let me see.... I just found this:

    http://winhlp.com/node/10

    I'll see if any of these tips will help. Thanks you all. Your the BEST. I tried several forums, and you all have definetly been the most helpfull, by the number of suggestions (ASUS forums the worst by Faaaaaaar).
    Last edited: May 31, 2009
  15. Tipstaff

    Tipstaff Well-Known Member

    Just out of curiosity, you have SP3 installed, right JB?

    Here's something to look at (I'm going to post this way so that those that don't know can follow it too):

    - Start Regedit (Start | Run | Regedit)
    - Go to this section: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}
    - Open that up, and you should see a bunch of folders labeled 0000, 0001, 0002, and Properties (possible more or less 000x folders depending on how many controllers you have).
    - Go through each folder, and on the right side if you see both or either MasterIdDataChecksum or SlaveIdDataChecksum, delete them. Then reboot.

    Another thing you can do is to manually add a DWORD listing called "ResetErrorCountersOnSuccess" set to 1 within each of those folders. For more information refer to THIS article on MS's website.
    Last edited: Jun 1, 2009
  16. JB2007

    JB2007 New Member

    Tried all of those suggestions to the letter, and still a no go and I'm fully patched up to the date. I think I'll just get a SATA II controller and go that route, there's just too much down time. I'm considering:

    HighPoint RocketRAID 2310 PCI Express x4
    PROMISE SATA300 TX4 PCI

    I don't need RAID, so I may get the Promise.

    Thanks all for all your help!
  17. Judas

    Judas Obvious Closet Brony Pony

    The only thing i can think of is a faulty board/chipset you've got.... in which case i would HIGHLY advise getting it replaced/rma'd as quite often, those problems may oventually spread to other system critical devices... and i doubt your going to be very happy when that starts occuring, specially out of the warranty period.

Share This Page