Solution: CATALYST install manager has stopped working

Discussion in 'AMD Graphics Cards' started by XxSIETHxX, Sep 10, 2008.

  1. XxSIETHxX

    XxSIETHxX New Member

    PROBLEM:
    After patching the drivers with Mobility Modder, and then Clicking on the Setup.exe icon in the ATI/SUPPORT/(software/driver version) An error message pops up stating "CATALYST install manager has stopped working"

    SOLUTION:
    This is what I found to fix the problem.

    (You may have to enter safe mode)

    1st: Enter task manager and stop all Catalyst and ATI processes and services.

    2nd: In device manager go to your display adapter and Uninstall the drivers, make sure you check the box to also delete the drivers off the computer. (otherwise they might reinstall on boot)

    3rd: Download and run Microsoft Installer CleanUp Utility. With that program make sure you remove all ATI and Catalyst that show up on the list. Description of the Windows Installer CleanUp Utility <--- get it here.

    4th: Download and run CCleaner make sure to clear traces of ATI and Catalyst from the Cleaner Tab and the Registry Tab. CCleaner - Home <--- get it here.

    *note* You may have to rerun CCleaner and Installer CleanUp a few times to make sure it gets everything.

    5th: Use RegEdit and make sure that no traces of ATI remain in the registry. Fast way to find what your looking for the to use the search and Type "ATI" in quotes. I still found two items that were not cleaned by the other programs.

    6th: Reboot the system, and again make sure everything is off the system. If windows detects the device and installs the PROPER (not default or generic) drivers then you messed up and will have to make sure it is all cleaned off again before rebooting.

    *note* Make sure no ATI folders are in the Program Files folder. I found two in there and for one I had to be in safe mode to delete.

    7th. (if using Mobility Modder) follow these slightly modded 5 steps....
    A: Download MSXML 6.0 from Microsoft. (Default in Vista) - Install.

    Step B is VISTA ONLY

    B: Make sure UAC control in Vista is turned off. If you don't know how to do this then read this guide (method 4 is the easiest) or click the "disable UAC" in Mobility Modder.net - please note you MUST reboot after disabling UAC. If you don't want it disabled permanently, you can turn it back on after our mobility tool has finished, but it won't mod the drivers correctly with UAC ON.

    C: Download the newest desktop drivers from www.ati.com (or get them from Driver Heaven Downloads). If you are using Windows XP make sure to download .net framework from Microsoft (this is built into Windows Vista so there is no need to install it).

    D: Run the downloaded driver, let it extract into c:/ATI/SUPPORT - but cancel the installation once the driver is extracted.

    E: This step will make you life easy. rename the 8-8_vista32_dd_ccc_wdm_enu_67980 (or what ever the folder name was that it extracted into) folder to something easy to type. i.e. I named mine ATI88. so it would be C:\ATI\SUPPORT\ATI88

    F: Run Mobility Modder - browse to the driver in C:ATI/SUPPORT/ATI88 ( if that is the name you gave it ) - hit modify. Wait until driver is modified.

    8th: THIS PART IS VERY VITAL!!! Do NOT run the setup.exe in the C:\ATI\SUPPORT\ATI88 folder. INSTEAD Open Command Prompt, CMD.

    9th: Change directory to C:\ATI\SUPPORT\ATI88\BIN:
    cd c:\ATI\SUPPORT\ATI88\BIN
    10th: Type to following command:
    ATISetup.exe -install -output SCREEN
    (you most likely will get a warning about unsigned driver. just hit yes... or OK)

    11th: All should install well. you will get a page pop up telling you everything was installed successfully.

    :) If you need further clarification on anything please fill free to ask. I hope this helps. It took my about 6 hours of fumbling around to figure this out. Now it shouldn't take you guys no longer than 20 - 30 min. If that. Have a nice day. :D
    Last edited: Sep 11, 2008
  2. okman9

    okman9 New Member

    Thank you! I was struggling with it until I found this post. ATI made me wasted hours!:mad:
  3. blueboy48

    blueboy48 New Member

    hi, i'm an Italian newbie and i'm sorry for my bad english. But i've got a problem similar to yours: CATALYST INTALL MANAGER does not work at all!
    I've a desktop PACKARD BELL, with a Processor Intel Pentium D 820, MainBoard NEC COMPUTERS GA-87RC410M-NF, memory DDR2 MBytes and i've had installed a NVIDIA Graphic Card.
    Unfortunately the Power Supply crashed and burnt the Graphic Card :drool:
    After the fixing up of the pc i've found something new: a Chipset ATI RS400/RC400/RC410, a Southbridge ATI SB400, and an ATI RADEON XPRESS 200 Card....
    In the partition with installed XP i've no problems with the Catalyst software and drivers.
    In VISTA partion instead, when i try to install the packs released by ATI, they install in C:\ATI. Then I open the folder to launch the setup: it says it'll install the CIM in C:\Program files\ATI Technologies. When the installation gets to an end I go and control and I find: C:\Program files\ATI Techonologies is empty!!! :eek: but there is a new folder ATI with the CIM Installer.exe and other files. If i click on the installer it says the newer version of CIM is already installed and ask me if i want to reinstall the previous version... NO TRACES OF INSTALLED DRIVERS, OF CCC and so on...:confused:
    So I've gone through the procedure you suggested in your post: Codec Cleaner, CCleaner, Easy Cleaner, manual control of the registry, but the Modding obviously, and when i get to the Command Propmpt Line .. it stops immediately to proceed because: NO CATALYST HARDWARE FOUND!!!!!:confused::mad:
    So I install the drivers manually, without any software and the results are: WindowsUpdate popups always telling me there is a new version of the drivers, but it is the May version and, ABOVE ALL, every, say, 4 days the system interrupts the drivers :( because of an undetermined error 43 and i've to repeat the cleaning and the manual installation...
    Can anyone suggests me a solution? But, please!, don't tell me i've to format!!!
    I'm sorry for my rigmarole and i thank you if you will pay me attention.
    Ciao from Italy
  4. cndittmar

    cndittmar New Member

    I hate to bring up such an ancient subject, but I stumbled across this post whilst searching Google for a cure to ths issue.

    Has anyone ever had any success with thi? I have even tried the steps here, usig not only CCleaner but 2 other cleaners (Windows Vista Manager included) to make sure all bad entries were gone from the registry during that step:

    However, this does not work either.

    I am about to just reinstall Vista, but I really do not want to. Time to reinstall Vista 64 bit -- half an hour. Time to reinstall Adobe and everything else I have that requires activations, licensing, etc. -- 2 weeks. I really do not want to do that but I have a feeling ATI hosed my OS with this :-(

    Now I have no control center, and no driver, yet the system performs as if i do have a driver installed. Even in Device manager I verified no display drivers installed, yet i am running at the same resolutions, etc that I have had before the uninstall. This concludes that it is impossible to completely remove the driver.

    Also in task manager, even after deleting all ATI and Catalyst related entries from registry, deleting all ATI folders, etc., I STILL get a service called "ATI External Event Utility", even though it is listed as "Stopped" in the list -- it disturbs me that this is still there even after doing the steps outlined above.

    Are there any other solutions to this???
  5. skyzosurf

    skyzosurf New Member

    this solution do not worked for me :(

    MOBILITY RADEON X1700
    catalyst 7.4 to catalyst 8.12
  6. thebaron26

    thebaron26 New Member

    The solution I found worked for me was the following:

    1. Save the ATI Drivers folder to a USB stick or other portable media. This folder should contain the 'FirePro_8.62_Vista32_82693' and/or 'FirePro_8.634_Vista32_86100'. The latter was the most recent I could find.

    2. Follow steps 1-6 posted by 'XxSIETHxX' which removes all ATI programs.

    3. Re-install the ATI drivers by going to the selected Firepro program on your portable media, transferring to your desktop and run the setup.

    4. This then re-installs everything from scratch and solved my problems. It also fixed the 'Atikmdag Driver' problem which I've had for some time.

    Hope this helps.

Share This Page