HardwareHeaven.com

HardwareHeaven.com

Looking for the skin chooser?
 
 
  • Home

  • Hardware reviews

  • Articles

  • News

  • Tools

  • Gaming at HardwareHeaven

  • Forums

 

Go Back   HardwareHeaven.com > Forums > Driver Support > kX Project Audio Driver Support Forum > General Discussion


Reply
 
Thread Tools
Old Jan 17, 2013, 05:57 AM   #1
HardwareHeaven Junior Member
 
Join Date: Jun 2012
Posts: 31
Rep Power: 0
Thelace43 is on a distinguished road

ASIO in SONARx2 on Windows 8 not working

At this point I'm wondering if Sonar x2 just doesn't work with the KX ASIO drivers.. I can't get a track to read a signal. I am using a single Audigy.

-ASIO is connected to working input src, (profx) which is also connected to a mixer which gets a read from a microphone. (no problems in the DSP)

-There are no other enabled sound devices.

-Sonarx2 is set on ASIO and all kx input channels are selected.

-The track is set to the correct ASIO input and it is armed. ..but no read on the VU.

-Sonar is run in Win7 compatibility mode, to which I also set kxmixer.

Can anyone give me any advice or share my frustration? I've been working on this computer for days just to lead up to this problem. Please and thank you!
Thelace43 is offline   Reply With Quote


Old Jan 17, 2013, 07:25 AM Threadstarter Thread Starter   #2
HardwareHeaven Junior Member
 
Join Date: Jun 2012
Posts: 31
Rep Power: 0
Thelace43 is on a distinguished road

Re: ASIO in SONARx2 on Windows 8 not working

I got it to work!.. I think the start/stop audio engine needed toggling, although I did reinstall 3550 and unchecked some of the optional features. Now I have a new problem: I don't get any playback. Again, I appreciate any help.

..It should work, but it might be a sonar thang. Sound files work, but no playback from sonar.
Thelace43 is offline   Reply With Quote
Old Jan 17, 2013, 04:55 PM   #3
HardwareHeaven Newbie
 
Join Date: Oct 2012
Posts: 12
Rep Power: 0
Toff is on a distinguished road

Re: ASIO in SONARx2 on Windows 8 not working

Have you registered kxasio.dll manually using regsvr32? You must do that first. First register kxasio.dll (either x86 or x64 version, or both) found in kX Project installation folder, then start kX mixer (x86 or x64 version accordingly) manually as administrator for it to make the appropriate changes in the registry (this links registered ASIO entries to your device). And don't forget to set Win7 compatibility for both kX Mixer and Sonar.
This is for 3551 though, not sure if 3550's behaviour is the same.
Toff is offline   Reply With Quote
Old Jan 17, 2013, 08:49 PM Threadstarter Thread Starter   #4
HardwareHeaven Junior Member
 
Join Date: Jun 2012
Posts: 31
Rep Power: 0
Thelace43 is on a distinguished road

Re: ASIO in SONARx2 on Windows 8 not working

Thank you very much, I was excited that I hadn't done this yet, but it is still not working. The registry went smoothly after a couple tries (typos), I did the win7 comp mode for the things that need it and set it to runasadmin, and I installed 3551 correctly, after uninstalling the previous. (then I did the reg thing again just as before) What seems wacky is that Win8 defaults the sound to wave out 6/7.. When I try to change it using the windows speaker icon mixer, I have options to go to wave out 2/3, or Master Mixer and some others, (all KX, and of course no onboard audio is enabled) HOWEVER, there is no 0/1 option. I can set it to 2/3 and then go to src and set it to 2/3 and audio files play fine, but not in sonarX2, even when I set the recording and playback to the corresponding outputs, open a new file, import an MP3 and push play. The VU meters show the audio playing in Sonar, but nothing is heard. Hmmm....
Thelace43 is offline   Reply With Quote
Old Jan 17, 2013, 09:00 PM Threadstarter Thread Starter   #5
HardwareHeaven Junior Member
 
Join Date: Jun 2012
Posts: 31
Rep Power: 0
Thelace43 is on a distinguished road

Re: ASIO in SONARx2 on Windows 8 not working

.. Also, I just set the default audio device in windows to 4800 from 4400, as it is set too in kx and sonar. Nothing.
Thelace43 is offline   Reply With Quote
Old Jan 18, 2013, 09:10 PM Threadstarter Thread Starter   #6
HardwareHeaven Junior Member
 
Join Date: Jun 2012
Posts: 31
Rep Power: 0
Thelace43 is on a distinguished road

Re: ASIO in SONARx2 on Windows 8 not working

Also, I installed Sonar4 (works fine with KX drivers on XP) and I'm getting the same results.
Thelace43 is offline   Reply With Quote
Old Jan 19, 2013, 12:11 AM   #7
HardwareHeaven Newbie
 
Join Date: Oct 2012
Posts: 12
Rep Power: 0
Toff is on a distinguished road

Re: ASIO in SONARx2 on Windows 8 not working

I don't think the output you select as default in your system's preferences matters at all for ASIO. Maybe try the default DSP setup without ProFX?
Toff is offline   Reply With Quote
Old Jan 19, 2013, 07:35 PM Threadstarter Thread Starter   #8
HardwareHeaven Junior Member
 
Join Date: Jun 2012
Posts: 31
Rep Power: 0
Thelace43 is on a distinguished road

Re: ASIO in SONARx2 on Windows 8 not working

I used FXbus2 instead of src and it works. wew. I'm only able to get 8 inputs at this point, (sonar only lets me set 8 inputs) and they go asio2 asio4 (right, left) 6-8,10-12-14-16.. which is not what I remember with the 3535 or whatever old version I was running on my XP macine. So when I'm in the DSP, I have to connect the inputs like this. In sonar, I just select the first Stereo input on a list of 8. I can't get past any more after the first 4. Does this sound familiar?
Thelace43 is offline   Reply With Quote
Old Jan 19, 2013, 08:33 PM   #9
HardwareHeaven Extreme Member
 
Join Date: Jan 2005
Posts: 5,722
Rep Power: 74
Russ is just super!Russ is just super!Russ is just super!Russ is just super!Russ is just super!Russ is just super!

Re: ASIO in SONARx2 on Windows 8 not working

What settings are you using in the ASIO Control Panel? In the ASIO CP you can select the number of inputs that will be available to your ASIO host program, and whether to use 16 bit or 24 bit (IIRC, 24 bit will have less inputs), etc.
Russ is offline   Reply With Quote
Old Jan 19, 2013, 09:20 PM Threadstarter Thread Starter   #10
HardwareHeaven Junior Member
 
Join Date: Jun 2012
Posts: 31
Rep Power: 0
Thelace43 is on a distinguished road

Re: ASIO in SONARx2 on Windows 8 not working

Let me correct myself first: I meant it goes asio1(left) asio3(right) and so on.. but that was with Profx asio.. I'm using epilog now and it's going smoothly with the first 4 .. and .. well look at that! 16 Profx is great, but only when it works. Thank you again!
Thelace43 is offline   Reply With Quote
Reply

Thread Tools