HardwareHeaven.com

HardwareHeaven.com

Looking for the skin chooser?
 
 
  • Home

  • Hardware reviews

  • Articles

  • News

  • Tools

  • Gaming at HardwareHeaven

  • Forums

 

Go Back   HardwareHeaven.com > Forums > Software Discussion > Mobility Modder Discussion


Reply
 
Thread Tools
Old Jan 31, 2010, 11:36 PM   #1
HardwareHeaven Newbie
 
Join Date: May 2008
Posts: 9
Rep Power: 0
FireSBurnsmuP is on a distinguished road
System Specs

??? ATI radeon X1200 and catalyst on XP...

Okay, so I'm trying to install the catalyst drivers for this X1200 gpu on a machine I just downgraded from vista to XP-SP3.

I'm sick of just trying everything and trying to read the posts on other sites that have no continuity or are just confusing due to mistakes. I decided that, since you guys seem to know the very most about this kind of thing, and your Mobility Modder 1.2.1.0 seems to be the best option, I'm asking you guys this:

How can I install these drivers using Mobility Modder?

Here's a list of things I tried:
1) Installing it automatically from windows update (failed of course).
2) My original install of 9-11 almost worked... I could set the options to force the max resolution (1280x800), and that worked, but I noticed that CCC would COMPLETELY lock the computer up when I try to open it from the desktop r-click context-menu sometimes, likewise with selecting "properties" in the same menu. Thus I decided there was a problem and tried re-installing (to no avail, of course).
3) I tried modifying 9-11's CX_xxxx.inf
and manually installing the device, to no avail. I couldn't get it to work.
4) I tried using the mobility modder, probably on 9-11, also to no avail.

Here's the device info:
Code:
lspci |grep "VGA"
01:05.0 VGA compatible controller: ATI Technologies Inc RS690M [Radeon X1200 Series]
the windows device man shows these Hardware IDs:
Code:
PCI\VEN_1002&DEV_791F&SUBSYS_FF001179&REV_00
PCI\VEN_1002&DEV_791F&SUBSYS_FF001179
PCI\VEN_1002&DEV_791F&CC_030000
PCI\VEN_1002&DEV_791F&CC_0300
... and this Device Instance ID:
Code:
PCI\VEN_1002&DEV_791F&SUBSYS_FF001179&REV_00\4&14AFA61C&0&2808
I hope that helps.

Now I just want this stupid thing to work. Apparently some people can get it to work on XP, but I can't seem to replicate their results. So any help you can give me is appreciated, and will be rewarded with free cookies*.

*: Free cookies subject to availability in your area.

FireSBurnsmuP
FireSBurnsmuP is offline   Reply With Quote


Old Feb 1, 2010, 01:19 AM   #2
Filled with noobsauce
 
Join Date: Nov 2009
Location: between the buns
Posts: 1,330
Rep Power: 70
iPlayer has a divinity and aura the likes we have never seeniPlayer has a divinity and aura the likes we have never seeniPlayer has a divinity and aura the likes we have never seeniPlayer has a divinity and aura the likes we have never seeniPlayer has a divinity and aura the likes we have never seeniPlayer has a divinity and aura the likes we have never seeniPlayer has a divinity and aura the likes we have never seeniPlayer has a divinity and aura the likes we have never seeniPlayer has a divinity and aura the likes we have never seeniPlayer has a divinity and aura the likes we have never seeniPlayer has a divinity and aura the likes we have never seen

Re: ATI radeon X1200 and catalyst on XP...

Try with 9.10 or older drivers instead.
iPlayer is offline   Reply With Quote
Old Feb 1, 2010, 01:31 AM Threadstarter Thread Starter   #3
HardwareHeaven Newbie
 
Join Date: May 2008
Posts: 9
Rep Power: 0
FireSBurnsmuP is on a distinguished road
System Specs

Re: ATI radeon X1200 and catalyst on XP...

Alrighty... It looks like I got it working without modification by using the legacy drivers. This PC isn't exactly for a gamer or an artist, so I'm not terribly concerned with how well it works, more just that it works. So far no freezing, either.
If you do know how you would do this with the Mobility Modder, go ahead and post a howto here to help other people out. Centralize information.

Here's what I did:
I downloaded https://a248.e.akamai.net/f/674/9206...-64_dd_ccc.exe (the legacy drivers version 9.11) This actually supported the ATI x1200 I have on this lappy.
I don't need bloatware, or installers (considering the installer screwed something up the first time), so I go to the device manager, and find my "VGA compatible controller" (or something like that) in the other devices section, and went to "Update driver...".
Chose "No, not this time", clicked "Next".
Chose "Install from a list or specific location (Advanced)", clicked "Next".

take a break from the DevMan, and open the legacy driver installer.
Let it unpack everything, by just clicking "Install".
Then, when the "ATI Software" window comes up, click cancel. agree to exit the installer.
Optional: If you're paranoid (like I was) do this part. If not, skip to "Go back to the DevMan".
Now: open My Computer, and browse to C:\ATI\Support\<driver>\Driver\XP_INF\. <driver> in my case (and if you downloaded the linked file, yours) was "9-11_legacy_xp32-64_dd_ccc".
Open CX_xxxxx.inf in Notepad. In this case, "CX_89304.inf" is the choice.
---I did this for one reason, to see if my device was actually supported by this driver, or if I needed to find another inf.
I got lucky; I used the "Hardware ID" from the device manager and searched for a bunch of substrings of it. I found earlier that the "subsystem" value is the one that differs the most often, so I deleted that part first in searching.
I found an entry in the file for this card. *I didn't touch said entry!* I just wanted to see it, so I could install EXACTLY the driver I needed.

Go back to the DevMan.
Click "Don't search. I will choose the driver to install.". Click "Next".
I chose "Display Adapter," I'm not sure if this makes a difference or not, but do it anyway. Click "Next"; this might take a sec.
It doesn't matter what's selected. Click "Have disk...".
Click "Browse". Browse to the CX_xxxxx.inf file in ATI\support\<driver pack>\driver\XP_INF\.
Click Open, OK, and the rest should be totally self-explantory.

I'll let ya know if I have any more trouble with this, and I hope this helps somebody get their X1200 or similar working under XP or what-have-you.

~FireSBurnsmuP
FireSBurnsmuP is offline   Reply With Quote
Reply

Thread Tools