Computer keeps automatically alt-tabbing

Discussion in 'Hardware Discussion & Support' started by xpremorph, May 26, 2013.

  1. xpremorph

    xpremorph New Member

    Joined:
    May 26, 2013
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    erm.I would like to ask how to solve automatic alt-tabbing when i am playing dota 2 as i just launched dota 2,my games immediately alt-tab's to the desktop
    page. when i tried to go back into the game,automatic alt-tab's occur.This goes on and on and on. Is there any programmes stopping me in my task manager from opening this game?I would appreciate it greatly if you know the answer :).
     
  2. Dyre Straits

    Dyre Straits 10 Grandkids and 1 Great-grandson!

    Joined:
    May 13, 2002
    Messages:
    18,533
    Likes Received:
    1,467
    Trophy Points:
    153

    Do you, by any chance, have any other control devices installed other than a Mouse and Keyboard? If so, make sure they are either disconnected or do not have anything lying on them.

    Personal Example: I have a Windows 360 Controller installed along with my normal control and input devices. I had a problem and discovered that I had something lying on my 360 controller that was causing the problem.
     
  3. Tipstaff

    Tipstaff Well-Known Member

    Joined:
    Jul 22, 2002
    Messages:
    8,963
    Likes Received:
    722
    Trophy Points:
    123
    I've also seen this with malware, and programs that force a centered view, or rather a piece of software that wants to be the center of attention.. even anti-virus software.

    So, after you try Dyre's suggestion go through your active programs, turning off everything that isn't necessary, including ending/exiting everything that shows up on the taskbar. Go so far as to disable most if not all of the programs that startup with Windows (do that via Windows key + R, MSCOFIG, startup tab). At the very least keep (if you have one) your anti-virus running, but everything else should be disabled (also take note of what is running.. look for anything out of the ordinary). Reboot the machine, and try the game again. If it stops just do the reverse, adding in 1 or 2 applications back into the startup list until it starts acting up again.

    Also, if you have an anti-virus software installed try disabling all notifications. Same goes for any software that has this feature too.

    Last thing, try a different keyboard. If you have a specialty keyboard that requires software to run, try uninstalling it. Same goes for mouse software.
     
  4. xpremorph

    xpremorph New Member

    Joined:
    May 26, 2013
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    mmh... my keyboard is built in (laptop) and i use a usb mouse.. a cooler fan.. and wire connecting to my fibre
     
  5. Tipstaff

    Tipstaff Well-Known Member

    Joined:
    Jul 22, 2002
    Messages:
    8,963
    Likes Received:
    722
    Trophy Points:
    123
    I would certainly look towards it being an application that is stealing "focus", forcing it to be the center of attention.

    As I said my first bet would be a piece of malware, or even an anti-malware/anti-virus software. If the laptop came with something like Norton 360, that thing is known for this kind of thing. I would turn off auto scanning for any software that does this, especially anti-virus, including turning off notifications, turn off automatic updates for Windows itself, and disable/exit out of any software showing up in the taskbar. That, as well as going along with my other suggestions.

    Questions:

    - What laptop is this? Make and model? And what operating system is it?

    - Since you are using an external mouse, try disabling the touch pad.

    - Does this happen with any other games?

    - Have you tried disabling Steam "In Game" overlay? To try this open Steam, choose "Steam" from the top menu, choose Settings, In-Game tab, uncheck "Enable Steam Community In-Game". Save/close, close and relaunch Steam, then try DOTA2 again.

    - Have you tried running DOTA2 in a "windowed borderless" mode? This is more so that you can see what, if any, piece of software might be activating in the background than as a possible fix (to try this open Steam, goto Library, highlight and right-click the DOTA2 listing, choose Properties, on the General tab choose "Set Launch Options", and paste the following in there:

    -novid -console -windowed -w 1920 -h 1200 -noborder

    I don't recall if you NEED to have -novid - console, but you need the rest. Also, make sure to replace -w 1920 -h 1200 with the resolution you play in, or the native resolution of your laptop.

    - Are you on Bell Fibe? If so, are you using their anti-virus and/or software? If so, uninstall it, and install something more friendly such as Windows Security Essentials (unless this is a Windows 8 laptop, in which case uninstalling any anti-virus software Windows will default back to the built in Windows Defender... which is the same thing now).
     
    Last edited: May 27, 2013
  6. Dyre Straits

    Dyre Straits 10 Grandkids and 1 Great-grandson!

    Joined:
    May 13, 2002
    Messages:
    18,533
    Likes Received:
    1,467
    Trophy Points:
    153
    So, you do have more than one control device installed: Touch-pad plus USB Mouse.

    Since this problem seems to only result when attempting to play this particular game, if it were me, I'd simply disconnect the USB mouse to see if the problem persists without it connected. If so, then somewhere in the game's Options settings for controls, you'll need to narrow down which setting is the culprit and see if you can change that.
     
  7. Dags Marce

    Dags Marce New Member

    Joined:
    Jan 30, 2015
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Hello! I am also experiencing this kind of annoying alt-tabbing. I am using a laptop (built-in keyboard and a mouse only). My brother did something that stopped the alt-tabbing for a while, as he said that he closed the skype. But now, it happened again. When my younger brother plays GTA or Warcraft III, it alt-tabs for no reason. Also, when I am using Firefox, it happens, meaning it does not only happens when i am playing Dota 2. Can you please help me too? Thanks!
     

Share This Page

visited