Crash while cleaning after latest DC update

Discussion in 'Driver Cleaner.NET Support' started by FTProtocal, Nov 26, 2009.

  1. FTProtocal

    FTProtocal New Member

    Joined:
    Nov 26, 2009
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    I'm not sure when the most recent update to DriverCleaner took place was, but I wanted to try the new 195.62 WHQL drivers so I uninstalled the old driver, fired up DC, updated, and then booted back in Safe Mode. I selected every nVIDIA profile, and the Ageia one; the scan only took a few seconds to complete, which was odd ... Then when I clicked clean, the program crashed. Again, this only started happening after downloading the latest DC core updates via the auto-update.

    I tracked the actual "profile" down to the nVIDIA specific driver. The PhysX, Control Panel, WDM, etc, all work fine if you select/clean them.

    I'm running Win7 x64; I don't think any other system spec is useful for this issue. Thanks.

    *Didn't even see the other post about the crashing issue; my bad :(
     
    Last edited: Nov 26, 2009
  2. Spike

    Spike Driver Cleaner Maker

    Joined:
    Jul 18, 2002
    Messages:
    2,044
    Likes Received:
    3
    Trophy Points:
    0
    I really need to know which version of the program you are using, so could you please check that and post that?

    Could you also send me an email with the message it gives or a screenshot of the error to info at drivercleaner dot net
     
    Last edited: Nov 26, 2009
  3. v4npro

    v4npro New Member

    Joined:
    Jan 5, 2006
    Messages:
    44
    Likes Received:
    0
    Trophy Points:
    0
    I think he's using the latest 3.2.4.0
     
  4. d.chatten

    d.chatten New Member

    Joined:
    Oct 17, 2006
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    Hi Spike, I'm also experiencing the same issue with Windows 7 64bit, it works fine with Windows 7 32bit, the version of DH Driver Cleaner.NET i'm using is the latest build (3.4.2.0)
     
  5. dipstick

    dipstick New Member

    Joined:
    May 29, 2002
    Messages:
    3,609
    Likes Received:
    16
    Trophy Points:
    0
    I get a crash after the last update too. When i try to clean I get hit with this;

    [​IMG]

    thanks, hope it helps

    Edit- this is on version 3.4.2.0
     
  6. SeraphicSorcerer

    SeraphicSorcerer Well-Known Member

    Joined:
    Jul 3, 2002
    Messages:
    2,125
    Likes Received:
    101
    Trophy Points:
    73
    Are you all running UAC enabled?
    Have you tried running as admin?
     
  7. Spike

    Spike Driver Cleaner Maker

    Joined:
    Jul 18, 2002
    Messages:
    2,044
    Likes Received:
    3
    Trophy Points:
    0
    I reverted back to 3.4.0.0 for now, because i need to look into this, but i have tried this on several systems i own and on none of them i have this problem. I haven't tested it yet on Windows 7, so not sure if it only happens on windows 7 64 bits or not. Hope to be able to test it soon.
     
  8. dipstick

    dipstick New Member

    Joined:
    May 29, 2002
    Messages:
    3,609
    Likes Received:
    16
    Trophy Points:
    0
    Yea, it makes no difference.



    Thanks for the hard work Spike, it probably is a 7 thing.
     
  9. SeraphicSorcerer

    SeraphicSorcerer Well-Known Member

    Joined:
    Jul 3, 2002
    Messages:
    2,125
    Likes Received:
    101
    Trophy Points:
    73
    It's not a windows 7 thing I just tried using my copy and it went right through. to be clear however I have UAC totally disabled.

    I'm using 64 bit W7

    I just noticed you reverted, forgive me. I is blind.
     
    Last edited: Dec 5, 2009
  10. d.chatten

    d.chatten New Member

    Joined:
    Oct 17, 2006
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    Version 3.4.2.0 crashes on my Windows 7 64bit install even with UAC disable, also, UAC is the first thing i disable to avoid issues such as this, i'm also running as admin.
     
  11. Anarion

    Anarion New Member

    Joined:
    Jan 1, 2010
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    I too have crashing problem, not sure if it's the same thing tough. I'm running Windows 7 x64 and UAC is disabled.

    When cleaning creatives driver it hangs here (I can hear error sound but nothing pops up and I have to use task manager to kill application):
    [​IMG]

    If I do not force quite the application and just log out, this error screen pops up for short period of time (managed to take a screen shot of it using FRAPS).
    [​IMG]

    If I select Creative Audio Lite it finishes cleaning but doesn't delete those registry entries (either but at least it doesn't crash) and get the following error log (see bellow).
    [​IMG]

    I can not post the whole log because of character limitation but the error is always the same.
    Code:
    ---- Library 2.0.14970.3408 ----
    Time: 17:49:37
    Location: DeleteKey
    Exception: ThrowArgumentException
    Error: Cannot delete a subkey tree because the subkey does not exist.
    Extra: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\PCI\VEN_1102&DEV_0004&SUBSYS_20021102&REV_04
    Trace:    at System.ThrowHelper.ThrowArgumentException(ExceptionResource resource)
       at Microsoft.Win32.RegistryKey.DeleteSubKeyTree(String subkey)
       at DCLibrary.clsRegistry.DeleteKey(String lngRootKey, String strKey, Boolean bRecursive)
    --------------------------------------------------------
    ---- Library 2.0.14970.3408 ----
    Time: 17:49:37
    Location: DeleteKey
    Exception: ThrowArgumentException
    Error: Cannot delete a subkey tree because the subkey does not exist.
    Extra: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\Root\LEGACY_CTAC32K
    Trace:    at System.ThrowHelper.ThrowArgumentException(ExceptionResource resource)
       at Microsoft.Win32.RegistryKey.DeleteSubKeyTree(String subkey)
       at DCLibrary.clsRegistry.DeleteKey(String lngRootKey, String strKey, Boolean bRecursive)
    --------------------------------------------------------
    ---- Library 2.0.14970.3408 ----
    Time: 17:49:37
    Location: DeleteKey
    Exception: ThrowArgumentException
    Error: Cannot delete a subkey tree because the subkey does not exist.
    Extra: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\Root\LEGACY_CTPRXY2K
    Trace:    at System.ThrowHelper.ThrowArgumentException(ExceptionResource resource)
       at Microsoft.Win32.RegistryKey.DeleteSubKeyTree(String subkey)
       at DCLibrary.clsRegistry.DeleteKey(String lngRootKey, String strKey, Boolean bRecursive)
    --------------------------------------------------------
    ---- Library 2.0.14970.3408 ----
    Time: 17:49:37
    Location: DeleteKey
    Exception: ThrowArgumentException
    Error: Cannot delete a subkey tree because the subkey does not exist.
    Extra: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\Root\LEGACY_CTSFM2K
    Trace:    at System.ThrowHelper.ThrowArgumentException(ExceptionResource resource)
       at Microsoft.Win32.RegistryKey.DeleteSubKeyTree(String subkey)
       at DCLibrary.clsRegistry.DeleteKey(String lngRootKey, String strKey, Boolean bRecursive)
    --------------------------------------------------------
    ---- Library 2.0.14970.3408 ----
    Time: 17:49:37
    Location: DeleteKey
    Exception: ThrowArgumentException
    Error: Cannot delete a subkey tree because the subkey does not exist.
    Extra: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\Root\LEGACY_HA10KX2K
    Trace:    at System.ThrowHelper.ThrowArgumentException(ExceptionResource resource)
       at Microsoft.Win32.RegistryKey.DeleteSubKeyTree(String subkey)
       at DCLibrary.clsRegistry.DeleteKey(String lngRootKey, String strKey, Boolean bRecursive)
    --------------------------------------------------------
    ---- Library 2.0.14970.3408 ----
    Time: 17:49:37
    Location: DeleteKey
    Exception: ThrowArgumentException
    Error: Cannot delete a subkey tree because the subkey does not exist.
    Extra: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\Root\LEGACY_HAP16V2K
    Trace:    at System.ThrowHelper.ThrowArgumentException(ExceptionResource resource)
       at Microsoft.Win32.RegistryKey.DeleteSubKeyTree(String subkey)
       at DCLibrary.clsRegistry.DeleteKey(String lngRootKey, String strKey, Boolean bRecursive)
    --------------------------------------------------------
    ---- Library 2.0.14970.3408 ----
    Time: 17:49:37
    Location: DeleteKey
    Exception: ThrowArgumentException
    Error: Cannot delete a subkey tree because the subkey does not exist.
    Extra: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\Root\LEGACY_OSSRV
    Trace:    at System.ThrowHelper.ThrowArgumentException(ExceptionResource resource)
       at Microsoft.Win32.RegistryKey.DeleteSubKeyTree(String subkey)
       at DCLibrary.clsRegistry.DeleteKey(String lngRootKey, String strKey, Boolean bRecursive)
    --------------------------------------------------------
    ---- Library 2.0.14970.3408 ----
    Time: 17:49:37
    Location: DeleteKey
    Exception: ThrowArgumentException
    Error: Cannot delete a subkey tree because the subkey does not exist.
    Extra: HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Enum\PCI\VEN_1102&DEV_0004&SUBSYS_20021102&REV_04
    Trace:    at System.ThrowHelper.ThrowArgumentException(ExceptionResource resource)
       at Microsoft.Win32.RegistryKey.DeleteSubKeyTree(String subkey)
       at DCLibrary.clsRegistry.DeleteKey(String lngRootKey, String strKey, Boolean bRecursive)
    --------------------------------------------------------
    ---- Library 2.0.14970.3408 ----
    Time: 17:49:38
    Location: DeleteKey
    Exception: ThrowArgumentException
    Error: Cannot delete a subkey tree because the subkey does not exist.
    Extra: HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Enum\Root\LEGACY_CTAC32K
    Trace:    at System.ThrowHelper.ThrowArgumentException(ExceptionResource resource)
       at Microsoft.Win32.RegistryKey.DeleteSubKeyTree(String subkey)
       at DCLibrary.clsRegistry.DeleteKey(String lngRootKey, String strKey, Boolean bRecursive)
    --------------------------------------------------------
    ---- Library 2.0.14970.3408 ----
    Time: 17:49:38
    Location: DeleteKey
    Exception: ThrowArgumentException
    Error: Cannot delete a subkey tree because the subkey does not exist.
    Extra: HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Enum\Root\LEGACY_CTPRXY2K
    Trace:    at System.ThrowHelper.ThrowArgumentException(ExceptionResource resource)
       at Microsoft.Win32.RegistryKey.DeleteSubKeyTree(String subkey)
       at DCLibrary.clsRegistry.DeleteKey(String lngRootKey, String strKey, Boolean bRecursive)
    --------------------------------------------------------
    ---- Library 2.0.14970.3408 ----
    Time: 17:49:38
    Location: DeleteKey
    Exception: ThrowArgumentException
    Error: Cannot delete a subkey tree because the subkey does not exist.
    Extra: HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Enum\Root\LEGACY_CTSFM2K
    Trace:    at System.ThrowHelper.ThrowArgumentException(ExceptionResource resource)
       at Microsoft.Win32.RegistryKey.DeleteSubKeyTree(String subkey)
       at DCLibrary.clsRegistry.DeleteKey(String lngRootKey, String strKey, Boolean bRecursive)
    --------------------------------------------------------
    
     
    Last edited: Jan 1, 2010
  12. Spike

    Spike Driver Cleaner Maker

    Joined:
    Jul 18, 2002
    Messages:
    2,044
    Likes Received:
    3
    Trophy Points:
    0
    Hi,

    thank you very much for that, because i think the subinacl is causing the problems on windows 7, will try to find a solution and update my program.
     
  13. Anarion

    Anarion New Member

    Joined:
    Jan 1, 2010
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    It definitely looks like that's the issue.
     
  14. flyingduck88

    flyingduck88 New Member

    Joined:
    Jan 14, 2010
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    I am having this problem also. I have v3.4.2.0. OS is windows 7 ultimate x64. I’m not sure how to find the older versions as mentioned in this post that are suggested. Any help or advice is welcome and appreciated. Thanks
     
  15. Spike

    Spike Driver Cleaner Maker

    Joined:
    Jul 18, 2002
    Messages:
    2,044
    Likes Received:
    3
    Trophy Points:
    0
    Hi,

    to find the older version use the link in the email to download that. It is reverted back to the older version.
     
  16. flyingduck88

    flyingduck88 New Member

    Joined:
    Jan 14, 2010
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0

    Thanks for the quick reply Spike. I sent you a PM.
     
  17. flyingduck88

    flyingduck88 New Member

    Joined:
    Jan 14, 2010
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    Any word as to when this issue will be fixed? I am not able to download the older version. The link in my email says that I have exceeded my download limit???
    Spike, I sent you a PM but have not heard back yet.
    Any advice is welcome.
     
  18. Spike

    Spike Driver Cleaner Maker

    Joined:
    Jul 18, 2002
    Messages:
    2,044
    Likes Received:
    3
    Trophy Points:
    0
    Hi,

    i pmed you back but if you can pm me the email address used then i can reset the download count. Did you try what i suggested in my email?

    Try deleting the subinacl.exe from the Driver Cleaner.NET installation directory and see if the program works then. I heard that that file could give problems in windows 7.
     
  19. Erroneus

    Erroneus Get off my lawn!

    Joined:
    Aug 25, 2002
    Messages:
    13,727
    Likes Received:
    101
    Trophy Points:
    103
    So 3.4.0.0 works fine with Windows 7 64bit? Or when can we see a version "certified" for 7?
     
  20. BizSAR

    BizSAR New Member

    Joined:
    Oct 21, 2003
    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    0
    Wondering the same thing here. Still sitting on 3.4.0.0, and now it seems it is NOT cleaning files properly.

    In Windows 7 64-bit, after running the nVidia cleanings (all 7 of them) in Safe Mode, I'm seeing files left behind! In Program Files (x86) there is a NVIDIA folder with PhysX .dll files still there. Under users\all users there is a NVIDIA folder with some files in it as well. Those are just the places I've looked so far. If you want further details, I could run it all the way through again.

    I'm sadly forced to use another (free) product until this is fixed. I've spent an entire day trying to figure out why I was having video driver issues assuming DriverCleaner.net was doing its job. I've already bought DriverCleaner twice now (pre .net and .net, a long-time customer), and it feels like I've been had, especially since I have brought you business via recommendations to friends.
     

Share This Page

visited