Getting WASAPI to work in Titanium HD

Discussion in 'PAX Download - PCIe X-Fi Series' started by wein07, Jun 28, 2013.

  1. wein07

    wein07 New Member

    Joined:
    Nov 25, 2002
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    0
    Hi there, is there anyway for Tit HD to work in WASAPI mode? It does work in ASIO, however it just doesn't sound as good as WASAPI :tears:. Any help would be appreciated. Thanks! :)
     
  2. Tipstaff

    Tipstaff Well-Known Member

    Joined:
    Jul 22, 2002
    Messages:
    9,363
    Likes Received:
    962
    Trophy Points:
    123
    Which operating system do you have? And which application are you trying to use WASAPI with/in?
     
  3. wein07

    wein07 New Member

    Joined:
    Nov 25, 2002
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    0
    Hi there. I am using Win7 64bit. I am trying to get WASAPI working on Jriver media player. When i choose to play on WASAPI under it preferences. It doesn't run. Thanks in advance.
     
  4. Robert McClelland

    Robert McClelland I'm An Uncle for 2nd time Staff Member

    Joined:
    Jun 25, 2002
    Messages:
    15,327
    Likes Received:
    253
    Trophy Points:
    108
    You may want contact them. I don't know even know what wasapi is lol.
     
  5. Tipstaff

    Tipstaff Well-Known Member

    Joined:
    Jul 22, 2002
    Messages:
    9,363
    Likes Received:
    962
    Trophy Points:
    123
    If you have WASAPI selected under the Audio options (Tools | Options | Audio), the only thing I can think of is to double check the WASAPI settings.

    For one, change the "Device" listing from "Default" to the Creative card. That way you know for sure which card is being used (check Device Manager for any other audio listings, in particular ones related to your video card. If you are not using them, disable any HDMI audio listing that might be there). Next, make sure "Open device for exclusive access" is check on. This is needed because WASAPI requires exclusive access to the audio device. Lastly, change the "Bitdepth" option from "Auto" to "24-bit integer" or you could even try "24-bit integer (in a 32-bit package)".

    I would also disable any DSP settings, as well as making sure Bitstreaming is set to "None". At least until you can be sure WASAPI is working.
     
  6. wein07

    wein07 New Member

    Joined:
    Nov 25, 2002
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    0
    Hi thks for the suggestions. I finally got it to work by enabling the option

    Disable event style(required for older hardware)

    Didn't think that would apply to my newer soundcard like TitHD earlier on, but well, it worked :)


     
  7. Tipstaff

    Tipstaff Well-Known Member

    Joined:
    Jul 22, 2002
    Messages:
    9,363
    Likes Received:
    962
    Trophy Points:
    123
    Cool. Glad you got it working. :)
     

Share This Page

visited