Logitech x530 speaker problem

Discussion in '3-D Audio' started by auggie_doggie, Mar 19, 2007.

  1. auggie_doggie

    auggie_doggie New Member

    Joined:
    Mar 19, 2007
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    After spending a whole day trying to fix my 5.1 x530 logitech speakers to work on vita 32 ultimate i finally came across a site that has the drivers for the soundcard. I have one problem though, All the speakers seem to be working except the sentre speaker. Can somebody please guide me step by step as to where to connect the speakers in which jack??? I have a SBLIVE CT4830!! Also what settings do i need to change to get all the speakers to work???



    Thanks and I love the drivers,you saved me!!!

    Regards
    auggie_doggie
     
  2. Judas

    Judas Obvious Closet Brony Pony

    Joined:
    May 13, 2002
    Messages:
    38,833
    Likes Received:
    1,072
    Trophy Points:
    138
    unfortuneatly, it appears the sound blaster live card you have is completely unsupported within windows vista beyond 2 channel stereo mode.

    Perhaps 4 channel stereo is supported. But the only drivers available for it is provided by Microsoft which has very little support overall.

    On the back of the x-530s should be a little switch. This switch should have a 5.1 mode and a 2/4 stereo mode. Flip this switch over to 2/4 stereo mode so that the speakers will do whatever it can itself to enable center or "poorly simulated surround sound.


    The other option is to purchase a new Sound Card that is fully supported by vista
     
  3. auggie_doggie

    auggie_doggie New Member

    Joined:
    Mar 19, 2007
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    Can you please guide me as to where the switch is??? Alson after installing the drivers from this site th audio driver works fine in vista but the joystick shows incompatability!!
     
  4. Judas

    Judas Obvious Closet Brony Pony

    Joined:
    May 13, 2002
    Messages:
    38,833
    Likes Received:
    1,072
    Trophy Points:
    138
    hmm...

    i was sure there was a switch on the back of the subwoofer, near the sub woofers volume controll...



    Perhaps not..

    Have you read through the setup guide... sometimes they suggest which things to plug in or change depending on your audio source, read through it.
     

Share This Page

visited