OS X driver 1.3b0 (BETA)

Discussion in 'MAC OS X Driver' started by Eugene Gavrilov, Jul 24, 2009.

  1. infraction

    infraction New Member

    Joined:
    Sep 14, 2009
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    Sorry for being a bit n00b but is this driver only suppose to support 10k1 or 2 cards only?

    I'm only curious because I've just noticed mines a 10k8 (thought it was 10k2) according to audio midi setup and it works perfectly with this driver (bar inputs and midi of course).

    [​IMG]
     
  2. Eugene Gavrilov

    Eugene Gavrilov kX Project Lead Programmer and Coordinator

    Joined:
    Dec 7, 2002
    Messages:
    3,147
    Likes Received:
    9
    Trophy Points:
    48
    Îòâåò: OS X driver 1.3b0 (BETA)

    10k8 is a nickname for 10k2.5 chip found on audigy2 value and newer e-mu edsp cards
    it is almost the same as 10k2

    E.
     
  3. Eugene Gavrilov

    Eugene Gavrilov kX Project Lead Programmer and Coordinator

    Joined:
    Dec 7, 2002
    Messages:
    3,147
    Likes Received:
    9
    Trophy Points:
    48
    Îòâåò: OS X driver 1.3b0 (BETA)

    10k8 is a nickname for 10k2.5 chip found on audigy2 value and newer e-mu edsp cards
    it is almost the same as 10k2

    E.
     
  4. 7yatna

    7yatna New Member

    Joined:
    Sep 23, 2009
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    hey guys how are you

    am really seeking for an answer for a question driving me crazy


    is the creative labs EV 1938-4ch PCI Sound Card

    Supported in this driver ??

    and its device id is

    0x89381102

    and its name from osx86tools

    is


    Creative Labs Ectiva EV1938

    am really trying to make this thing work

    tell me how to do

    thank you all in advance
     
  5. 7yatna

    7yatna New Member

    Joined:
    Sep 23, 2009
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    Any Thing Guys ??

    ANy KX Audio Driver Leader ??

    am waitin
     
  6. Max M.

    Max M. h/h member-shmember

    Joined:
    Dec 7, 2002
    Messages:
    2,690
    Likes Received:
    9
    Trophy Points:
    63
    Îòâåò: OS X driver 1.3b0 (BETA)

    Well, in short, the "Creative 1938" (aka Ensoniq ES137x, aka Creative PCI64/128) is not compatible with kX - give it up.
    (You'll find the list of the compatible devices here)
     
  7. chekist

    chekist New Member

    Joined:
    Dec 15, 2009
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    Îòâåò: OS X driver 1.3b0 (BETA)

    Hallo every body.

    I cant play Quake 3 because sound in this game doesn't work. One smart man
    Fix for Mac OS X Quake 3 Sound Bug
    said that I should change format from 48000 Ghz to 41100 Ghz. Any ideas?
     
  8. freespirit

    freespirit New Member

    Joined:
    Jan 29, 2010
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    Will this work with a soundblaster Live 24 bit PCI card ?
    Thanks...
     
  9. Russ

    Russ Well-Known Member

    Joined:
    Jan 17, 2005
    Messages:
    5,722
    Likes Received:
    13
    Trophy Points:
    48
  10. Oxtie

    Oxtie Active Member

    Joined:
    May 14, 2008
    Messages:
    137
    Likes Received:
    0
    Trophy Points:
    26
  11. yybug

    yybug New Member

    Joined:
    Apr 23, 2010
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    1.11b is no work,1.3b0 is perfect! thx !
    iDeneb_v1.5.5
    U:E7400
    MOBO:p5Q-D
    nVIDIA GF9800gtx
    SBLIVE CT4620
    3Q boy~
     
  12. artixer

    artixer New Member

    Joined:
    Jun 4, 2010
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    THX~~~~~~~~~~~
     
  13. Naoru

    Naoru New Member

    Joined:
    Mar 30, 2010
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    Îòâåò: OS X driver 1.3b0 (BETA)

    SB0100, two different computers - nothing.
    works ok on 7+kX.

    òî ëè ëûæè íå åäóò...
     
  14. Eugene Gavrilov

    Eugene Gavrilov kX Project Lead Programmer and Coordinator

    Joined:
    Dec 7, 2002
    Messages:
    3,147
    Likes Received:
    9
    Trophy Points:
    48
    Îòâåò: OS X driver 1.3b0 (BETA)

    swap front and rear issue? :)

    E.
     
  15. naroito

    naroito New Member

    Joined:
    Apr 19, 2008
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    Great thanks E!
    You're the rock star
     
  16. dbvandyke

    dbvandyke New Member

    Joined:
    Dec 20, 2010
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    Hello, and thanks so much for your work!

    I've been using v1.11.b0 for a long time now on my Hachintosh (GA-P55A-UD4P v1.0 MB and Creative Audigy2 ZS). It was a true God send when I found it.

    One thing I always missed though was the ability to play out of all of my 7.1 speakers as I can in Windows. I was very excited when I saw there was a 1.3b0 version that would allow playing out of all speakers, so I was very eager to try it.

    For some reason however, it is not working, at all for me. :(

    I installed it, but it doesn't even show up as a device under Sound. I tried repairing permissions, restarting, but still not good. I even tried installing it again, but still nothing.

    Please tell me I am doing something wrong and how I might fix this.

    Thank you very much,

    Buztarovia!
     
  17. xtraa

    xtraa New Member

    Joined:
    Aug 18, 2008
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    Hi Eugene,

    thanks for all your drivers

    Could you set up a paypal account? I'd like to donate, but I don't like to give away my credit card number,.
     
  18. dbvandyke

    dbvandyke New Member

    Joined:
    Dec 20, 2010
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    Hello,

    I have been using v1.11b0 for a long time on my system with no problems. I have 7.1 surround speakers and would like to get them all working, so I installed v1.30b0, but it does not work at all.

    - Speaker icon at top is grayed out
    - Under Sound, "No output devices found"
    - Trying to open Audio MIDI Setup "quits unexpectedly".

    My system:
    Gigabyte GA-P55A-UD4P (v1.0)
    Intel Core i5 750
    OS X 10.6.6 (have been using 10.6.5 fine)
    Audigy2 ZS (installed in PCI slot #2)

    INSTALLATION

    - To install v1.3b0 I used the v1.11b0 uninstaller
    - Restarted
    - Installed v1.3b0, restarted
    - Once restarted, as described, NOTHING
    - Tried the 'edspctrl -reset' and all I got was:

    "Error initializing kX interace"
    (I think the message means interFace)

    KERNEL LOG WITH V1.11b0

    (because with v1.3b0 NOTHING shows up in the
    kernel log about kX AT ALL, so it's not loading for some
    reason)
    ======================


    Jan 15 11:31:26 Mammoths-iMac kernel[0]: kXAudioDevice[0xffffff800aadc600]::init: --- driver start-up, version 1.11b0
    Jan 15 11:31:26 Mammoths-iMac kernel[0]: kXAudioDevice[0xffffff800aadc600]::initHardware(0xffffff8009d6cf00)
    Jan 15 11:31:26 Mammoths-iMac kernel[0]: kXAudioDevice[0xffffff800aadc600]::initHardware: bus/dev/func: 9/2/0; device/subsys/chip: 00041102:20011102:04010004 - at port bf00
    Jan 15 11:31:26 Mammoths-iMac kernel[0]: kXAudioDevice[0xffffff800aadc600]::initHardware: I/O range @0x10 (0000bf00) mapped into 0000bf00 [up to 0000bf3f]
    Jan 15 11:31:26 Mammoths-iMac kernel[0]: kXAudioDevice [HAL] --- kX Software Abstraction Level Library init ---
    Jan 15 11:31:26 Mammoths-iMac kernel[0]: kX Audio Driver (Debug)
    Jan 15 11:31:26 Mammoths-iMac kernel[0]: version: 5.10.00.3550 - debug
    Jan 15 11:31:26 Mammoths-iMac kernel[0]: Copyright Eugene Gavrilov, 2001-2009. All rights reserved.
    Jan 15 11:31:26 Mammoths-iMac kernel[0]: Library Compiled Dec 25 2009, 04:36:32
    Jan 15 11:31:26 Mammoths-iMac kernel[0]: kXAudioDevice [HAL] Hw PCI device: dev: 41102 sub: 20011102 rev: 4
    Jan 15 11:31:26 Mammoths-iMac kernel[0]: PCI: resources: io:bf00 irq:0
    Jan 15 11:31:26 Mammoths-iMac kernel[0]: Hw PCI location: bus: 9h dev: 2h func: 0h (invalid under 98se)
    Jan 15 11:31:26 Mammoths-iMac kernel[0]: kXAudioDevice [HAL] card name: 'SB0360 10k2 [bf00]'
    Jan 15 11:31:26 Mammoths-iMac kernel[0]: kXAudioDevice [HAL] initializing kX HAL...
    Jan 15 11:31:26 Mammoths-iMac kernel[0]: kXAudioDevice [HAL] HW voices reset
    Jan 15 11:31:26 Mammoths-iMac kernel[0]: kXAudioDevice [HAL] p16v initialization
    Jan 15 11:31:26 Mammoths-iMac kernel[0]: kXAudioDevice [HAL] ac97 init
    Jan 15 11:31:26 Mammoths-iMac kernel[0]: kXAudioDevice [HAL] mpu init
    Jan 15 11:31:27 Mammoths-iMac kernel[0]: kXAudioDevice [HAL] db type: LiveBay1 db1 [11]
    Jan 15 11:31:27 Mammoths-iMac kernel[0]: kXAudioDevice [HAL] DSP initialization
    Jan 15 11:31:27 Mammoths-iMac kernel[0]: kXAudioDevice [HAL] Note: microcode EQ set to 'bypass' for OSX
    Jan 15 11:31:27 Mammoths-iMac kernel[0]: kXAudioDevice [HAL] Note: microcode ReverbLT disabled for OSX
    Jan 15 11:31:27 Mammoths-iMac kernel[0]: kXAudioDevice [HAL] Note: microcode Chorus disabled for OSX
    Jan 15 11:31:27 Mammoths-iMac kernel[0]: kXAudioDevice [HAL] Microcode compiled: Dec 25 2009 04:36:33; [Standard microcode]; with '10 Band EQ'NVDANV50HAL loaded and registered.
    Jan 15 11:31:27 Mammoths-iMac kernel[0]: kXAudioDevice [HAL] --- Library init completed ---
    Jan 15 11:31:27 Mammoths-iMac kernel[0]: kXAudioDevice [??] [ResetSettings]identified as RTL8168D/8111D
    Jan 15 11:31:27 Mammoths-iMac kernel[0]: identified as RTL8168D/8111D
    Jan 15 11:31:27 Mammoths-iMac kernel[0]: kXAudioDevice[0xffffff800aadc600]::createAudioEngine()
    Jan 15 11:31:27 Mammoths-iMac kernel[0]: kXAudioEngine[0xffffff800b911000]::init
    Jan 15 11:31:27 Mammoths-iMac kernel[0]: kXAudioEngine[0xffffff800b911000]::initHardware(0xffffff800aadc600)
    Jan 15 11:31:27 Mammoths-iMac kernel[0]: kXAudioDevice [HAL] asio: allocating voices 0,1; latency: -4800 -- 32-bit
    Jan 15 11:31:27 Mammoths-iMac kernel[0]: kXAudioDevice [HAL] asio: alloc_output(chn=2; hw=0)
    Jan 15 11:31:27 Mammoths-iMac kernel[0]: kXAudioEngine[0xffffff800b911000]::peformFormatChange(0xffffff800aadcc00, 0xffffff805d172da0, 0)
    Jan 15 11:31:27 Mammoths-iMac kernel[0]: kXAudioDevice [HAL] asio: allocating voices 2,3; latency: -4800 -- 32-bit
    Jan 15 11:31:27 Mammoths-iMac kernel[0]: kXAudioDevice [HAL] asio: alloc_output(chn=3; hw=2)
    Jan 15 11:31:27 Mammoths-iMac kernel[0]: kXAudioEngine[0xffffff800b911000]::peformFormatChange(0xffffff800accb000, 0xffffff805d172da0, 0)
    Jan 15 11:31:27 Mammoths-iMac kernel[0]: kXAudioDevice [HAL] asio: allocating voices 4,5; latency: -4800 -- 32-bit
    Jan 15 11:31:27 Mammoths-iMac kernel[0]: kXAudioDevice [HAL] asio: alloc_output(chn=6; hw=4)
    Jan 15 11:31:27 Mammoths-iMac kernel[0]: kXAudioEngine[0xffffff800b911000]::peformFormatChange(0xffffff800abc4e00, 0xffffff805d172da0, 0)
    Jan 15 11:31:27 Mammoths-iMac kernel[0]: kXAudioDevice [HAL] asio: allocating voices 6,7; latency: -4800 -- 32-bit
    Jan 15 11:31:27 Mammoths-iMac kernel[0]: kXAudioDevice [HAL] asio: alloc_output(chn=7; hw=6)
    Jan 15 11:31:27 Mammoths-iMac kernel[0]: kXAudioEngine[0xffffff800b911000]::peformFormatChange(0xffffff800ad0fe00, 0xffffff805d172da0, 0)
    Jan 15 11:31:27 Mammoths-iMac kernel[0]: kXAudioDevice [HAL] asio: allocating voices 8,9; latency: -4800 -- 32-bit
    Jan 15 11:31:27 Mammoths-iMac kernel[0]: kXAudioDevice [HAL] asio: alloc_output(chn=4; hw=8)
    Jan 15 11:31:27 Mammoths-iMac kernel[0]: kXAudioEngine[0xffffff800b911000]::peformFormatChange(0xffffff800ad0f800, 0xffffff805d172da0, 0)
    Jan 15 11:31:27 Mammoths-iMac kernel[0]: kXAudioDevice [HAL] asio: allocating voices 10,11; latency: -4800 -- 32-bit
    Jan 15 11:31:27 Mammoths-iMac kernel[0]: kXAudioDevice [HAL] asio: alloc_output(chn=5; hw=10)
    Jan 15 11:31:27 Mammoths-iMac kernel[0]: kXAudioEngine[0xffffff800b911000]::peformFormatChange(0xffffff800a517800, 0xffffff805d172da0, 0)
    Jan 15 11:31:27 Mammoths-iMac kernel[0]: kXAudioDevice [HAL] asio: allocating voices 12,13; latency: -4800 -- 32-bit
    Jan 15 11:31:27 Mammoths-iMac kernel[0]: kXAudioDevice [HAL] asio: alloc_output(chn=8; hw=12)
    Jan 15 11:31:27 Mammoths-iMac kernel[0]: kXAudioEngine[0xffffff800b911000]::peformFormatChange(0xffffff800ad0f200, 0xffffff805d172da0, 0)
    Jan 15 11:31:27 Mammoths-iMac kernel[0]: kXAudioDevice [HAL] asio: allocating voices 14,15; latency: -4800 -- 32-bit
    Jan 15 11:31:27 Mammoths-iMac kernel[0]: kXAudioDevice [HAL] asio: alloc_output(chn=9; hw=14)
    Jan 15 11:31:27 Mammoths-iMac kernel[0]: kXAudioEngine[0xffffff800b911000]::peformFormatChange(0xffffff800ad0f000, 0xffffff805d172da0, 0)
    Jan 15 11:31:27 Mammoths-iMac kernel[0]: DSMOS has arrived
    Jan 15 11:31:27 Mammoths-iMac kernel[0]: com_chucko_RealtekR1000: Ethernet address 6c:f0:49:5e:99:82
    Jan 15 11:31:27 Mammoths-iMac kernel[0]: com_chucko_RealtekR1000: Ethernet address 6c:f0:49:5e:99:c3
    Jan 15 11:31:31 Mammoths-iMac kernel[0]: kXAudioDevice[0xffffff800aadc600]::volumeChanged(0xffffff800aba6000, 65535, 53247): chn: 0 -> 98000000; 10 (none)
    Jan 15 11:31:31 Mammoths-iMac kernel[0]: kXAudioDevice[0xffffff800aadc600]::volumeChanged(0xffffff800aba6300, 65535, 0): chn: 1 -> 0; 10 (out0vol)
    Jan 15 11:31:31 Mammoths-iMac kernel[0]: kXAudioDevice[0xffffff800aadc600]::volumeChanged(0xffffff800aba6700, 65535, 0): chn: 2 -> 0; 10 (out1vol)
    Jan 15 11:31:31 Mammoths-iMac kernel[0]: kXAudioDevice[0xffffff800aadc600]::volumeChanged(0xffffff800aba1000, 65535, 48134): chn: 7 -> 1780e000; 10 (out30vol)
    Jan 15 11:31:31 Mammoths-iMac kernel[0]: kXAudioDevice[0xffffff800aadc600]::volumeChanged(0xffffff800aba1200, 65535, 49038): chn: 8 -> 17f1e000; 10 (out31vol)
    Jan 15 11:31:31 Mammoths-iMac kernel[0]: kXAudioEngine[0xffffff800b911000]::peformFormatChange(0xffffff800aadcc00, 0xffffff805cc53c40, 0)
    Jan 15 11:31:31 Mammoths-iMac kernel[0]: kXAudioEngine[0xffffff800b911000]::peformFormatChange(0xffffff800accb000, 0xffffff805cc53c40, 0)
    Jan 15 11:31:31 Mammoths-iMac kernel[0]: kXAudioEngine[0xffffff800b911000]::peformFormatChange(0xffffff800abc4e00, 0xffffff805cc53c40, 0)
    Jan 15 11:31:31 Mammoths-iMac kernel[0]: kXAudioEngine[0xffffff800b911000]::peformFormatChange(0xffffff800ad0fe00, 0xffffff805cc53c40, 0)
    Jan 15 11:31:31 Mammoths-iMac kernel[0]: kXAudioEngine[0xffffff800b911000]::peformFormatChange(0xffffff800ad0f800, 0xffffff805cc53c40, 0)
    Jan 15 11:31:31 Mammoths-iMac kernel[0]: kXAudioEngine[0xffffff800b911000]::peformFormatChange(0xffffff800a517800, 0xffffff805cc53c40, 0)
    Jan 15 11:31:31 Mammoths-iMac kernel[0]: kXAudioEngine[0xffffff800b911000]::peformFormatChange(0xffffff800ad0f200, 0xffffff805cc53c40, 0)
    Jan 15 11:31:31 Mammoths-iMac kernel[0]: kXAudioEngine[0xffffff800b911000]::peformFormatChange(0xffffff800ad0f000, 0xffffff805cc53c40, 0)
    Jan 15 11:31:45 Mammoths-iMac kernel[0]: NTFS driver 3.3 [Flags: R/W].
    Jan 15 11:31:45 Mammoths-iMac kernel[0]: NTFS volume name , version 3.1.
    Jan 15 11:31:47 Mammoths-iMac kernel[0]: kXAudioDevice[0xffffff800aadc600]::volumeChanged(0xffffff800aba6000, 53247, 57343): chn: 0 -> 90000000; 10 (none)
    Jan 15 11:31:47 Mammoths-iMac kernel[0]: kXAudioDevice[0xffffff800aadc600]::volumeChanged(0xffffff800aba6000, 57343, 61439): chn: 0 -> 88000000; 10 (none)
    Jan 15 11:31:47 Mammoths-iMac kernel[0]: kXAudioDevice[0xffffff800aadc600]::volumeChanged(0xffffff800aba6000, 61439, 65535): chn: 0 -> 80000000; 10 (none)
    Jan 15 11:31:47 Mammoths-iMac kernel[0]: kXAudioDevice[0xffffff800aadc600]::volumeChanged(0xffffff800aba6000, 65535, 61439): chn: 0 -> 88000000; 10 (none)
    Jan 15 11:31:47 Mammoths-iMac kernel[0]: kXAudioDevice[0xffffff800aadc600]::volumeChanged(0xffffff800aba6000, 61439, 57343): chn: 0 -> 90000000; 10 (none)
    Jan 15 11:31:47 Mammoths-iMac kernel[0]: kXAudioDevice[0xffffff800aadc600]::volumeChanged(0xffffff800aba6000, 57343, 53247): chn: 0 -> 98000000; 10 (none)
    Jan 15 11:31:47 Mammoths-iMac kernel[0]: kXAudioDevice[0xffffff800aadc600]::volumeChanged(0xffffff800aba6000, 53247, 49151): chn: 0 -> a0000000; 10 (none)
    Jan 15 11:31:48 Mammoths-iMac kernel[0]: kXAudioDevice[0xffffff800aadc600]::volumeChanged(0xffffff800aba6000, 49151, 53247): chn: 0 -> 98000000; 10 (none)
    Jan 15 11:31:48 Mammoths-iMac kernel[0]: kXAudioDevice[0xffffff800aadc600]::volumeChanged(0xffffff800aba6000, 53247, 57343): chn: 0 -> 90000000; 10 (none)
    Jan 15 11:31:49 Mammoths-iMac kernel[0]: kXAudioDevice[0xffffff800aadc600]::volumeChanged(0xffffff800aba6000, 57343, 53247): chn: 0 -> 98000000; 10 (none)
    Jan 15 11:33:38 Mammoths-iMac kernel[0]: kXAudioEngine[0xffffff800b911000]::stop(0xffffff800aadc600) -
    Jan 15 11:33:38 Mammoths-iMac kernel[0]: kXAudioEngine[0xffffff800b911000]::free_all() -
    Jan 15 11:33:38 Mammoths-iMac kernel[0]: kXAudioEngine[0xffffff800b911000]::free_all() - dereference iKX interface
    Jan 15 11:33:38 Mammoths-iMac kernel[0]: kXAudioDevice[0xffffff800aadc600]::stop: interrupts disabled
    Jan 15 11:33:38 Mammoths-iMac kernel[0]: kXAudioDevice[0xffffff800aadc600]::free()
    Jan 15 11:33:38 Mammoths-iMac kernel[0]: kXAudioDevice[0xffffff800aadc600]::free_all() - close iKX interface
    Jan 15 11:33:38 Mammoths-iMac kernel[0]: kXAudioEngine[0xffffff800b911000]::free()
    Jan 15 11:33:38 Mammoths-iMac kernel[0]: kXAudioEngine[0xffffff800b911000]::free_all() -
    Jan 15 11:33:38 Mammoths-iMac kernel[0]: kXAudioEngine[0xffffff800b911000]::free_all() - iKX interface already closed
    Jan 15 11:33:38 Mammoths-iMac kernel[0]: kXAudioDevice [ERROR] error in bufmgr_close [invalid blocks found]
    Jan 15 11:33:38 Mammoths-iMac kernel[0]: kXAudioDevice [HAL] --- Library done ---
    Jan 15 11:33:39 Mammoths-iMac kernel[0]: Kext com.kXProject.driver.kXAudioDriver not found for unload request.
     
  19. Shane83

    Shane83 New Member

    Joined:
    Jan 16, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    Which the latest release? kX Driver for OS X 1.11b0 or kX Driver for OS X 1.3b0 ??
     
  20. sammcj

    sammcj New Member

    Joined:
    Feb 5, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    Hi,

    Thank you for all your hard work.
    Is there any way to get the mic input working with the Audigy 2?
     

Share This Page

visited