Realtek/Soundmax Modds + SB X-fi MB 1.2

Discussion in 'PAX Drivers' started by -Alexa-, Apr 9, 2011.

  1. wolkaz

    wolkaz New Member

    Joined:
    May 12, 2011
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    0
    Is it possible to install this xfi mod on my pc?
    motherboard: Gigabyte GA-EP43-DS3LR,
    audio: Realtek ALC888 High Definition Audio
    OS: WIN 7 64bit
    I was trying all day to instal it but when I try to start creative console lausher it writes "there are no supported audio diveces. I cant understand what is wrong.
    Activation I think was sucsessful.
    C:\ProgramData\Creative\SoftwareLock\CTD1JXF23A.kg a <- I got this file in there.
    Hardware Id:
    HDAUDIO\FUNC_01&VEN_10EC&DEV_0888&SUBSYS_1458A002&REV_1000
    HDAUDIO\FUNC_01&VEN_10EC&DEV_0888&SUBSYS_1458A002

    Please help me :]
     
  2. -Alexa-

    -Alexa- New Member

    Joined:
    Jan 30, 2011
    Messages:
    38
    Likes Received:
    2
    Trophy Points:
    0
    1.uninstall realtek and creative software and restart.
    2.Install Realtek modded driver and restart
    3.When u run ceative software installation select english language
    4.Activate it.
     
  3. wolkaz

    wolkaz New Member

    Joined:
    May 12, 2011
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    0
    I was doing it step by step, but its not working...
    [​IMG]

    Whats wrong?
     
  4. -Alexa-

    -Alexa- New Member

    Joined:
    Jan 30, 2011
    Messages:
    38
    Likes Received:
    2
    Trophy Points:
    0
    Did you try manual update of driver?
     
  5. wolkaz

    wolkaz New Member

    Joined:
    May 12, 2011
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    0
    yes and when i try to update manualy it say that drivers is up to date, but its not... I cant understand whats wrong.
     
  6. -Alexa-

    -Alexa- New Member

    Joined:
    Jan 30, 2011
    Messages:
    38
    Likes Received:
    2
    Trophy Points:
    0
    Ok.. i will update the driver to 2.60 later. Remove that Realtek and Creative software.
     
  7. wolkaz

    wolkaz New Member

    Joined:
    May 12, 2011
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    0
    Okey thanks for help
     
  8. Les^P@ul

    Les^[email protected] New Member

    Joined:
    Jun 22, 2009
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    0
    Runs flawlessly on my ASrock 890GX Extreme 4 R2.0 (ALC 892) + Win 7 x64 after proper activating! But i must say THX TruStudio Pro software included with my board a bit better than MB 1.2.

    humm, why I only got SPEAKERS, EAX, EQ, & VOLUME? No crystalizer, cmss3D, etc. in creative audio console? one more thing Alexa :rolleyes:, about activation; do i have to use activation included with Realtek 2.59 rar or one from rapid link given?

    thnx again :p
     
    Last edited: May 13, 2011
  9. johnsmith1

    johnsmith1 New Member

    Joined:
    Feb 3, 2011
    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    0
    Quick question; can the "Creative Software AutoUpdate" be used to update various modules that are offered, or will doing so break the activation?

    After successfully installing/activating SB X-fi MB 1.2 with RealTek 2.59 on my Asus G73JH following the info in this thread (thanks!), the AutoUpdate is showing a few things marked as "Critical," such as "Creative Sound Blaster X-Fi MB 1.00.10"... I didn't want to update them yet until I know that it won't break the activation (I used the "Activation2" method)...

    Last question: For later versions of the RealTek drivers (like the current 2.60, and in the future), will we have to check back here and only install modded drivers, or is it possible to update normally without breaking the X-Fi MB activation, or without encountering the "no supported hardware" error?

    Thanks!
     
  10. -Alexa-

    -Alexa- New Member

    Joined:
    Jan 30, 2011
    Messages:
    38
    Likes Received:
    2
    Trophy Points:
    0
    Use activation from rapid share link,but before download it disable antivirus.
     
  11. -Alexa-

    -Alexa- New Member

    Joined:
    Jan 30, 2011
    Messages:
    38
    Likes Received:
    2
    Trophy Points:
    0
    That update can't break activation.
    Once when you activate x-fi software,activation remains to the next installation of OS.
    I will post update for Realtek driver for 10 minutes.If u want to install this new driver you must uninstall previous 2.59 driver and creative software and restart,zand the install 2.60 driver and after reboot creative software.You don't to activate it second time.:)
     
  12. -Alexa-

    -Alexa- New Member

    Joined:
    Jan 30, 2011
    Messages:
    38
    Likes Received:
    2
    Trophy Points:
    0
    Realtek driver is updated to 2.60.
     
  13. Les^P@ul

    Les^[email protected] New Member

    Joined:
    Jun 22, 2009
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    0
    yeap, i did the activation from rapid link... but i only get EQ, Audio Console, Volume, & Speaker Setup. No Crystalizer, CMSS3D, etc... :confused:
     
  14. -Alexa-

    -Alexa- New Member

    Joined:
    Jan 30, 2011
    Messages:
    38
    Likes Received:
    2
    Trophy Points:
    0
    That probably because your motherboard support thx tru studio.I will try in next version of x-fi software to add thx tru studio.:)
     
  15. wolkaz

    wolkaz New Member

    Joined:
    May 12, 2011
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    0
  16. -Alexa-

    -Alexa- New Member

    Joined:
    Jan 30, 2011
    Messages:
    38
    Likes Received:
    2
    Trophy Points:
    0
    This is 2.59 driver.I realy don't know what is problem.Did you try fresh install of windows?:confused:
     
  17. wolkaz

    wolkaz New Member

    Joined:
    May 12, 2011
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    0
    No this is 2.54 and I downloaded it from my motherboard website, all other realtek new and old versions dont work.
     
  18. mite_jan

    mite_jan New Member

    Joined:
    May 13, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    okay so i have registered only to say thanks a lot to Alexa and tell you what i did

    i have a G73JH which have a Realtek HD audio
    i have been using the stock Sound blaster audigy which had some options to adjust the sound but not like the X-fi package (and i didn't had any problems installing it ...no modded drivers needed)

    i am a member in notebookreview and there was a thread long time ago about X-fi package 1.1 +2.48 Realtek drivers (modded by Alexa) and a lot of people were complaining that couldn't install the X-fi package .... and there were some that can't install it after fresh Clean OS

    then couple days ago some guy posted a link which was leading right here (X-fi 1.2 +2.59 Realtek) and i decided to try it out

    and i did all the same like in the instructions but that didn't worked....then i tryed the 1.3 package and other realtek drivers posted on the second page ... that didn't worked too
    tried also with the old 2.48 drivers +X-fi 1.1 but no success

    i have waste a lot of time believe me to get this thing working (what a nightmare)
    i have made thousands of uninstalls reinstalls , restarts cleaned the registry manually for every "creative" and "realtek" entry but no sucess

    here comes the good part
    actually i can't tell what i did so the X-fi package recognise my realtek driver but i can tell you what i did last

    i have put my OS to CLEAN STATE MODE (that means that i didn't formated and installed os but made it like that)
    to put OS in CLEAN STATE MODE you need to open msconfig and select under startup selection SELECTIVE STARTUP and under services click hide microsoft services and then disable all
    also disable all the startup programs
    then i have installed driver sweeper v3.0 (i think this made the trick but i am not sure)
    and i have sweeped all the creative and realtek crap
    tried this package 2.59 + creative X-fi 1.2 but still coudlnt get it working althought when i oppened creative console it didn't sayed that my audio device is not recognised do i want to choose another sound device (something like that) which gave me before so i knew something was changed
    then i have uninstalled the creative and realtek and driver sweeped and tried the 2.48 +creative 1.1 and activated it , here is the link Creative X-Fi MB for your G73 (Realtek HD 2.48)
    and boom the software was working ....then what i did i have installed X-fi 1.2 on top of it and after that installed 2.59 modded drivers ....everything works perfectly now

    so for all of you who can't get it working i suggest installing driver sweeper latest version and also you can try the clean state mode method

    and after that if you can't get it worked try with the 2.48 drivers (for me that's how it worked)

    sorry about the long post

    p.s @ ALEXA i don't think that if you want to install the 2.60 modded drivers we need to uninstall the creative software too but just the realtek drivers
     
  19. Les^P@ul

    Les^[email protected] New Member

    Joined:
    Jun 22, 2009
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    0
    that's true that thx trustudio supported by my board. yeah2 combine them. thx trustudio has a great crystalizer, smart volume, and surrounder. maybe it would come with even greater audio quality if combined with xfi softwares.

    thnx for your consideration alexa :)
     
  20. atomizer123

    atomizer123 New Member

    Joined:
    May 7, 2011
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    I installed 2.60 drivers (after uninstalling the previous 2.59 drivers and without uninstalling creative software previously installed) and it is working just fine for me.. is it really essential to actually uninstall and reinstall creative software every time a realtek driver update (and the mod by Alexa) is released?
     

Share This Page

visited