Running OpenGL on Radeon X2300

Discussion in 'AMD Graphics Cards' started by megaDude, Sep 1, 2009.

  1. megaDude

    megaDude New Member

    Joined:
    Sep 1, 2009
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    Hello everyone, I would like to wish myself welcome to this community.

    About 2 years ago I bought a asus laptop(running Vista, which i hate) with the ATI Mobility Radeon x2300 graphics cards, which unebknownst to me, did not support OpenGl, so i was quite shocked and annoyed to find out that my Epsx emulator could not run properly because the driver I was currently using required OpenGl(i got hold of a number of D3D drivers now though, so now I can run my mega sweet wipEout) and that the process of acquiring a driver for said graphics card that does support OpenGl seems impossible, since the ATI site just tells me to go to asus.com to look for drivers, which are not there in the first place. So I gave it up, I did quite nicely without openGl support at that time, but as of tommorow I am going to read a computer graphics course, and of course the API the teacher choose to teach has to be OpenGl(is api the right term for nominating libraries?) so here I am again, totaly stuck on trying to find myself that elusive driver. It seems that it is possible though:

    ati mobility radeon x2300 benchmark

    As you can see, there are clearly one user that somehow got openGl running on its x2300. I WANNA OpenGl TOO!

    So I thought I would ask you guys here, what can I do to get my x2300 openGl compatible? I was thinking of downloading the nifty feature you provide(AMM) and try maybe an older driver or something along those lines, but I am not very suave regarding this kind of buisness, so I would really apreaciate if someone provided me with some nice tips or guides on this matter.

    Super thank you for your time.

    BTW, i got Gore Riders on diablo 2, if someone help me out of this %ยค/&% pickle(seriously I am so bloody angry right now, I just want to get down and cracking with my C, but instead im stuck browsing the internet for a driver that afaik does not even exist!) i'll gladly throw out those to the person that helped me(if you dont play diablo 2 you will just have to take my word for it that they are really cool(if you dont play diablo 2, do)).
     
    Last edited: Sep 2, 2009
  2. skychimp

    skychimp New Member

    Joined:
    Sep 13, 2009
    Messages:
    28
    Likes Received:
    1
    Trophy Points:
    0
    Last edited: Sep 17, 2009
  3. Nachbrenner

    Nachbrenner New Member

    Joined:
    Aug 29, 2006
    Messages:
    80
    Likes Received:
    3
    Trophy Points:
    0
    In a 64 bit OS everything must be done twice.

    Put a copy of that key in the Wow6432Node
     
  4. tgorecki

    tgorecki New Member

    Joined:
    May 4, 2011
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    Hi

    I have an ATI Radeon Mobility X2300 graphics card in my ASUS F3JR laptop.

    I am having an issue where the driver does not give me OpenGL support. It says 'Open GL Version Not Available' in the Catalyst Control Center and an application I am using which requires OpenGL support tells me that OpenGL support is not available.

    I have installed the latest driver available from ASUS' website and this does not help.

    1. What do you think is the best way to resolve this issue?
    2. Should I try using the Mobility Modder software to install a legacy driver?
    3. Which driver should I try to install? ATI Catalyst? Legacy Display Driver OR ATI Catalyst? Display Driver ?
    4. I am concerned that these two above drivers don't say they support the ATI Radeon Mobility X2300. Why is this and should I be concerned?

    Thank you for any help you can provide me with.
     
  5. shaman9876

    shaman9876 New Member

    Joined:
    Oct 15, 2002
    Messages:
    80
    Likes Received:
    3
    Trophy Points:
    0
    NVM wrong post
     

Share This Page

visited