Sound distortion

Discussion in 'MAC OS X Driver' started by malexer, Jan 21, 2010.

  1. malexer

    malexer New Member

    Joined:
    Jan 21, 2010
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    Hi!

    I have one very annoying error, googling and reading this forum didn't help :(
    So.
    I am listening to music, every thing OK. but after some time sound becoming distorted. Like it is some slowdown in processing (i.e. you try to play HD movie on 133 Mhz CPU ;)
    very often it is happening when I am changing source - play another track, or stopped itunes and started watching movie. but sometimes it can also happen in process :(
    after some reading I found short-term solution:
    when distortion happens, I stop playing sound and execute "kxctrl -reset"
    it will fix, but in some cases I have to execute it several times and may be wait some time.
    And as i said it is only short term solution (actually I created script for this command on desktop)

    I have tried it on clear installs of 10.5.7 and 10.5.8 by iDeneb
    Soundcard: SB0102 10k1 [9800]
    I have tried kx drivers 1.3b0 and 1.2b1
    kx drivers for windows is working perfect without any problems, so I think it is some kext/soft error, may by some kext conflict...

    I have found System.log record for the time when distortion started:

    Code:
    Jan 21 19:21:26 alexs-mac-pro kernel[0]: IOHIDSystem::relativePointerEventGated: Capping VBL time to 20000000 (was 20577955)
    Jan 21 19:21:56 alexs-mac-pro kernel[0]: kXUClient[0x7c23100]::initWithTask(type 0)
    Jan 21 19:21:56 alexs-mac-pro kernel[0]: kXUClient[0x7c23100]::start
    Jan 21 19:21:56 alexs-mac-pro kernel[0]: kXUClient[0x7c23100]::openUserClient()
    Jan 21 19:21:56 alexs-mac-pro kernel[0]: kXAudioDevice [HAL] db type: none [0]
    Jan 21 19:21:56 alexs-mac-pro kernel[0]: kXAudioDevice [HAL] kx_get_asio_position: shared access
    Jan 21 19:21:56: --- last message repeated 1 time ---
    Jan 21 19:21:56 alexs-mac-pro kernel[0]: kXAudioDevice [HAL] note: mutual ptr access
    Jan 21 19:21:56 alexs-mac-pro kernel[0]: kXAudioDevice [HAL] kx_get_asio_position: shared access
    Jan 21 19:21:56: --- last message repeated 3 times ---
    Jan 21 19:21:56 alexs-mac-pro kernel[0]: kXAudioDevice [HAL] note: mutual ptr access
    Jan 21 19:21:56 alexs-mac-pro kernel[0]: kXAudioDevice [HAL] kx_get_asio_position: shared access
    Jan 21 19:21:56: --- last message repeated 2 times ---
    Jan 21 19:21:56 alexs-mac-pro kernel[0]: kXAudioDevice [HAL] note: mutual ptr access
    Jan 21 19:21:56 alexs-mac-pro kernel[0]: kXAudioDevice [HAL] kx_get_asio_position: shared access
    Jan 21 19:21:56: --- last message repeated 1 time ---
    Jan 21 19:21:56 alexs-mac-pro kernel[0]: kXUClient[0x7c23100]::closeUserClient()
    Jan 21 19:21:56 alexs-mac-pro kernel[0]: kXUClient[0x7c23100]::stop
    Jan 21 19:22:28 alexs-mac-pro kernel[0]: IOAudioStream[0x56ad400]::clipIfNecessary() - Error: attempting to clip to a position more than one buffer ahead of last clip position (1348,36d)->(16fb,56d).
    Jan 21 19:22:28 alexs-mac-pro kernel[0]: IOAudioStream[0x56ad400]::clipIfNecessary() - adjusting clipped position to (16fb,36d)
    Jan 21 19:22:28 alexs-mac-pro kernel[0]: IOAudioStream[0x56ad300]::clipIfNecessary() - Error: attempting to clip to a position more than one buffer ahead of last clip position (1348,36d)->(16fb,56d).
    Jan 21 19:22:28 alexs-mac-pro kernel[0]: IOAudioStream[0x56ad300]::clipIfNecessary() - adjusting clipped position to (16fb,36d)
    Jan 21 19:22:28 alexs-mac-pro kernel[0]: IOAudioStream[0x56ad400]::clipIfNecessary() - Error: attempting to clip to a position more than one buffer ahead of last clip position (1349,994)->(16fb,b94).
    Jan 21 19:22:28 alexs-mac-pro kernel[0]: IOAudioStream[0x56ad400]::clipIfNecessary() - adjusting clipped position to (16fb,994)
    Jan 21 19:22:28 alexs-mac-pro kernel[0]: IOAudioStream[0x56ad300]::clipIfNecessary() - Error: attempting to clip to a position more than one buffer ahead of last clip position (1349,994)->(16fb,b94).
    Jan 21 19:22:28 alexs-mac-pro kernel[0]: IOAudioStream[0x56ad300]::clipIfNecessary() - adjusting clipped position to (16fb,994)
    .....
    
    and then repeating these last lines many, many times.

    So, I am looking for a solution to my problem.
    please help me anybody! :)

    Thanks!
     
    Last edited: Jan 23, 2010
  2. swillis11

    swillis11 New Member

    Joined:
    Nov 25, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    I am having this same problem, first on snow leopard and now on lion. Does anyone have a solution to this?

    I have a soundblaster audigy 2 ZS.
     
  3. kimiko

    kimiko New Member

    Joined:
    Jan 10, 2012
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    I am having this same problem too, on leopard and sblive value. I can see there is no answer to our questions... ¿Is this project still alive? :rolleyes:
     
  4. Eugene Gavrilov

    Eugene Gavrilov kX Project Lead Programmer and Coordinator

    Joined:
    Dec 7, 2002
    Messages:
    3,147
    Likes Received:
    9
    Trophy Points:
    48
    Îòâåò: Sound distortion

    it is quite hard to find the reason for the issue: it seems the audio engine gets out of sync due to some problem. no workaround available at the moment, sorry

    yes, the project is sort of alive :) in the hearts of our users
    I hope we have new OS X release soon (probably in May) with recording support

    E.
     
  5. EsTaF

    EsTaF New Member

    Joined:
    Nov 15, 2003
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    0
    Re: Îòâåò: Sound distortion

    while that moment would not come maybe do somebody know how decide that problem without restart system?
    some restarting kext module or other one/workaround.
     
    Last edited: May 7, 2012

Share This Page

visited