VMWare Player VMs Are Sloooow

Discussion in 'General Software Discussion' started by IvanV, Feb 6, 2020.

  1. IvanV

    IvanV HH Assassin Guild Member

    Joined:
    Dec 18, 2004
    Messages:
    10,628
    Likes Received:
    1,826
    Trophy Points:
    138
    Hi guys! I'm experiencing some insanely slow performance from a couple of VMs. I'm using VM Ware Workstation Player 15, although VMs were (probably) created in a slightly older version and I see drastically different performance between my desktop and laptops: both laptops run the VMs like total champs and the desktop is dragging its feet (there is noticeable lag between clicking on a cell in Excel and it becoming highlighted, for instance).

    The specs for the machines are as follows:
    Desktop: Core i7 4790K, 16GB RAM, Windows 7 Professional 64-bit
    Laptop 1: Core i7 4500U (2C/4T), 8GB RAM, Windows 8.1 Professional 64-bit
    Laptop 2: Core i7 9750H (6C/12T), 16GB RAM, Windows 10 Professional 64-bit

    The VMs are:
    Windows 7 Professional 32-bit 2GB RAM
    Windows 10 Professional 64-bit 4GB RAM.

    Is my desktop screwed because I have a K processor, as those lack some virtualization features? AFAIK, it shouldn't be, the features that are missing should not matter for this type of VMs (they matter only when using "bare metal" hypervisors) and tests show that hardware virtualization is indeed present and active.

    EDIT: CPU usage is not high, although vmware-vmx.exe does take some 13% of my CPU time doing nothing.
     
  2. IvanV

    IvanV HH Assassin Guild Member

    Joined:
    Dec 18, 2004
    Messages:
    10,628
    Likes Received:
    1,826
    Trophy Points:
    138
    As of a few days ago, the VM on my work laptop started to behave the same as the one on my home PC so I had to fix it, because, under certain scenarios, it was becoming unbearable.

    First, a correction, as things would really bog down, the CPU utilization would shoot up, so as a mitigation I added more CPU cores to the VM, but it was still awful!

    Logically, I started thinking what was it that I did to the VM, and I remembered that I updated VM Ware Tools. There was no downgrade option, so I outright uninstalled them. The VM came back to life! I thought about leaving it like that, but a lot of things didn't work without VM Ware Tools, including any resolution above 1152x846, so I managed to find an older version and installed just the necessary components and the SVGA driver. The things got bogged down again.

    I started googling and this time I had something to go on, so I stumbled upon a post that said that, as of WMWare Workstation Player 12, they changed the renderer and there was an option to force it to use the old one. So I wanted to try that, but first, I thought, since this VM was made with an older version, I might just see what's the highest virtual hardware version the new Player supported and try that. Bingo! Changing the virtualHW.version entry in the vmx file to "16" made everything fly!

    So, TL;DR the trick to ensure optimum performance was to change the virtualHW.version to the highest supported value (reference). Also, if the performance issue is related to the graphics subsystem, you may try turning D3D rendering, but disabling the DX11 option (can't find the article ATM). It helps on certain GPUs.
     
    Calliers likes this.

Share This Page

visited