Windows 10

Discussion in 'General Discussion' started by imperia, Apr 26, 2015.

  1. imperia

    imperia Active Member

    Joined:
    Dec 17, 2002
    Messages:
    197
    Likes Received:
    0
    Trophy Points:
    26
    Hello,

    Looks like the driver is still working in Windows 10 :)
     
  2. djvky

    djvky New Member

    Joined:
    Mar 27, 2015
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
  3. imperia

    imperia Active Member

    Joined:
    Dec 17, 2002
    Messages:
    197
    Likes Received:
    0
    Trophy Points:
    26
    Except I have issue with my Recording Mixer. If I record through it, my voice is robotic and slowed down.
    If I use Wave HQ for recording everything is fine.

    If I listen to my own voice, everything sounds fine inside the DSP. Maybe is something related to sample rate and/or bits or Windows itself.
     
  4. krafty

    krafty New Member

    Joined:
    Mar 4, 2011
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    Here's the steps I followed to install in Windows 10 Pro 64 bit:
    I downloaded version 3552 this time. I was using 3550-x64-full in Win 8.1 Pro Update 1.

    1) Ran the installer and followed all the steps.
    2) I had to go for the kxmixer.exe in the folder and make it "Compatible with Windows 7" and "Run as Administrator", as usual.
    3) Next time after reboot, I have the speaker showing up as working. I set Wave 2/3 as default channel.
    4) But even like this, I have to execute kxmixer.exe manually, for everything to work fine.

    However I am having two issues:

    - Even though kxmixer is set to autoload upon logon, it is not loading, in Task Manager.
    - It doesn't seem to remember last saved settings: I usually load up my own special configuration file and everything works, then.

    Any ideas to fix these issues?

    Thank you.
     
  5. krafty

    krafty New Member

    Joined:
    Mar 4, 2011
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    Hey guys, what's up.
    I did some investigation on what was going on and have some findings...

    You can notice in Task Manager, that kx Mixer has been enabled but "never measured".
    The current installation is placing this reference in the registry, with the following values:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run
    kX Mixer REG_SZ "C:\Windows\system32\kxmixer.exe" --startup
    • This is WRONG.
    But...
    If you change it to "C:\Program Files (x86)\kX Project\kxmixer.exe" --startup, or your actual path, it will not work. Even If you remove the --startup option. It will also not work.

    This is what is being seen in Task Manager. After removing this registry line, it will vanish from the Task Manager.

    Here's what you need to do
    (will only work if you have an administrator account).

    Open the Task Scheduler
    (don't confuse with Task Manager which I just was talking about). Execute the command taskschd.msc or if you prefer, you can go to Control Panel, Administrative Tools, and find Task Scheduler in the list. Click then, on top of that.

    Click on the folder Library for the Task Scheduler and you'll see that there are some tasks in there. Inside the task list area, right-click your mouse and select Create New Task. A modal window will pop up and you will just need to fill some values. In Name, give it a name "kX Mixer" (without quotes). Check the box "Execute with higher privileges", and select Configure to "Windows 7, Windows Server 2008 R2".

    On the second tab, Triggers, select New and chose On Log On, and leave Any user. Go for the third tab, Actions and choose New. Choose Start up a program, and point it to the kxmixer.exe executable. You can leave the rest as it is and click on OK. The task will be created. There is only one problem here though. Upon startup, it won't remember your settings, every time you reboot. So, here, I got muted zeroed sound, despite having it running after boot. More on next post...
     
    Last edited: Jan 8, 2016
  6. krafty

    krafty New Member

    Joined:
    Mar 4, 2011
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    So, here is the solution to make the settings permanent.

    On previous post, the part when you have to go to the Actions tab, you will edit it...
    Check your path to your kxmixer.exe executable. If you reached this point, like in the steps from previous post, everything is just fine.
    • Then, on Additional Arguments, just fill with "--startup" (without quotes).
    On next reboot, kx Mixer should load normally and play just fine your music files on Windows 10.
    I hope I contributed to improve and offer a workaround to the main issues.
     
  7. krafty

    krafty New Member

    Joined:
    Mar 4, 2011
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    I would like to add an additional instruction.
    When 3552 driver version installs, it installs two versions, 32 bit in "Program Files (x86)" and 64 bit in "Program Files"
    If you use the 64-bit executable "kmixer.exe" with the instructions above, you will be getting a warning and something not being recognized within the system (I didn't look too much on this, but I will try to figure this on my next post).
    If you use the 32-bit executable "kmixer.exe", with the instructions above, the warning will disappear upon logon.
     

Share This Page

visited